1. Are you ready for the Galaxy S20? Here is everything we know so far!

Can't instal apps!

Discussion in 'Android Devices' started by bertie11, Jan 30, 2021.

  1. bertie11

    bertie11 Newbie
    Thread Starter

    I use an Alcatel U5, Android 7.0. I've been trying to instal several different cleanup apps, like Smart Kit 360 and others.Either they just keep showing 'pending' or some will say they are installed but also show 'no Devices found'.

    Either way, I'm stuck, as I'm getting the same faults when trying to instal onto my Kindle Fire 7 (OK, different forum?)

    Any ideas please?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. puppykickr

    puppykickr Android Expert

    Settings
    Apps & notifications
    See all
    three dot menu in upper right
    Show system
    scroll to Google Play Services
    Storage
    Manage space
    Clear all data
    go back to the apps list
    select Google Play Store
    Storage
    Clear cache (NOT CLEAR DATA)

    Now try downloading again.

    If it still fails, try restarting the device, and then try downloading again.
     
  3. bertie11

    bertie11 Newbie
    Thread Starter

    Thank you puppykickr.

    I managed to fix it but in a different way. I'm not sure how I got there but I went into Google Play settings and found 'My Devices' which showed that the device I was looking to fix was unticked. It seemed to me that it was worth ticking that box and then I found that it worked!

    So I haven't tried your fix, which may well have fixed it anyway so thanks for the suggestion.
     

Alcatel U5 Forum

The Alcatel U5 release date was July 2017. Features and Specs include a 5.0" inch screen, 5MP camera, 1GB RAM, MT6737M processor, and 2050mAh battery.

July 2017
Release Date
0
Reviews
Loading...

Share This Page

Loading...