Root Can't Install Android Revolution 50.2 (latest) in Verizon M8


I'm trying to install the latest version of the ROM Android Revolution, which I found on this thread

My phone is Verizon
I downloaded the zip called ""
But although the installation process runs smoothly and says it worked perfectly... when the phone is rebooted I can't pass from the bootloader screen.

This is my bootloader screen

I've already tried Viper ROMs but I haven't been able to add apns to those so I changed to Skydragon... it works, a little unstable but the main con is no 4G for my carrier in Mexico (Movistar), then I read that with ARHD I could get 4G for another carrier(TELCEL), here in México... but I'm not able to install this ROM to test it...

Can someone help me figure this out?



I've been reading the last 60 pages(or so) in the ARHD thread in XDA, and for what I understand some people claim that they've been able to use it on verizon or sprint devices, althought others says that the ROM is not compatible with them... Anyway, I'm having some hope from some posts that claim that to use this ROM with Verizon you have to flash a compatible Verizon Kernel just after installing the ROM and before the first boot.

Here:, Einwod claims so.

But I have no idea where I can find that "verizon compatible kernel" and how to install it.

Any comments are really appreciated!!!

Last edited: