1. Are you ready for the Galaxy S20? Here is everything we know so far!

Cant install twrp recovery on my Samsung S3 neo. lost stock recovery too!

Discussion in 'Android Help' started by Amit Charan, Feb 2, 2016.

  1. Amit Charan

    Amit Charan Lurker
    Thread Starter

    Hi guys!
    So I rooted my Samsung galaxy S3 neo GT-I9300I with KingRoot.
    And then I was searching for methods to installl Twrp recovery for my device without using odin ( that seemed rocket science to ne then)
    I finally found this method on xda by Rox ( a senior developer for my device) which Im quoting below : 3rd method ( Terminal emulator - requires rooted device )

    1. Download recovery.img and transfer it to your phone ( i will use /sdcard but it is optional)
    2. Download Terminal Emulator from playstore
    3. Open Teminal emulator and type
    NOTE: It is VERY IMPORTANT to write this correctly because you are risking to hard brick your device if you mistype number, double check before pressing enter
    Code:
    su
    dd if=/sdcard/recovery.img of=/dev/block/mmcblk0p15
    or to be 100% sure you can write this, effect is same
    Code:
    su
    dd if=/sdcard/recovery.img of=/dev/block/platform/msm_sdcc.1/by-name/recovery
    Note: You can change path to recovery.img to your optional
    4. Now you have TWRP recovery on your device ( Boot with vol up + home + power

    Courtesy : rox from xda
    Link of method : http://forum.xda-developers.com/gal...overy-t-r-p-samsung-galaxy-s3-neo-gt-t2906840

    So when i rebooted my device to recovery it went to download mode ( odin mode) with message "could not normal boot " .
    Then i tried to boot it normally and yes it did.
    But now the problem is that I dont have any recovery on my mobile. I cant boot into recovery. If i try to boot in recovery thw phone directly goes to odin mode.
    After that I even tried flashing twrp by odin and also by flashify app . But nothing worked.
    Please guys help me get a recovery no matter if it is stock or custom.
    I just want a recovery for my phone atleast.
    Cause my phone gets stuck in a boot loop i wouldnt be able to save it without a recovery.
    Please guys help. Thanks in advance!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. James L

    James L Android Expert

    When you flashed the recovery with Odin, did you uncheck auto reboot?
    If you un check auto reboot and flash Twrp, once it says reset. Unplug the phone,pull the battery, reinsert it and leave the phone off. Then hold volume up, home and power and you should see Twrp.
     
  3. Amit Charan

    Amit Charan Lurker
    Thread Starter

    Tried that. But even that didnt work. Any other ideas?
     
  4. Jfalls63

    Jfalls63 Android Expert

    Where did you download TWRP? You can try getting the tar file from here and try again with Odin. Did the previous flash with Odin pass or fail?
    https://dl.twrp.me/s3ve3g/
     
Loading...

Share This Page

Loading...