1. Check out our companion app, Forums for Android! Download from Google Play

Root can't make/receive phone call after root but txt and internet works

Discussion in 'Android Devices' started by ccavery, Oct 16, 2011.

  1. ccavery

    ccavery New Member
    Thread Starter

    Jun 2, 2011
    Hey everyone,

    I just rooted my evo 4g running gingerbread 2.3.3 following ocnbrze's wonderful tutorial (using revolutionary.io and the superuser zip file)

    the first time I did it I didn't realize I had fastboot checked and the root didn't take. The HBOOT menu came up, but revolutionary didn't get to the stuff about flashing clockwork. I hate to admit this, but I think I poked through some of the HBOOT menues trying to get it to work, and I'm not really sure what I did. It ended up restarting my phone which went to the screen ocnbrze talks about when revolutionary fails to take (red exclamation point), but I rebooted my phone, turned off fastboot, and was able to root successfully.

    the problem is, now I can't make or receive phone calls. I can connect to the internet using 3G/4G and I can also still send and receive text messages

    when I try to make a phone call it acts as if it's starting the call (and the active call timer starts, as if it had dialed) but it never connects to anything and the call just ends after about 5 seconds. When I try to call myself from another phone it goes to voicemail after 1 or 2 rings (as if the phone were off) even though the phone is on and "actively connected"

    I've rebooted the phone several times, tried turning airplane mode on and off, and completely powered off the phone, removed the battery, and put it back in and tried again. all with no luck.

    I've also tried the solution posted in this thread (even though it's for evo 3D and describes a total loss of connectivity) but that didn't seem to help either

    any help or suggestions would be greatly appreciated. I'm totally baffled but really want to get this fixed :( Is there anything I could have done in HBOOT that would render me unable to make calls but still use internet/sms?

    UPDATE: The problem seems to have fixed itself. Maybe it was actually a problem with Sprint's network that just happened to coincide with when I was rooting my phone? Strange coincidence, but possible.

    I just kept trying to place a call over and over, and then eventually a call went through. I found that if I kept trying to call a number it would connect maybe 1 time in 10 or 20, then in a matter of minutes it went back to working every time like it should.



    Rxpert83 likes this.
  2. Rxpert83

    Rxpert83 Dr. Feelgood

    Aug 30, 2011
    Graduate Student
    Glad you got it figured out!

    And thanks for posting the info for anyone else that comes across this strange problem
    ccavery likes this.
  3. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    May 13, 2010
    being a flashaholic sponsor, helping others gettin
    los angeles
    one thing you can do is update your prl and profile. but glad it started working now.
    ccavery likes this.

Share This Page