1. Are you ready for the Galaxy S20? Here is everything we know so far!

can't mount evo to pc

Discussion in 'Android Devices' started by flyingmunkey, Jun 7, 2010.

  1. flyingmunkey

    flyingmunkey Lurker
    Thread Starter

    ok, so earlier today, i go to mount my evo as a disk drive to copy some files over and i'm no longer able to. when i plug in the usb to the pc (win7 ultimate x64), it starts to charge the phone, but i don't get the option in the notification panel to choose what i want it to do when i plug it in. i've check the phone settings and it's still supposed to ask each time it's plugged in. the sd card is recognized in astro, i even put it back in the hero just to make sure, and everything is there and working. i've tried on my pc (16 different usb slots) and my laptop (4 usb) and neither one will allow me to mount. any ideas on what this could be? thanks for any help!
     


  2. tvkg22

    tvkg22 Lurker

    same problem here...my pc makes the sound that a usb device has been connected but then just acts like nothing was connected and my Evo window asking me how to treat the connection disappears as well
     
  3. hlazar

    hlazar Lurker

    Sme here with win xp. I think the driver is missing.
     
  4. SprintFun

    SprintFun Android Expert

    Same for me :(
     
  5. MisterEd

    MisterEd Android Expert

    I had the same problem. After 2 hrs of going nuts it turned out to be the elcheapo cable I bought off eBay. Maybe you have bad cables?
     
  6. SprintFun

    SprintFun Android Expert

    I'm only using the one that came with the Evo, and when using it I still get a charge on the phone, I just can't do anything besides charging it.
     
    Ms2Classy4ya likes this.
  7. drbgotenks

    drbgotenks Newbie

    There are some other threads about this also.

    http://androidforums.com/support-troubleshooting-evo-4g/91268-unable-access-sd-card-pc.html

    I am having the same problem, but with the stock cable. It will work if you keep pressure on the plug in the usb outlet on the phone. I think it is a defect and I am going to get a replacement phone. It is probably just not sitting perfectly in the opening in the frame, but either way, I don't want to deal with it.

    I would suggest a replacement phone so you don't have to think about it any more.
     
  8. flyingmunkey

    flyingmunkey Lurker
    Thread Starter

    yeah, i don't even get the windows beep saying it knows something new has been plugged in, it just starts charging the phone. i'm using the stock cable, the new ones i ordered don't come in until later today or tomorrow maybe. i think i'm gonna go visit a sprint store and see if they can get it recognized with a different cable.
     
  9. SprintFun

    SprintFun Android Expert

    Well, I just plugged it into my work laptop (running Vista) and its working fine. Is it maybe a Win 7 issue?
     
  10. drbgotenks

    drbgotenks Newbie

    I have tried with Vista, Xp and 7, and none work for me. I'm not concerned, sprint has always been good to me about replacing devices.
     
  11. acm28

    acm28 Lurker

    This is my first post, I just have a week with my rooted HTC Hero and It's awesome!

    I just had this problem for the second time in this week, I don't remember what I did the first time but right now I just turned the phone off and then after that it worked just fine.

    An easy solution , in case anybody needs it in the future..... but this problem shouldn't be happening.
     
  12. superb

    superb Lurker

    This is happening to me today, first time i've experienced this. quite frustrating. I'm on Windows 7 x64
     
  13. autumnriver

    autumnriver Lurker

    Just got the phone, and thought I had this problem too. I'm running Windows 7 64-bit.

    Go to Settings (on the phone), choose Connect to PC and then look at "Default connection type." The default is "charge only." You can set it to "disk drive."

    After making this change I found the phone as the F drive on my PC.

    Hope this helps.

    BTW: I've had no luck with the Wifi connection to my PC via my home network. The phone says it's connected, but Windows can't see it on the network.
     
  14. tttallman

    tttallman Lurker

    I have Windows Vista and cannot see my HTC Evo when I plug it in using the USB cord. I tried all suggestions on this thread. Checked SETTINGS>CONNECT TO PC>DISK DRIVE. Turned Evo on and off. Tried different USB ports. AND the charging light is ON, meaning there is a good connection. How frustrating, I really want to transfer music and pictures. Anybody have any new ideas? I'd be very grateful.
     
  15. Mr. Ed

    Mr. Ed Extreme Android User

    So you have tried a different cable and usb ports...have you tried a different computer or tried a different phone on that computer? Is usb debugging enabled on your phone?
     
  16. jackgross

    jackgross Lurker

    I had the same problem. I simply turned the phone off (with it connected to the PC) and back on...my PC recognized the phone and initiated the sync process.
     
  17. I have had the exact same problem for weeks and it is still not resolved. I have seen the following suggestions online (none of which worked for me, but have worked for others):
    - Turn on USB Debugging
    - Turn OFF USB Debugging
    - Turn off, pull battery, reinsert and restart
    - Reseat SD Card
    - Try different computers, different operating systems
    - Try different cables (including the one that shipped with the phone)
    - Try holding in the cable with your hand in various positions

    I have tried all of these and NOTHING has worked. Last night I called HTC customer service and all they could recommend was doing a full factory reset.

    I have no idea what caused my phone to stop working correctly. I used to be able to plug in and mount as a drive easily. Now all it does it go to charge mode, I do not have any option to mount.

    Any help would be appreciated!
     
  18. adamf663

    adamf663 Lurker

    I got the same issue. Plugging in usb cable doesn't raise any notification that would permit me to change the usb mode. Setting default to disk drive doesn't help. Setting the checkbox to ask me doesn't work.
    Also: doesn't work on my home linux system either.

    Booted to recovery mode and selected mount usb and I was able to see the evo's sd card. This rules any possibility that it is a hardware or windows issue.
     
  19. Granite1

    Granite1 Zercron Encrusted Tweezer

    The card may be corrupted. Have you tried to take the card out of the phone and use a card reader?

    Try that and see if you can access the card. If not you may need to format the card. :(
     
  20. argedion

    argedion The TechnoFrog

    Another thing you can try (No Guarantees) but change the language from english to spanish and then change it back. This sometimes will allow the Dialog box for the USB to show up. Note You will have to do this every time your phone reboots. You can also look for automount on the market and try that.
     
  21. archangel007

    archangel007 Lurker

    Try downloading HTC Syc. It has a driver installation package that comes with it. If you don't want to keep Sync, you can uninstall it and the drivers will stay. Hope that helps.
     

HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date
0
Reviews
Loading...
Similar Threads - can't mount evo
  1. grameswan
    Replies:
    0
    Views:
    107
  2. androidBum
    Replies:
    6
    Views:
    218
  3. Joel Pietrangelo
    Replies:
    5
    Views:
    215
  4. pasinduvibahaliyanage
    Replies:
    12
    Views:
    399
  5. Madasa
    Replies:
    3
    Views:
    653
  6. ARAMP1
    Replies:
    2
    Views:
    304
  7. Chris2020
    Replies:
    4
    Views:
    255
  8. Ymelfilm
    Replies:
    4
    Views:
    178
  9. Lansselot
    Replies:
    11
    Views:
    8,293
  10. Afoyem
    Replies:
    2
    Views:
    2,546

Share This Page

Loading...