1. Download our Official Android App: Forums for Android!

Can't mount /system as RW on Xperia T3

Discussion in 'Android Rooting' started by Szmok, Aug 12, 2016.

  1. Szmok

    Szmok Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Aug 12, 2016

    Aug 12, 2016
    1
    0
    5
    So I recently rooted my Xperia T3 using KingRoot... It was successful, various root checkers didn't report any problems but I just can't delete any system apps, move, cut, anything. Was trying to do this with ES Root Explorer (it has option to make /system RW but it doesn't work), Root Explorer, even system apps removers. Titanium Backup also didn't make it.
    I tried using Total Commander and its remount function too. At last I tried to do this through terminal with "
    mount -o rw,remount -t ext4 /dev/block/platform/..." command and it just says "operation not permitted"

    As you can see I ran out of options (at least out of these I know). I'm still a noob so it's really possible that I'm doing something wrong.

    I'm using android 4.4.4, original from Sony.
    Thank you for your time!
     

    Advertisement

  2. scary alien

    scary alien not really so scary
    Moderator
    Rank:
     #9
    Points:
    2,138
    Posts:
    22,282
    Joined:
    Mar 5, 2010

    Mar 5, 2010
    22,282
    23,583
    2,138
    Male
    space alien ;)
    Indy
    Hello and welcome to our AndroidForums, @Szmok :).

    It sounds/looks like you've done your homework and more, trying all of the obvious and non-obvious ways to remount /system in read-write mode...

    I'm guessing you've got a locked bootloader or a kernel that has extra measures in-place to keep you from getting that filesystem/partition out of read-only mode :(.

    Not sure what else to suggest at this point...:thinking:
     

Share This Page

Loading...