Root Can't receive mobile calls on CM7.0.3.1

For some reason I can't receive mobile calls on my rooted CM7 Evo (rings once and goes to VM) . It accepts land line calls and has no problem outgoing calls/texts. I did a factory wipe on 7.0.1 and did a fresh install of and it still doesn't work. So I wiped and restored back to my stock froyo, updated profile, PRL, and it would receive again. Restored back to my CM7 backup and was back to no incoming. Any ideas?


Thread starter
ocnbrze said:
it could be a bad flash. I would try to wipe and re-flash cm7.0.3.1 or maybe re-download a new .zip file. it could also be a bad download.

When you came from 7.0.1 did you wipe cache, dalvik, and user data in recovery or did you just do a data reset?

Yes did a full wipe (Data/cache/dalvic) in Recovery and then flashed (was second time flashing due to the same issue).

Did a full wipe again last night and reflashed the same .zip. Once I singed in and installed GAPPS, I tried to call it again from another Cell Phone and it accepted the call.

So I only resorted "missing apps with data" in Titanium (instead of "missing apps + all system data") and then downloaded the newest version of Google Voice from Market.

Everything seams fine now... so must have just been something wrong in the system data that I restored last time in Titanium.

Thanks all for your help!