1. Are you ready for the Galaxy S20? Here is everything we know so far!

Can't reconnect to Wifi

Discussion in 'Android Devices' started by Shadowsoul, Dec 26, 2011.

  1. Shadowsoul

    Shadowsoul Lurker
    Thread Starter

    Hello,

    I'm new here, a noob with electronics. Had some problem with my a500 Wifi connection. It detects the Wifi networks but is unable to obtain the IP address even when it's right next to the router.

    My tablet can detect the Wifi networks as 'excellent', but as soon as I tap on it to connect, it'll drop to the 'poor' signal where it shows 'obtaining IP address...' repeatedly followed by 'disabled', preventing me from connecting to the internet. Then it'll goes back showing the 'excellent' signal again.

    I'm able to connect it to my router before, but after I came back from a Christmas trip, it stops working. I'm using the same router as before and my laptop has no problem connecting at all.

    It happen once before (last month) which I did a factory reset and it's able to work again. But resetting my tablet every month will probably cause a lot of problems, so I was wondering, does anyone has any idea on how to solve this?

    I'd be really grateful. Thanks.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. al2fast

    al2fast Member

    static ip.

    what security protocol you use on your router?
     
  3. Shadowsoul

    Shadowsoul Lurker
    Thread Starter

    WPA/WPA2 PSK

    By static ip, do you meant that I should change it to static IP? I'm using DHCP.

    Thanks.
     
  4. al2fast

    al2fast Member

    Same protocol I use on my router with no issues. Yes, by static IP I mean assigning a static IP address to your a500.

    You don't have to turn off the DHCP on your router. Say your router is setup for DHCP and it assigns IP addresses in the range of 192.168.1.2 through 192.168.1.50. Set your a500 address to 192.168.1.51. I would just recommend setting your IP address out of the DHCP range or on the high side of the DHCP range so that another device does not get assigned the same IP address that you give to your a500 or you will most definitely have communication problems then. Set your subnet mask to 255.255.255.0. Cannot remember if it asks for a default gateway or a DNS server, but if it does put in the address of your router for each of those, which in my example here would most likely be 192.168.1.1 which would be the address you'd punch into your browser to connect to it to manage it.

    Another thing that I have read since getting my a500 is that when some people have had problems similar to yours that resetting the tablet with the reset button 2x has solved their wireless connectivity issues. This does not wipe your data. I tried this on mine for the heck of it and it did not wipe any of my data.

    I've had my a500 for a little over 2 weeks now and I had some sporadic wifi dropping. I've assigned a static IP now for about 2 weeks and have not dropped wifi since. This is not quite the same problem you are running in to.

    Another thing I would try, probably the first because it is easy, would be to go into your wifi settings (with wifi on other wise manage networks may be grayed out, it is on my phone, a500 is at home now) and then manage networks on your a500 and tell it to forget your saved home network. Then turn your wifi off and back on and "re-discover" your home network and see if you cannot reconnect then.
     
    Shadowsoul likes this.
  5. Shadowsoul

    Shadowsoul Lurker
    Thread Starter

    Thank you so much!! It connects successfully after changing to static IP. :D

    Mind I ask? How did you reset the tablet without losing the data? I used the factory reset button(the one in 'setting' - privacy) previously and lost all my data. Thanks.
     
  6. al2fast

    al2fast Member

    there is a tiny button marked reset right next to the usb port, you will need something like a paperclip to press it. I have read that using that reset button tends to be only a temporary fix.

    Glad the static IP worked! I'm back on my tab now so I can't be so long winded. Forever got the Swype beta installed now and I can type a lot faster with this than thumbs keyboard!
     
  7. Shadowsoul

    Shadowsoul Lurker
    Thread Starter

    Gotta try that someday. Thanks a lot for the tips! :D
     
Loading...

Share This Page

Loading...