Root Can't root ace 2


Sorry if this question has already been answered or if i'm posting in the wrong section, i'm kind of new to these forums :)

Recently i bout an ace 2 and i was pretty satisfied with it. One day i decided to root it and followed this guide:

Everything worked fine and the phone was rooted. But i was dissapointed that i couldn't flash any roms because there wasn't any CWM for the ace 2 in the rom manager app. After a quick google search i found a custom kernel with CWM preinstalled here. Of course without thinking i flashed it and it worked. The next step was to install a rom. So i found the one i want and like the guide said, i did a factory reset with CWM before installing the rom and as soon as it rebooted i booted it into CWM again and flashed the rom the first time. The guide said to do it twice so i rebooted back to CWM and found and error saying:

E: failed to open /etc/recovery.fstab (I/O error)
E: unknown volume for path [/cache/recovery/command]
E: Can't mount /cache/revoery/command
etc and when i select install zip from sd card it says
E: can't mount /sdcard/

I tried formating and re-partitioning but it didn't work. I flashed the first "ready to root" kernel and installed the from stock recovery but super su said it couldn't find the su binaries and root-checker pro said that it couldn't locate the directory /system/bin/su
i checked for that directory in file manager and found that the su file was in a folder titled "xbin" instead of "bin". So i tried copying the files to the bin folder but wasn't able to do so because i didn't have wright permissions, only read. So i tried root explorer file manager and got the same error.

Finally i decided to flash the original kernel and start the rooting process all over again and i still get the error, it's like the CWM reset did sth to my phone that doesn't let me root it. Or it might have been the rom.

Thanks in advance for any help given :hello: