1. Are you ready for the Galaxy S20? Here is everything we know so far!

Cant root my LG optimus M

Discussion in 'Android Devices' started by pcapelo, Feb 17, 2011.

  1. pcapelo

    pcapelo Lurker
    Thread Starter

    Hi,

    I have doing research across the internet and every video, forum thread, web pages says to use z4root to root you phone. Well, I have been trying do that for the last 3 days without success.

    What happens is that, after download and install z4root, I click the temporary root, the process start and after a short time (right after the message: acquiring root shell) the application disappear. Not like reboot or shut down, the application just hangup and, if you try click again it will tells you:

    "the application z4rot (process com.z4mod.z4root) has stopped unexpectedly. Please try again."

    After that, the only way for you to restart z4root is rebooting the phone and trying again. Smae thing happen if I try permanent root.

    I can only imagine that the reason its because my phone version is 2.2.1

    Other than that I have no idea about what is happening and I really would like some feedback.

    If anyone have a better way to do it I would appreciate some help

    cheers

    PC
     



    1. Download the Forums for Android™ app!


      Download

       
  2. ChazzMatt

    ChazzMatt Android Enthusiast

    Yes, it's because it's 2.2.1.

    Start reading through the threads, especially the "all things root" sub-section.

    2.2.1 has now been successfully rooted, but you have to wrestle it to the ground to do it. There's no "one click" yet for 2.2.1.

    http://androidforums.com/optimus-m-all-things-root/
     
  3. joneidy

    joneidy Android Enthusiast

    Just go to this post and folow the complete guide http://androidforums.com/optimus-m-all-things-root/279318-root-2-2-1-get-data-working.html and you will be rooted on your 2.2.1 phone.
     
  4. pcapelo

    pcapelo Lurker
    Thread Starter

    I thought so.

    thank you for clarifying. I just don want to mess with rom, etc
     
  5. juanhonglo

    juanhonglo Lurker

    ok i downloaded and installed everything i run lgnpst it sees my phone shows all info has the correct dll loaded so it says ms690 then crash program fails. i managed to get it to stay running and began update process but it stayed at 0% overnight. complete unistall and reinstall still no good.

    first install lgnpst componets had a fail on install deleted all files from directory (C:\LG Electronics\LGNPST) then they would install but no good uninstallation.
    any suggestions of what i did wrong unable to root sucks bad
     
Loading...

Share This Page

Loading...