1. Are you ready for the Galaxy S20? Here is everything we know so far!

Can't Root Samsung Galaxy Ace 2.3.6 XWKT4

Discussion in 'Android Devices' started by alexpu1u, Aug 14, 2012.

  1. alexpu1u

    alexpu1u Lurker
    Thread Starter

    Hi i tryed all the ways to root my Samsung Galaxy Ace (S5830), SuperOneClick, upd_1.zip
    I get the superuser application on it but doesn't give me root acces, so its still not rooted,
    All applications that requires rooted phone don't work, super user doesn't show any allow
    notifications, has no apps in its list when i open it, tryed modifing settings in it still no succes....

    Model Number: GT-S5830
    Android Version: 2.3.6
    Baseband Version: S5830XWKT4
    Kernel Version: root@DELLBUILDER11 #1
    Build Number: GINGERBREAD.HRKT2

    I googled a lot, tryed a lot, no succes, please help!

    1. Download the Forums for Android™ app!


  2. alexpu1u

    alexpu1u Lurker
    Thread Starter

    (sry for double post, but the forum didn;t allowed me to post link or photos on my first post)
  3. damewolf13

    damewolf13 live~laugh~love

    Welcome, Alexpu1u, to Android Forums.
    I have moved this thread into the "all things root" portion of this forum, so that the rooting wizards of this forum can help you figure out what you need to do to accomplish rooting. Good Luck!:)
  4. StoneBoyTony

    StoneBoyTony Well-Known Member

  5. alexpu1u

    alexpu1u Lurker
    Thread Starter

    From google I got to you're tutorial and this forum, I tryed it step by step and the result is that I get Superuser app on my phone but the phone isn't rooted... tryed every step, afther every fail I factory restored my phone deleted everything and tryed again with update from sdcard in recovery mod, no succes, here is a pic that will explain it :

    What to do?

    I'm curios if its not working because of my Baseband Version, did anyone with Samsung Galaxy Ace Model Number: GT-S5830
    Android Version: 2.3.6
    Baseband Version: S5830XWKT4
    Kernel Version: root@DELLBUILDER11 #1
    Build Number: GINGERBREAD.HRKT2
    or similar, did actually succesfull rooted his/her device? When I google "root tutorial for Samsung Galaxy Ace S5830 XWKT4" i get similiar tutorials for rooting Samsung Galaxy Ace S5830 DDKQ8 ... not XWKT4, tryed the tutorials step by step, not succesfull on my Ace with XWKT4 baseband...
  6. zZzACEzZz

    zZzACEzZz Well-Known Member

    ite olin rootannu puhelimeni upd_1 tiedostolla. 2.3.6
  7. StoneBoyTony

    StoneBoyTony Well-Known Member

    All explained here:


    UNIVERSAL GINGERBREADROOT SAMSUNG GALAXY MODELS: GT-S5570, GT-S5570B, GT-S5570I, GT-S5570L, GT-S5571, GT-S5578 (Chinese-Mini), GT-S5660, GT-S5660M, GT-S5660L, GT-S5660V, SHW-M290K (Korean-Gio), GT-S5670, GT-S5670B, GT-S5670L, GT-S5830, GT-S5830B, GT-S5830C, GT-S5830D, GT-S5830F(La Fleur), GT-S5830G, GT-S5830i, GT-S5830L, GT-S5820, GT-S5830M, GT-S5830T, GT-S5830V, GT-S5830Z, GT-S5838(Chinese-Ace), GT-S5839i, GT-S6800(Africa-Ace Advance), GT-S6802, GT-S6802B, GT-S6802L (new), GT-B5330, GT-B7510, GT-B7510B, GT-B7510L, GT-B7800, GT-B5510, GT-B5510B, GT-B5510L, GT-B5512, GT-B5512B, GT-S6102, GT-S6102B, GT-S5300, GT-S5300B, GT-S5300L (new), GT-S5302, GT-S5302B (new), GT-S5302L (new), GT-S5360, GT-S5360B, GT-S5360L, GT-S5360T, GT-S5363, GT-S5367 (new), GT-S5368 (new), GT-S5369, GT-S5690, GT-S5690i, GT-S5690L, GT-S5690M, GT-S5690R, GT-I8150, GT-I8150B, GT-I5510, GT-I5510B, GT-I5510L, GT-I5510M, GT-I5510T, SCH-i110 (new), SCH-i509, SCH-i559, SCH-i589(Ace Duos -Chinese/India), SGH-T499, SGH-T499Y, SGH-T499V, SGH-T499W, SGH-T589, SGH-T589R, SGH-T589W, SGH-I837, SGH-I857.

    The thread expand in a very big size and can't be posted here but I made a PDF file so you can download it from here or you can visit me on the next link.
    NEW UPDATE ON: stoneboytony.blogspot.com

    Universal Gingerbread Root & Unroot 2.3.3 -> 2.3.7+
    √ Do not add mirror in my releases!
    √ Support the developers!

    Download The Leatest Tutorial:
    Universal Gingerbread Root & Unroot 2.3.3 -> 2.3.7+.pdf

  8. alexpu1u

    alexpu1u Lurker
    Thread Starter

    Today is the second day i try the metods from there, and it still doesn't work, at the step with remove quickoffice, it didn;t removed my thinkfreeoffice... do you have something that removes thinkfreeoffice, maby then it will work...
  9. StoneBoyTony

    StoneBoyTony Well-Known Member

    First apply in recovery mode unroot_v7 becouse you have half extracted files from other (older) version of the Superuser(reboot) then again in recovery mode apply c.c.b.s.f_v6 (reboot) and finaly apply again in recovery mode gb_root_v23b (reboot). After reboot look for the application SuperSU on your phone. Open the application and press continue to update the binary. Download from google play Root Validator and check if everything is ok.


    If you don't success like this the next update will be a fix to remove Thinkfreeoffice that's the promise from me and you will root your phone with no problems
  10. alexpu1u

    alexpu1u Lurker
    Thread Starter

    The phone laughs at me saying, I will not root because you are a noob even if you did every thing right and tryed every tutorial on google step by step... Just because you are a noob!
    I tryed again and again... the Su application won't appear... I tryed all day, I unrooted amd wiped all data afther every fail and tryed again still nothing, I will wait for you're fix to remove thinkfreeoffice.
  11. StoneBoyTony

    StoneBoyTony Well-Known Member

    You are ready. Just follow the link and read in the FAQ

    Chapter II
    -Removing Thinkfree Office-

    I already added your name in my testers list wille rooting your name will be displayed. I know you will root your phone finaly now. Good luck :D
    Meisterbob and alexpu1u like this.
  12. alexpu1u

    alexpu1u Lurker
    Thread Starter

    Thank you very much it worked, I'm so happy you diserve a lot of beeeers :D

    Edit: Nopw i unlocked it too , and enabled move 2 SD, happy happy . thank you again, keep up the good work!
  13. KayeNg

    KayeNg Lurker

    Hey StoneBoy, you are a genius!!!
    I had the same problem. Glad I found this thread. Thanks a lot!!
    Thanks to the original poster as well!!

    Manila, Philippines
  14. dor812

    dor812 Lurker

    hi I did the all this but nothing happens.

    1. I cannot root my galaxy ace with the one buttin root
    2. I cannot delete thinkfree office

    the ptoblem is that when I press the home button it says
    Installation aborted
  15. Shrikant716

    Shrikant716 Android Enthusiast

    Download the flashable zip from the following link...

    flash it in the recovery...ur mobile is rooted.
    after flashing the zip reboot ur mobile and download busy box install app from market n install it.

    for removing the thinkfree office ....download link2sd from market.
    after removing thinkfree office if u got any force close error, just reboot ur mobile......
  16. alexpu1u

    alexpu1u Lurker
    Thread Starter

    it din't worked from the first try to me because i had some applications installed in phone memory, the ace has a low phone memory i deleted every aplication and then the rooting worked, afther that i reinstaled my games widgets etc... hope this will help you
  17. ntlam

    ntlam Lurker

    I tried all options without success. Removed a lot of apps and memory > 100 Mb free now. Deleted Thinkfreeoffice in the recovery mode but after I rebooted it's still there when checking with the application management. In the recovery mode, unroot and root run smoothly, no errors. Just that the phone is still NOT rooted, verified this with an app called root checker.

    By the way, my phone is 5830L, at some forums some people also had problem of rooting this phone, somehow some of them succeeded with the universal_root_v17, some edit the scripts in upd_1 to add an L to 5830 in the script. I tried all those, no luck.:(
  18. Meisterbob

    Meisterbob Lurker

    @StoneBoyTony Great job! I had the problem with thinkfree office. Searching in german forums didn't help. With your files we could now finally root our Galaxy Ace La Fleur. Thank you very much from Germany!
  19. xenoblade

    xenoblade Newbie

    try updating your kernel version to the latest :- DELL238* 2
    (sorry no hash key)then try again.:)
  20. himagamal

    himagamal Lurker

    hey man thank you so much i tried everything and finally i was able to have superuser, however the validator says no busybox binary and no busybox applets also link2sd doesn't want to connect to the second partion i have on SD thank in advance
  21. himagamal

    himagamal Lurker

    i also had CWM Room but i flashed it with stock room
  22. alexpu1u

    alexpu1u Lurker
    Thread Starter

    The download links don't work anymore :(, they ask for surveys.
  23. Bloke1995

    Bloke1995 Lurker

    yea i had the link before he shut it down, it was a great setup of files; however i think that it is a bit harsh for him to make us do scamming surveys,i would support the developer using paypall however i don't want to hand in my phone number to scamers:(
  24. alexpu1u

    alexpu1u Lurker
    Thread Starter

    I don't think is the developer who did this(EDIT now I saw his blog, he really did it...), but the uploading hosts, because the links worked well before, and now I tryed many times even to complet those stupid surveys, still no download file... And I had it backed up on my laptop but my HD broked so... I'm pretty "lucky"

Samsung Galaxy Ace Forum

The Samsung Galaxy Ace release date was February 2011. Features and Specs include a 3.5" inch screen, 5MP camera, 278GB RAM, Snapdragon S1 processor, and 1350mAh battery.

February 2011
Release Date

Share This Page