1. Download our Official Android App: Forums for Android!

Can't send or receive MMS messages

Discussion in 'Metro PCS' started by zarar, Jan 24, 2015.

  1. zarar

    zarar Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Dec 18, 2014

    Dec 18, 2014
    13
    1
    16
    I have an unlocked ATT HTC One M8 for Metro and I'm noticing that I can't send nor receive MMS messages even with 4g lte on. I tried using Metro and T-Mobile's MMSC on the APN but neither worked. Is there something wrong/missing from my APN?

    Name: metropcs
    APN: fast.t-mobile.com
    Proxy: not set
    Port: not set
    Username: not set
    Password: not set
    Server: not set
    MMSC: http://mms/msg/eng.t-mobile.com/mms/wapenc
    MMS proxy: not set
    MMS port: not set
    MMS protocol: WAP 2.0
    MCC: 310
    MNC: 260
    Authentication type: not set
    APN type: default,supl,mms
    Bearer: unspecified

     

    Advertisement

    Trevor971 likes this.
  2. BRIAN5337

    BRIAN5337 Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    264
    Joined:
    Jan 2, 2011

    Jan 2, 2011
    264
    21
    38
    Under MMSC: Try this

    h**p://mms.msg.eng.t-mobile.com/mms/wapenc
     
    #2 BRIAN5337, Jan 24, 2015
    Last edited: Jan 24, 2015
  3. zarar

    zarar Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Dec 18, 2014

    Dec 18, 2014
    13
    1
    16
    Tried it but still doesn't work. :(
     
  4. puyow18

    puyow18 Android Enthusiast
    Rank:
    None
    Points:
    83
    Posts:
    254
    Joined:
    Feb 20, 2011

    Feb 20, 2011
    254
    60
    83
    Male
    Florida
    This is what my settings are (and it works for me):

    Name: MetroPCS LTE
    APN: fast.metropcs.com
    Proxy: not set
    Port: not set
    Username: not set
    Password: not set
    Server: not set
    MMSC: http://metropcs.mmsmvno.com/mms/wapenc
    MMS proxy: not set
    MMS port: not set
    MCC: 310
    MNC: 260
    Authentication type: not set
    APN type: default,mms,supl
    APN protocol: IPv4
    APN roaming protocol: IPv4
    Bearer: unspecified
    MVNO type: None

    Hope this works out for you!
     
    StevosGalaxy likes this.
  5. zarar

    zarar Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Dec 18, 2014

    Dec 18, 2014
    13
    1
    16
    Doesn't work still. I tried switching APN and MMSC settings. Tried sending/receiving MMS from both built in messenger and Go Sms Pro too. Is there another setting that might be the problem?
     
  6. KOLIO

    KOLIO Guest
    Rank:
    None
    Posts:
    0
    Joined:

    Try changing the MMSC setting to "not set".
    Also,have you tried other messaging apps?
     
  7. zarar

    zarar Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Dec 18, 2014

    Dec 18, 2014
    13
    1
    16
    Changing it to "not set" won't work either.

    Are there any other messaging apps that you can use your original # with?
     
  8. puyow18

    puyow18 Android Enthusiast
    Rank:
    None
    Points:
    83
    Posts:
    254
    Joined:
    Feb 20, 2011

    Feb 20, 2011
    254
    60
    83
    Male
    Florida
    Sorry to hear none of this stuff is working for you; I know it's frustrating. I did some searching and it seems you are not alone; people seem to have issues with the One M8 being unlocked from AT&T and trying to send mms on Tmobile and other carriers. Read this thread. One person offers a possible solution (fourth reply in the thread), but it involves flashing an HTC update for Tmobile which may or may not help you out for Metropcs issues.

    Other advice I've read include clearing all APNs besides the Metro one, doing a factory reset, deleting all text messages before doing these steps, etc.

    Another idea (if possible) is to try and put your Metro SIM into another unlocked/Metro phone to see if you can get the mms working there. That would tell you if it's a network issue or the phone. Plus if you got the other phone working you could maybe copy those APN settings over to your One.

    Last option would be to bring it in to a CORPORATE Metro store and explain your situation, hoping that they've encountered this problem with this phone before and know of a fix.
     
  9. confed

    confed Android Expert
    Rank:
    None
    Points:
    183
    Posts:
    1,076
    Joined:
    Apr 9, 2011

    Apr 9, 2011
    1,076
    377
    183
    Male
    Philly
    Have you tried Google Hangouts?
     
  10. zarar

    zarar Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Dec 18, 2014

    Dec 18, 2014
    13
    1
    16
    Textra didn't work and Hangouts creates a blank screen right after I try to text a photo for some reason. Don't have another phone that fits my SIM card.

    Looks like I'll have to use another text app to send MMS. Are there any recommended MMS text apps that won't need my APN to send MMS and others can send me MMS hassle free?

    Thanks for all the help everyone!
     
  11. puyow18

    puyow18 Android Enthusiast
    Rank:
    None
    Points:
    83
    Posts:
    254
    Joined:
    Feb 20, 2011

    Feb 20, 2011
    254
    60
    83
    Male
    Florida
    Textra is the one I know that meets your criteria; sucks it doesn't work for you.

    Maybe try to delete the apn file altogether as perhaps one of the old at&t apns are muddying the water. Make a backup of the apn file first (found here: /system/etc/apns-conf.XML), then reboot the phone. After that, go into your system settings and manually create a new apn with the correct Metro settings.

    Not sure if this would/should/could work, but it might be worth a shot. If it doesn't work just restore the apn backup you made.
     
  12. FishingforBears

    Rank:
    None
    Points:
    16
    Posts:
    9
    Joined:
    Mar 21, 2015

    Mar 21, 2015
    9
    5
    16
    Male
    E-Commerce
    New Jersey
    I have an Unlocked HTC Desire 610 from AT&T that i use on MetroPCS (with T-mobile network APN) and it stopped sending/receiving MMS messages. I fixed it and here's how I did it in my APN Settings:
    Name: MetroPCS
    APN: fast.t-mobile.com
    Proxy: Not set
    Port: Not set
    Username: Not set
    Password: Not set
    Server: Not Set
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS Proxy: Not set
    MMS Port: 80
    MMS Protocall: WAP 2.0
    MCC: 310
    MNC: 260
    Authentication Type: Not set
    APN Type: default,mms,supl,hipri
    Bearer: Unspecified

    The only thing i had changed was adding the MMSC of http://mms.msg.eng.t-mobile.com/mms/wapenc and my APN Type was originally set to default,supl,hipri . Adding the mms to the APN type was what fixed it for me. Hope I can help any future inquiries of this question with this post.
     
    Lordvincent 90 and EarlyMon like this.
  13. EarlyMon

    EarlyMon The PearlyMon
    VIP Member
    Rank:
     #1
    Points:
    5,218
    Posts:
    57,591
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    57,591
    70,376
    5,218
    New Mexico, USA
    Nicely done, thanks! :)
     
  14. zarar

    zarar Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Dec 18, 2014

    Dec 18, 2014
    13
    1
    16
    Doesn't work for me. :(

    Would rooting possibly help me with this problem?
     
  15. FishingforBears

    Rank:
    None
    Points:
    16
    Posts:
    9
    Joined:
    Mar 21, 2015

    Mar 21, 2015
    9
    5
    16
    Male
    E-Commerce
    New Jersey
    I don't think so. I could be wrong but I think it's all about your apn
    settings
     
  16. zarar

    zarar Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Dec 18, 2014

    Dec 18, 2014
    13
    1
    16
    I created a new APN and copied everything you had posted, but can't send or receive. Maybe it's because we have different phones?
     
  17. FishingforBears

    Rank:
    None
    Points:
    16
    Posts:
    9
    Joined:
    Mar 21, 2015

    Mar 21, 2015
    9
    5
    16
    Male
    E-Commerce
    New Jersey
    I did a lot of research and experimented with a few different settings before I found settings that worked for me. APN settings are carrier specific. just remember that Google is your friend. I wish I could help more.
     
  18. zarar

    zarar Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Dec 18, 2014

    Dec 18, 2014
    13
    1
    16
    Thanks for the help anyways! :)
     
  19. Jeyd02

    Jeyd02 Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,996
    Joined:
    Nov 26, 2011

    Nov 26, 2011
    1,996
    335
    163
    To help people, currently student
    US
    What about the default messenger?
     
  20. zarar

    zarar Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Dec 18, 2014

    Dec 18, 2014
    13
    1
    16
    You mean the messenger app that's pre installed? Using that doesn't send mms either.
     
  21. twinkie41

    twinkie41 Lurker
    Rank:
    None
    Points:
    16
    Posts:
    1
    Joined:
    Apr 13, 2015

    Apr 13, 2015
    1
    2
    16
    Female
    Thank you,It worked for me.
     
    Gimmick_User and FishingforBears like this.
  22. Reek

    Reek Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Dec 7, 2015

    Dec 7, 2015
    1
    0
    15
    Male
    What do you do when there is a lock on the apn? It won't let me select the second apn or the alternate that I created.
     
  23. LOZxp

    LOZxp Lurker
    Rank:
    None
    Points:
    16
    Posts:
    2
    Joined:
    Feb 24, 2016

    Feb 24, 2016
    2
    1
    16
    Male
    What about the apn settings necessary for simple mobile on an HTC desire 610...I've tried everything...
     
  24. FishingforBears

    Rank:
    None
    Points:
    16
    Posts:
    9
    Joined:
    Mar 21, 2015

    Mar 21, 2015
    9
    5
    16
    Male
    E-Commerce
    New Jersey
    @LOZxp If you set the settings to what I have above then all should work for you.
     
    LOZxp likes this.

Share This Page

Loading...