1. Download our Official Android App: Forums for Android!

Support Cant turn off vibration for notifications 4.2.2

Discussion in 'Android Devices' started by poccari, Jul 21, 2013.

  1. poccari

    poccari Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    7
    0
    5
    Hi,

    I've tried searching but haven't found anyone else with this problem, so thought that someone has a solution here.
    I have recently updated at 4.2.2, and found that my phone vibrates with every notification I receive. I'm happy for my phone to vibrate when it calls or I receive a SMS, MMS etc, but I dont want it to vibrate when I receive an email, or facebook notification etc.

    Before, I just unchecked the "vibrate" setting in each app settings (gmail and facebook), but it still vibrates when a notification comes in even if it's set not to vibrate for this application.

    As I receive a lot of emails, it's driving me up the wall. I've tried everything, factory reset, flashed a stock XZ ROM of 4.2.2. and it still happens!

    Is there some setting that I'm overlooking, or is there an app which can fix this?

    Thanks in advance for any assistance or light you can shed on this matter!
     

    Advertisement

  2. OutOfPhase

    OutOfPhase Premium Member
    Rank:
    None
    Points:
    523
    Posts:
    4,023
    Joined:
    Dec 7, 2010

    Dec 7, 2010
    4,023
    2,149
    523
    Retired Lineman
    Tampa, FL
    I dont have your phone but there is a general android setting to vibrate on all notifications,. Go to settings sounds and there should be a box to uncheck about vibration. Like I said I don't have your phone but that should get you in the general area of the box to uncheck.

    Good luck.
     
    Slug likes this.
  3. poccari

    poccari Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    7
    0
    5
    Thanks for your input. But I dont want to turn off all vibration (i.e. I still want it to vibrate to get phonecalls and SMS), but application specific notifications like facebook and gmail. Each app has it's own setting to have vibration or not, which in the past has worked fine. I've checked and the settings in the gmail and facebook app definitely have the vibration setting set to off. But whenever I get a notification from these apps, it vibrates.

    My phone has a setting in where you say, but it says "Vibrate when ringing". I may try this and see how it goes. Thanks!
     
  4. poccari

    poccari Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    7
    0
    5
    No, turned that off, and it still vibrated for an email notification!
     
  5. OutOfPhase

    OutOfPhase Premium Member
    Rank:
    None
    Points:
    523
    Posts:
    4,023
    Joined:
    Dec 7, 2010

    Dec 7, 2010
    4,023
    2,149
    523
    Retired Lineman
    Tampa, FL
    If you turn the vibrate off in settings it will still let you enable it for individual apps.
     
  6. poccari

    poccari Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    7
    0
    5
    Yep, individual app vibrate setting is set to off also. Still get vibration on notifications for those apps.
     
  7. Slug

    Slug Check six!
    VIP Member
    Rank:
    None
    Points:
    2,043
    Posts:
    20,541
    Joined:
    Aug 1, 2009

    Aug 1, 2009
    20,541
    17,001
    2,043
    Male
    Mobile phone retail
    Inverness, UK
    Just a thought.... do you have FB etc accounts linked to Socialife? If so, it might be the source of the mysterious notifications. Go into Settings/Apps, select Socialife and disable "Show notifications".
     
  8. poccari

    poccari Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    7
    0
    5
    Cheers Slug.... no, that didn't do it (I hadn't registered any accounts with Sociallife, but I froze the app just in case). Still vibrates whenever I get a gmail or FB notification. Just confirming, are you running 4.2.2? Are you having the same problem?
     
  9. Slug

    Slug Check six!
    VIP Member
    Rank:
    None
    Points:
    2,043
    Posts:
    20,541
    Joined:
    Aug 1, 2009

    Aug 1, 2009
    20,541
    17,001
    2,043
    Male
    Mobile phone retail
    Inverness, UK
    Nope, still on 4.1.2 here. I briefly flashed the generic_ES 4.2.2 update but it messed with my notification LED settings so I reverted. I'm not getting any unexpected vibration alerts, no.
     
  10. poccari

    poccari Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    7
    0
    5
    Yeah, I'm thinking of reverting to 4.1.2 until this is fixed (it's a small issue, but an annoying one)
     
  11. poccari

    poccari Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    7
    0
    5
    I've found that it only vibrates when my phone is set to "vibrate" When the ringer volume is on, it only vibrates when it is told to... it's weird, it seems like a system override thing. When it's set to silent (no vibrate) it doesn't vibrate.
     
  12. Raptor_Jesus

    Raptor_Jesus On Probation
    Rank:
    None
    Points:
    38
    Posts:
    135
    Joined:
    Apr 6, 2013

    Apr 6, 2013
    135
    22
    38
    Male
    Twitter’s settings interface actually offers many more configuration options than are obvious at first glance.

    At the top, however, there’s a section headed Accounts, the first entry under which should be your account name. Though there’s nothing to indicate it, clicking on this takes you to another menu offering many more settings – including a whole section headed NOTIFICATION SETTINGS.

    Read more: Twitter for Android: how to stop unwanted alerts | PC Pro blog Twitter for Android: how to stop unwanted alerts | PC Pro blog



    گردا
     
  13. dnasailor

    dnasailor Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 13, 2013

    Dec 13, 2013
    1
    0
    5
    I'm having the very same issue. I tried turning off the vibration in gmail settings, but it still vibrates. This only happens when the phone is set to vibrate, not when the ringer or normal sound setting is on. This is a very annoying problem. Hope we can find a fix.
     
  14. animal47

    animal47 Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    160
    Joined:
    Jan 26, 2011

    Jan 26, 2011
    160
    17
    38
    My phone is doing it as well on emails. It doesn't vibrate as strongly as it does when vibrate notification is on but it still does it a bit and it is annoying as I get loads of emails and don't want to be notified as they aren't urgent.
     
  15. Landroid

    Landroid Lurker
    Rank:
    None
    Points:
    6
    Posts:
    1
    Joined:
    Oct 14, 2014

    Oct 14, 2014
    1
    1
    6
    I had this issue with Facebook notifications. Turns out the fix is through the app, not the phone. Haven't tried other apps, but for facebook (on Z3 compact), go Menu>App Settings> untick Vibrate.
     
    dw3000 likes this.
  16. dw3000

    dw3000 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 18, 2014

    Oct 18, 2014
    1
    0
    5
    This worked for me!
     
  17. Honeytea

    Honeytea Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Aug 12, 2015

    Aug 12, 2015
    1
    0
    15
    Female
    To turn off vibrations tap the message icon on your screen. At the bottom of your phone tap the menu button its on the left. Scroll down to notifications setting and select vibrate, u mark or unmark.
     

    Attached Files:

  18. uniquePia

    uniquePia Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 4, 2015

    Oct 4, 2015
    1
    0
    5
    Female
    Hi, the below information may help you...

    I went into the app (for me, this was maildroid), accessed the menu within the app, where there is a 'Notification Channels' option, when opening this, there is then a list of options that are checked or unchecked - one of these is 'vibrate', I unchecked this & that fixed it for me - no more vibration on notifications from maildroid.

    Prior to this, I had already unchecked the vibrate under sounds settings in the general phone settings, which didn't stop the vibrations on these notifications.
    I had also gone into the settings for maildroid & could not find anywhere that it referred to 'vibrate'. Also could not find reference to 'vibrate' within the 'notifications' area within the settings menu for maildroid. And could not find anything relating to 'vibrate' within the notifications area within the phone's general settings.

    Hopefully the app you are dealing with has 'notification channels' options/settings somewhere.
     
  19. rickdes

    rickdes Lurker
    Rank:
    None
    Points:
    15
    Posts:
    2
    Joined:
    Oct 31, 2015

    Oct 31, 2015
    2
    0
    15
    Male
    Thank you Honeytea for this info. I finally found where to turn off vibrate on notifications (for my text messages). I have a droid 4 xt894. After I tapped message icon and then pressed menu and settings i found the vibrate on/off in the delivery reports of all places. They sure put stuff in obscure places on this phone.
     
    #19 rickdes, Oct 31, 2015
    Last edited by a moderator: Nov 4, 2015
  20. furry cakes

    furry cakes Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 22, 2015

    Nov 22, 2015
    1
    0
    5
    I found this worked for me:

    https://support.google.com/nexus/answer/2819577?hl=en

    For the lazy:
    "When your device's ring volume is turned all the way down to vibrate mode [​IMG], notifications that are set to play a sound will vibrate instead. Notifications set to vibrate will still vibrate."

    I.e. turn of vibrate for notifications on a per-app basis. If you have your phone on vibrate mode, it will vibrate for notifications with sounds instead of playing the sound.
     
  21. Rajesh1988

    Rajesh1988 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 30, 2015

    Nov 30, 2015
    1
    0
    5
    There is no such option to uncheck the vibration alert for app notifications.
     

Share This Page

Loading...