1. Are you ready for the Galaxy S20? Here is everything we know so far!

Can't update usb driver during 1.5>2.1 root procedure

Discussion in 'Android Devices' started by mckayg, May 26, 2010.

  1. mckayg

    mckayg Lurker
    Thread Starter

    I am on a replacement phone. 1.5 updated to 2.1OTA trying to root per walkthrough instruction in guide forum.
    Firmware 2.1
    Kernel 2.6.29-5898f66b
    htc-kernel@and18-2 #1
    Build 2.19.605.1 CL123435 test-keys
    Software 2.19.605.1
    Browser WebKit 3.1
    PRI 2.11_002
    PRL 51866
    ERI 5
    While following the instructions posted, Step II-10.
    Have yellow exclamation in Device Manager,
    Get this window during update driver step:
    Cannot Continue the Hardware Update Wizard
    The wizard could not find a better match for your hardware than the software you currently have installed.
    I do have usb_driver folder:
    has subfolder amd64 and i386 along with
    AndroidSDK has Installed Packages: Usb Driver package, revision 3
    I haven't been able to finish the steps and get ROOT to work.
    adb shell commands give me "can't find device"

    Any help is appreciated. Not very computer software programmer savvy but I follow directions well!
    and keep up the awsome work. the original phone I loaded 2.1 leak v.3. Loved it! Replaced/ warranty exchanged due to poor call reception and echo-ing on the other end.

    1. Download the Forums for Android™ app!


  2. les017

    les017 Newbie

    Are you running Windows XP? For done unexplained reason I had the exact same thing, except my PC would not see the drivers at all.

    Solution: Install HTC Sync, this will install the proper drivers for you. Then when you go to root just make sure your phone is set to Charge Only AND MAKE SURE that you completely shut down HTC Sync on your computer.

    Go forth, good luck, report back!!
  3. BlueDC2

    BlueDC2 Android Enthusiast

    Download htc sync. It will install the proper usb drivers for you.
  4. mckayg

    mckayg Lurker
    Thread Starter

    This is what I did. (NO change in results)

    Control Panel, Add/Rmv pgms, uninstalled htc sync, downloaded fresh htc sync, restarted pc, run htc sync

    Debugging selected, (tried both ways with charge only and disk drive)

    NO yellow exclamation in device mngr, Shows Android USB device and My HTC.

    tried update drivers and got same results. I do not use windows outlook if this means anything, so I have nothing to sync.

    went to Android SDK and tried to refresh installed pckgs also.
  5. jreed2560

    jreed2560 Android Expert

    Have you tried a different cable? It sounds simple, but it made a world of difference to me. Also once you connect the new cable, open up the tools folder and while you phone is set to debugging on/charge only, then run ddms. See if your device is listed in the boxes to the left (there should be a small picture of a phone follow by the letters HT9B2something something). If its there your computer is definitely seeing your device.
  6. mckayg

    mckayg Lurker
    Thread Starter

    UPDATE: Success!

    Apparently, the new HTC Sync loaded what it needed as far as updated drivers. I continued on with GUIDE: From stock 1.5 to the latest root 2.1 at running 'install root.bat.

    (this time)Phone did what the instructions said it would.
    and there it is.

    Now on to tethering, and beyond!

    Thanks for your help and patience w/ another 'noob'.

HTC Droid Eris Forum

The HTC Droid Eris release date was November 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7600 processor, and 1300mAh battery.

November 2009
Release Date

Share This Page