1. Are you ready for the Galaxy S20? Here is everything we know so far!

Captivate Root

Discussion in 'Android Devices' started by chaoscentral, Jul 12, 2010.

  1. tawerner

    tawerner Newbie

    Everything seemed to work as planned but when I open Superuser permissions all I see is a blank black screen. Tried uninstalling and installing update.zip again and same thing happens....suggestions?
     

    Advertisement

  2. tawerner

    tawerner Newbie

    answered my own question. found sgs tools in SU.
     
  3. gspears

    gspears Newbie

    okay guys I'm confused. My Captivate is updated to stock 2.2. I tried the update.zip and I get the signature verification failed error. Is there an updated update.zip? I tried the toolbox but could not find the 3.0 download, only the 2.5 download which does the same thing.

    Thanks for the help.
     
  4. reinbeau

    reinbeau Klaatu barada nikto

    from this post:

    You can download it from this thread.
     
    gspears likes this.
  5. gspears

    gspears Newbie


    Thanks for the thread suggestion. I was not able to utilze his procedure but in the thread he sent another person with the same issue to superoneclick which did root the phone. I verified it by loading Titanium Backup which installed correctly.

    But then when I installed ROM managoer and tried to load CWO recovery it said it installed correctly but when I booted into recovery it still came up the the Samsung blue texted recovery. I was hoping rooting would bix these types of issues.
     
  6. quiteryot

    quiteryot Lurker

    I download Androzip and when I tried to copy the update.zip file to the root it said that it could not move to the root due to system restrictions .. ugggh

    I updated to stock 2.2
     
  7. jlc24_1982

    jlc24_1982 Lurker

    I am new to this i want to root my phone I have tried the way chaoscentral shoes but it gets stuck on downloading do not turn off the target and it wont do anything else PLEASE HELP....and i tried it again and it said the the e signiture wouldnt verify
     
  8. js593

    js593 Member

    Are you still able to get back to your phone unrooted? As in, unpower it, and boot it back up into Android OS? If so, i would highly recommend using Super One Click. Used it on my phone, never had an issue. E-signature verification issue seems to be a CWM issue: [Q] E:signature verification failed ClockWorkMod - xda-developers

    Whats the reason for doing the rooting in the first place?
     
  9. Moosequest2

    Moosequest2 Lurker

    i used superoneclick root and it worked just fine
     
  10. HGUser99

    HGUser99 Lurker

    Method did not work on Samsung Captivate with AT&T version of Froyo.

    It says e-signature verification failed, update aborted. Apparently this zip file is incompatible with the Samsung Captivate or the Froyo version that AT&T released.
     
  11. beatdroppah

    beatdroppah Well-Known Member

    it is compatible, bc tons of other people have done it. but i had the exact same problem when i first got my Cappy, and was trying to root. go here--> [RECOVERY] 3e Recovery Modded w/ No Verification - xda-developers and download the file, and follow the directions listed. it is to install a modded 3e recovery that skips the verification check.
     
  12. HGUser99

    HGUser99 Lurker

    The instructions tell me to:

    mount -o rw,remount /dev/block/stl9 /system
    That gives me a response of
    mount: Operation not permitted

    Does mounting the system directory read-write require root access? I would expect that it does.
     
  13. reinbeau

    reinbeau Klaatu barada nikto

    Yes, it does.
     
  14. HGUser99

    HGUser99 Lurker

    That's what I thought.

    The whole point of this is that I want have a Captivate running the Froyo upgrade from Samsung. It is not rooted.

    To root the phone I have to have an update that will pass verification. Bypassing verification is possible, but apparently only if you have already rooted the phone. Or maybe there's some trick to bypass such restrictions.

    So can anybody recommend a method that will root a Samsung Captivate phone running upgraded Froyo?
     
  15. vt6spd

    vt6spd Member

    We need a step by step guide of how to root the 2.2. And I do mean step by step...where files are located is always good to know. Copy to internal memory is vague- many do not know where to find internal memory. Hope someone does a write up. :)
     
  16. yellowfuse

    yellowfuse Lurker

    what about a new captivate built 07.12.2011?
    2.2???
     
  17. yellowfuse

    yellowfuse Lurker

    keeps saying signature failed or something
    aborted
    also why does it reset my phone everytime i go into out of recovery?
    is that normal??
    i am used to the moto droid 1 for verizon. i still have it and its rooted and on ss/cm latest 2.3.4 and i would give it to you if you can help me get this crazy captivate rooted and on latest cm7 2.3 or whatever is avail. no joke. working moto droid 1 w/blemishes of course, it's 1.5yrs old. but still...
     
  18. yellowfuse

    yellowfuse Lurker

    word!
     
  19. kbolt

    kbolt Lurker

    Good day, I have a Samsung Captivate with 2.3.4 Gingerbread and I need help with getting it rooted. I am in love with the Android OS but i am clueless in regards to the rooting process.

    The phone's info:
    kernel version: 2.6.35.7-I897UCKH3-CL461307

    baseband version: I897UCKH3
     
  20. zmcgrew83

    zmcgrew83 Newbie

    ok so im stuck where thispoor lad is how do just drag it over to the removable disk g thingy if it nevert popped up i installed all the drivers?:thinking:
     
  21. davep13

    davep13 Member

    make sure your sd card is mounted so you copy files to it. hope that helps
     
  22. sunnyred

    sunnyred Lurker

    after i restart my phone after that my phone has blank..only show X forever..how do i solve this problem..please help me..
     
  23. NNMDCruzB

    NNMDCruzB Lurker

    I know this post is dated but it concerned me and I thought it would help for anyone who decided to root with the Froyo updated (Stock 2.2) on their Captivate.

    I myself had this error:
    -- Install from sdcard...
    Finding update package...
    Opening update package...
    Verifying update package...
    E: signature verification failed
    Installation aborted.


    So delved into page 7 of this thread. Specifically this link that was quoted above for [RECOVERY] 3e Recovery Modded w/ No Verification - xda-developers. Then went to the link that the guy took it from, user untermensch and followed his instructions. Here ->recovery 3e modified to work like recovery 2e - Updated 01/23/2011
    I looked into the archived folder and simply opened the install Batch file and it opens up a terminal. I have screen shots down below.
    It's simple, follow the instructions. Make sure your phone is on USB Debugging and such and while your phone is connected to your computer, follow the on screen commands on the terminal and it will install the 3e Recovery Mod on your phone.
    NOTE: The update untermensch has attached on his post is not for the Samsung Captivates/SGH-I-987. So use the ones available here in the Captivate Forums, like Captivate Root.

    Screen Shots:
    install_terminal.PNG
    Just opened it
    3e recovery installer.PNG
    It ran.

    Like it says, it automatically reboots. Then after that just follow the instructions like normal provided by others, again, I used Captivate Root.

    Cheers!
     
  24. Andyroids

    Andyroids Lurker

    trying to do this on my captivate, running Froyo 2.2.....keep getting this error

    E:signature verification failed
    Installation aborted.

    what am I doing wrong
     
  25. trev1011

    trev1011 Newbie

    rooting seems confusing as hell. All these custom ROMS and flashing and crap. Wth is going on! Iphone seemed so much easier to jailbreak. I have researched for enough time now for the wife to be pissed. I quit! stock will have to do this time
     

Samsung Captivate Forum

The Samsung Captivate release date was July 2010. Features and Specs include a 4.0" inch screen, 5MP camera, 512GB RAM, Hummingbird processor, and 1500mAh battery.

July 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...