1. Are you ready for the Galaxy S20? Here is everything we know so far!

Casio C771 Unlock Bootloader and Install GNM Recovery via Fastboot

Discussion in 'Android Devices' started by rasta4rest, Jan 4, 2013.

  1. rasta4rest

    rasta4rest Member
    Thread Starter

    First of all , Do with your own risk.. im not responsible for any damage caused by your action . Im just share my experience and trial , this trick is working for me To Unlock bootloader , flashing recovery with GNM Recovery from fastboot [Command Line mode] , and finally Root your device from GNM Recovery. This is just alternative root method , i dont think it's an easier than THIS method but it's worth to try.

    Im on M110 Build , still hoping for anyone here upload their M130 stock build , since i cant get OTA Update from here. But i guess this method work for all build.

    The starting point is here :
    I've guessed that "Bypass Booting" was bootloader lock "bypassing", but how can i use that to install recovery from stock device without root access ?

    Here's the step by step guide assuming everyone here has been enabling "bypass booting" - ON & C771 Boot Loader Interface driver installed on their device , just googling it or search on this forum to get the correct driver:
    1. Download ADB , since im doing all my stuff from there and make sure to connect your device in computer with Debugging On [ see Setting > Application > Development > USB Debugging ] and Charge Only mode. [see attachment for ADB package for windows]

    2. Execute this Command from Command Line [ im using Windows Command Line ] to Enter C771 Bootloader :
    you should see stuck on G'zone logo on your Device after the process completed.

    3. Check device already connected and can do the fastboot command
    - the command should have result = version: 0.5 <-- or something like that , it means the device already connected [ 0x0409 --> Vendor id of C771 ]

    4. Assuming you're already have GNM Recovery image on you PC do this following command :
    screenshot of mine on attachment for example.

    When you see something like this on CMD Windows :
    That means the flashing process already done and succeed.

    6. Now boot to Android with this command :
    no need for disassembly battery anymore from bootloader interface and continue to normal booting.

    7. After booting process completed and your PC detected your ADB interface again. Run this command from CMD Windows :
    and you'll see GNM Recovery installed on your C771 Calculator eh sorry i mean Android Device. :D

    8. Make Yourself familiar with GNM Recovery Interface on you Device , you can do root and anything you could normally do from Recovery Interface.
    I'm still waiting for someone Cooking Custom ROM from this lovely calculator :D.

    9. This is personal advisory , do a NANDROID BACKUP is strongly recomended first action after all of this done.
    You should at all cost avoid to wipe /Sytem , /Boot , /etc except you really need to brick your phone for doing some development.

    PS : I would prefer THIS TRICK. Once again , this is only an alternative method especially for you who have wifi error problem after rooting and lost superuser access , or accidentally restore to factory default , hoping the wifi problem gone suddenly by itself

    Attached Files:

    1. Download the Forums for Android™ app!


  2. jova33

    jova33 Android Expert

    That's not unlocking your bootloader?
    fastboot oem unlock
  3. rasta4rest

    rasta4rest Member
    Thread Starter

    Fastboot oem unlock , wont do anything on this "special" device.

    but i dont know where to have the key.

    Above trick just for unlocking to enable flashing GNM Recovery,not to enter fastboot mode (it's disabled i think).
    It's just my opinion :-D
    I just did it without root access to gain root.
  4. r_hippy

    r_hippy Well-Known Member

    and that is as far as I get ...
    nothing else will work..
    the numbers you have in bold are they specific to the phone ?
    if so where do I get them from
  5. r_hippy

    r_hippy Well-Known Member

    ok I got all you shown in the screen shot
    but when I adb reboot recovery I get this screen


    what to do
  6. rasta4rest

    rasta4rest Member
    Thread Starter

    - I assume you have correct driver installed on your PC also you're already familiar with ADB Command.
    -Are you sure have enabled bypass boot from device's program mode ?
    -Make sure your device detected as bootloader interface in your pc.
    To check fastboot command has already recognize your device.
    - put that gnm recovery .img on your one of Pc partition.
    (In my case i put it on D:\casio\gnm_recovery.img)
    - bold numeric was Vendor Id of casio,it's global for all Casio Commando.
    - the screenshot was just example,please read through entire guideline step by step.
    r_hippy likes this.
  7. r_hippy

    r_hippy Well-Known Member

    drivers installed, used the drivers provided and windows install some as well




    step 2


    step 3


    and of course

    what I get after I posted all ready
    as you can see where I am grabbing the recovery img from in the screen shot
    all commands executed successfully
    I did a button combination only to get recovery screen that prompted me if I wanted to do a factory reset ..when all else failed as well
    and yes
    I went into the dialer and added ##7764726 hit send the I had the little windows to add the pass 000000
    navigated to enabled bypass boot and it was off I did turn it on...

    I followed it step by step..

    and I'm very familiar with the cmd / shell I would on Linux servers and centOS Ubuntu etc
    thanks for your reply
  8. rasta4rest

    rasta4rest Member
    Thread Starter

    Awesome :D
    Then right before command
    try executing this command
    Maybe that's the missing part.
    r_hippy likes this.
  9. r_hippy

    r_hippy Well-Known Member

    fastboot -i 0x0409 oem unlock
    sits there starts out like
    then stops .. left it like that for 30 min ..

    also tried the hold the 2 volume buttons down when it goes into the bott recovey and I get the droid with the ! with the triangle around it

    any more ideas ?
  10. rasta4rest

    rasta4rest Member
    Thread Starter

    That's weird,im on build m110.
    I've done exactly as you do,and it's worked.
    The flashing process has done with no error.
    Or maybe this guide won't work on m130 build?
  11. r_hippy

    r_hippy Well-Known Member

    What I'm thinking is when I screwed with the su version and replaced it manually
    then did it all over with the wifi on I screwed up other stuff..
    I have a new one now but I have not rooted it ..
    since it's refurbished So I'm going to wait till I know the phone is good..
    Just in case I have to send it back..
  12. rasta4rest

    rasta4rest Member
    Thread Starter

    Well i guess i've run out ideas.
  13. matchsol08

    matchsol08 Lurker

    I just rooted my droid commando. thanks to all the information on this forum. Like Hippy I have M130 and tried to flash recovery as described above. during recovery reboot I get screen shown by hippy. no options. I have to remove my battery to reboot to desktop. at this time what other recovery flash can I try? anyone out there with a m130 get this to work?

  14. monkeytools

    monkeytools Well-Known Member

    r_hippy and matchsol08 like this.
  15. matchsol08

    matchsol08 Lurker

    i just realized that I did not use the right image file. I didn't know that the commando had its own. I just downloaded the img file at the top assuming it was the latest version without paying attion to the acronyms.

    thanks monky.
    now that I have GNM recovery installed, i created a backup and started peeling off stock applications. my assumption is that the recovery flash I recovered in the dump files is no longer the stock since i was flashing the wrong one. how can i tell if its stock or not?

    thanks again.
  16. monkeytools

    monkeytools Well-Known Member

    The recovery dump is your stock recovery. And I am glad I could help. Put that recovery dump in a safe place. Just incase you need it later. I made a copy on my pc.
  17. r_hippy

    r_hippy Well-Known Member

    so whats the right recovery for the c771 M130
    in the thread you posted all in one recovery is where you get GNM ?

  18. monkeytools

    monkeytools Well-Known Member

    it will say commando 3.06. Just click on link and scroll down to 3.06 recoverys and find the commado 3.06.
    r_hippy likes this.
  19. r_hippy

    r_hippy Well-Known Member

  20. monkeytools

    monkeytools Well-Known Member

    What is the problem.
  21. r_hippy

    r_hippy Well-Known Member

    I can't use the boot loader as expected. As I said in the other thread I can get there adb and scroll up and down but I can not select any option. Not even boot. I need to pull the battery to boot the phone
  22. matchsol08

    matchsol08 Lurker

    Use the menu button of the phone....bottom left of your screen to execute your highlighted action. First thing you shud do is make a backup before you start peeling stock apps.
    r_hippy likes this.
  23. r_hippy

    r_hippy Well-Known Member

    thanks very much for the detailed answer
    for the noob

    I did figure it out today playing around at luch

    I did a nfull nadroid back up..
    now I need to figure out what can go with out issue

    thanks again
  24. unibonger

    unibonger Newbie

    So I got it to the stuck G'zOne logo

    adb devices returns a blank list?

    If I try fastboot it comes back:

    'fastboot' is not recognized as an internal or external command, operable program or batch file
  25. r_hippy

    r_hippy Well-Known Member

    Driver missing? Or it didn't install the recovery... You unlocked the bootloader? Us terminal. Su reboot recover. You should have the Droid screen with options you us the volume buttons and the touch screen to make the backup

Casio G'Zone Commando Forum

The Casio G'Zone Commando release date was April 2011. Features and Specs include a 3.6" inch screen, 5MP camera, 512GB RAM, processor, and 1460mAh battery.

April 2011
Release Date

Share This Page