1. Are you ready for the Galaxy S20? Here is everything we know so far!

Casio Pro Trek WSD F20 not working properly

Discussion in 'Android Help' started by BRETT BUCHANAN, May 13, 2020.


    Thread Starter

    Guys, my protrek is no longer tracking my steps and the tools are wonky. Specifically, the compass tool doesn't work or will only work if I spend like 30 minutes messing with settings and recalibrating etc.

    I just rebooted the watch to factory settings 4 days ago which included the update to Wear OS and thought that fixed it but today I'm back to square one.

    Can anyone with experience in this area give me some ideas?

    THANK YOU!!!

    1. Download the Forums for Android™ app!


  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    was this all of a sudden? or gradually? you did not drop the watch? do you have a warranty or insurance on it? if a factory reset does not work then you might have a hardware failure.
    BRETT BUCHANAN and Dannydet like this.

    Thread Starter

    Kinda sudden, not sure if I still have a factory warranty. Probably do as it's only about 14 months since I purchased. I have not purchased any insurance.

    I have never dropped it or really even gotten it wet!

    Guess I just need to call/contact Casio next?
    ocnbrze likes this.
  4. mikedt

    mikedt 你好

    Definitely. As it sounds like you've tried everything else you can.
    ocnbrze likes this.
  5. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    i would definitely contact casio. hopefully they can get it replaced for you.

    good luck and keep us posted.
    mikedt likes this.

Share This Page