1. Check out our companion app, Forums for Android! Download from Google Play

Root [CDMA] Help w HTCdev "waiting for device"

Discussion in 'Android Devices' started by kbakermemphis, Jan 2, 2012.

  1. kbakermemphis

    kbakermemphis New Member
    Thread Starter
    5

    Jan 2, 2012
    4
    0
    5
    Hello, I'm completely phone ******ed, I'm trying to root the gf's evo 3d so she can use open garden tether. It took like 5 seconds with my evo 4g and I'm using the HTCdev unlock so it should be just as easy but I cannot get the last step to work.

    I am supposed to put all the files into a folder and run the fastboot get cmd and I do that no problem but then instead of the token printing all I get is
    <waiting for device>

    the phone is sitting on the FASTBOOT USB screen, it is HBOOT 1.50. It says S-ON (I don't know what that means I just saw it referenced a lot) and it is connected via USB so I don't know why it isn't being recognized.

    Thanks for any help.
     

    Advertisement

  2. DonB

    DonB ♡ Spidey Sense !! ♡ ™
    Moderator
    1,423

    Nov 30, 2009
    19,339
    8,003
    1,423
    Male
    18th Hole Of the Golf Course
    Make sure your USB debugging is check marked



     
  3. kbakermemphis

    kbakermemphis New Member
    Thread Starter
    5

    Jan 2, 2012
    4
    0
    5
    Yeah it's checked.

     
  4. wake69

    wake69 Well-Known Member
    213

    Jun 8, 2010
    1,808
    513
    213
    Security Engineer
    Georgia
    make sure all software is installed. install android sdk dont just unzip it also install jdk and htc sync

    after you fully install android sdk, copy the files in the tools folder to the platform tools folder. the install should take between 20-45 mins
     
  5. kbakermemphis

    kbakermemphis New Member
    Thread Starter
    5

    Jan 2, 2012
    4
    0
    5
    OK, so I figured out what the problem was. The fastboot I was trying to use was 69kb and there was another one that was 180kb and once I switched that one into the folder it worked. Now I'm at the point that I have downloaded and moved the .bin into the correct folder and run the unlock cmd and the print looks just like the example on the HTCdev site but I never got the "Unlock Bootloader" screen on the phone. Nothing happened at all. I turned it on thinking maybe it would pop up on reboot but nothing. I tried it again, nadda.

    Any thoughts on this one?
     
  6. DonB

    DonB ♡ Spidey Sense !! ♡ ™
    Moderator
    1,423

    Nov 30, 2009
    19,339
    8,003
    1,423
    Male
    18th Hole Of the Golf Course
    If you are on HBoot 1.50 you will not get S-OFF but you will be rooted.


     
  7. USB Debugging is checked and I have the 180kb version of Fastboot loaded in the folder. Still nothing. It always stops at the "<waiting for device>" prompt.
     
  8. champaine

    champaine New Member
    6

    Mar 19, 2012
    2
    2
    6
    I had this same issue after actually attaining root with my 3D. The device seems to have been recognized by the os, and was available to move files around on the SD, but running
    Code (Text):
    1. ./adb devices
    only yielded:
    Code (Text):
    1. <waiting for device>
    So I scoured other forums about this, and it seems to be a general Linux issue, though it had escaped me at the time since I had previously successfully mounted a recover image and had root. The fix seems to be to updated the udev rules on your machine, then restart

    First jump into root
    Code (Text):
    1.  
    2. su
    The perform the following commands:

    Code (Text):
    1. cd /etc/udev/rules.d
    2. touch 51-android.rules
    3. nano 51-android.rules
    4.  
    Can be simply
    Code (Text):
    1. nano /etc/udev/rules.d/51-androidrules
    Then entering the following line:d
    Code (Text):
    1. SUBSYSTEM=="usb", SYSFS{idVendor}=="0e79", MODE="0666"
    Ctrl+X to save, "y" to save changes. Then you need to reboot (really linux? fine.)

    Once back up you need to get the phone into recovery with the power/volume down buttons again. Then check it out:
    Code (Text):
    1.  
    2. ./adb-linux devices
    3. * daemon not running. starting it now *
    4. * daemon started successfully *
    5. List of devices attached
    6. HT16THX18787    device
    7.  
    Now, you can use the USB bootloader to flash your recover/other roms.

    Reflashing or flashing a new recover allowed me to flash roms where I was previously unable to do so as well.

    I would love to cite sources on this one so credit goes where due, but I understand there is no linking as a new poster, and I'd like to respect the rules of the forum. If allowed I will be happy to link.
     
    jerofld likes this.
  9. jerofld

    jerofld Fixing stuff is not easy
    313

    May 10, 2011
    7,687
    4,269
    313
    Male
    I fix stuff
    Over there <points>
    The no linking on your first post is an anti-spam policy. You can posts URLs after your first post. But we do appreciate people citing their source.
     
  10. champaine

    champaine New Member
    6

    Mar 19, 2012
    2
    2
    6
    Glad to hear it

    Stack overflow helped out a bit with general debugging mode:
    android - Detecting device for debugging (ADB) does not work - Stack Overflow

    Found the vendor information here: Setting Up ADB/USB Drivers for Android Devices in Linux (Ubuntu) Esau Silva

    Also, there are a lot of useful adb commands on that page, makes a great reference.
     
    jerofld likes this.
  11. frutekake

    frutekake New Member
    5

    Mar 10, 2013
    4
    0
    5
    I don't mean to be annoying or sound like an idiot, but I'm COMPLETELY lost. I, too, am stuck at this point where it says "waiting for device" (I'm surprised I even made it this far) but as I read the replies to troubleshoot it, I'm baffled and don't understand a word. :( Is there a less advanced way of explaining how to fix this from this point? Thanks in advance for any and all help!
     
  12. frutekake

    frutekake New Member
    5

    Mar 10, 2013
    4
    0
    5
    ...and I just realized this thread is almost a year old... my bad.
     
  13. remanifest

    remanifest Well-Known Member
    113

    Jan 13, 2013
    839
    321
    113
    You just need to be in your HBOOT to do this.

    Pull your battery, hold the volume-down button, and press power. Then you can run the commands.

    Way to resurrect the dead frutekake!
     
  14. frutekake

    frutekake New Member
    5

    Mar 10, 2013
    4
    0
    5
    No, I'm already in "Fastboot" mode and it says "Fastboot USB" for a minute then my computer USB messes up says the device can't be recognized then goes back to "Fastboot" and my Command Prompt will get stuck at <waiting for device> ... does that make any sense?

    P.S. Thanks for your reply regardless!
     
  15. MahaloCat

    MahaloCat Well-Known Member
    163

    Aug 3, 2010
    1,934
    460
    163
    Honolulu
    Frutetkake - what h-bbot - are you windows or linux?
     
  16. frutekake

    frutekake New Member
    5

    Mar 10, 2013
    4
    0
    5
  17. MahaloCat

    MahaloCat Well-Known Member
    163

    Aug 3, 2010
    1,934
    460
    163
    Honolulu
    hmmm can you confirm that fastboot is unchecked...
     
  18. DiagonalArg

    DiagonalArg Member
    16

    Nov 28, 2011
    16
    6
    16
    Ok, I'm stuck on the same issue (Linux, trying to root a Droid Incredible 2). HTCDev website tells me to dl/unzip the adt-bundle, then run the "SDK Manager" to download a bunch of files, from where I get adb and fastboot. Thing is, in Linux there _is_ no "SDK Manager", so what do I run? Also, adb and fastboot are already present, so do I really need to run whatever the linux equivalent is?

    @champaine - I don't really understand udev, but it seems like SYSFS has become ATTR. Can you explain what the "0e79" is in:

    Code (Text):
    1. SYSFS{idVendor}=="0e79"
    Is this idVendor the same for all HTC phones?
     
Tags:

Share This Page

Loading...