1. Are you ready for the Galaxy S20? Here is everything we know so far!

[CDMA] Perm rooting the Evo 3D with S-OFF

Discussion in 'Android Devices' started by novox77, Jun 25, 2011.

  1. ovrrdrive

    ovrrdrive Android Expert


    Advertisement

    EarlyMon likes this.
  2. evolution3d

    evolution3d Well-Known Member

    Worked beautifully! Thank you!!!!!!
     
  3. Knewz

    Knewz Android Expert

    Got Root? I do!!!
     
    EarlyMon likes this.
  4. outkast25

    outkast25 Android Enthusiast

    I had problems flashing recovery lastnight. Im trying to start from the beginign today,run revolutionary again today and its tell me "your device is not supported at this time" why is this?
     
  5. outkast25

    outkast25 Android Enthusiast

    now it just says waiting for phone.....
    is this because I already ran it lastnight?
     
  6. M5Rahul

    M5Rahul Well-Known Member

    Question :

    I attainted S-OFF and successfully flashed ClockWork

    Phone activated fine, PRL updated fine too.

    I also downloaded the SU-2.3.6.3-efgh-signed.zip


    Question is, how do I flash it from Recovery ?

    Do I copy it to the card's root and flash from recovery ?

    Please help... I wanna be sure beore doing this last step :eek:
     
  7. novox77

    novox77 Leeeroy Jennnkinnns!
    Thread Starter

    yup, put the su .zip file in your sd card, top level directory (aka root directory). then go to recovery and flash the .zip file. it will let you pick which file to flash.

    @outkast:
    if the recovery didn't go through, you need to manually flash it. read the OP :)
     
    M5Rahul likes this.
  8. ovrrdrive

    ovrrdrive Android Expert

    If you ran it last night your phone should already be s-off so it's not supported in the program. You'll just need to push your recovery in fastboot or hboot to get access to the fun stuff.
     
  9. mynamewastaken

    mynamewastaken Android Enthusiast

    After a successful S-OFF I'm having trouble booting in to recovery. I followed the 3D boot to recovery instructions but this just causes my phone to lock up/not respond/appear dead (it even stops charging). If I just hold power it'll boot normally. Fastboot is off.

    To get around this, I connected my 3D to my PC and used 'adb.exe reboot-bootloader', which worked just fine. I reflashed the recovery from here, but that still doesn't fix the problem.

    I've also flashed the correct version of su and have all my su-lovin' apps working correctly.

    Anyone else just not able to boot in to recovery?
     
  10. jpreichart

    jpreichart Lurker

    Anyone know if an airrave will mess with the hands free activation? I am wondering if I should shut it off during the s-off procedure and basically go outside to run the exploit.
    Not sure why but I have an aversion to calling Sprint, especially if they are going to track these things now.
    Thanks so much everyone. Always very helpful.
     
  11. Jays4Life

    Jays4Life Lurker

    -_- I am disappoint... and i'm sure I messed up somewhere I doubt it's the case.

    I downloaded the drivers, installed them. Ran the .exe, entered the necessary info, ran the bootloader, and it froze on the Magenta banner for 20 minutes. I then chose "next" as a restart, and it booted up no problem as well as hands-free update, but afterword I can't send any sms out, I believe it was code "62" or "64". I then tried to connect it and run the software to the phone as I first did, and it didn't recognize the phone!

    HALP!!!

    EDIT: just did a battery pull, and verified it's S-OFF. Still having code 64:2 with SMS, e-mail downloads and browser/marketplace work without a hitch =/
     
  12. jersey221

    jersey221 Android Enthusiast

    wait let me get this straight sprint will service rooted phones now?


    can i get a link?
     
    michaelgrbbs likes this.
  13. novox77

    novox77 Leeeroy Jennnkinnns!
    Thread Starter

    jersey221 likes this.
  14. z50king

    z50king Well-Known Member

    HEYY OHHH!!! I am writing to you on my laptop via Barnacle on 3g!!! woohoo i am so excited

    I was helped by a nice guy on the xda chat last night, well up all night, and i am using Barnacle for the first time!

    I used Revolution, like in the OP, then use the fixed version of s-off and then got a nandroid via TeamWin recovery!

    I have learned so much from here on Andriod Forum and also from all that I did tonight. I got the error 16 after about 10 minutes of not getting error 16 while I was trying to make calls out and use 3g. Talked to the nice lady on the phone with Sprint and she cleared it up after taking passwords and name and phone number.

    This was fun! Rooting, S-off ing, and recovery/backup is fun!!
     
    novox77 likes this.
  15. novox77

    novox77 Leeeroy Jennnkinnns!
    Thread Starter

    anyone else think of Red Hot Chili Peppers? :)
     
  16. z50king

    z50king Well-Known Member

    I listen to what you SAYY OHHHH
     
  17. Stix

    Stix Newbie

    I cannot get the phone connected to computer i installed sdk and plugged in phone and I get nothing :/

    Revolutionary screen I just get waiting for device
     
  18. novox77

    novox77 Leeeroy Jennnkinnns!
    Thread Starter

    You need the HBOOT drivers. Go back to the Revolutionary doc page. There's a link to get the drivers.
     
    Stix likes this.
  19. Stix

    Stix Newbie

    Well it now will not give me the ability to update PG86IMG.zip. ..... fixed it had .zip .zip had to erase one :)
     
  20. Knewz

    Knewz Android Expert

    Anyone else having problems with TB? With temp root this was pretty much the only app that worked, now ironically its the only root app that does't.
     
  21. Jays4Life

    Jays4Life Lurker

    Help? Somebody? Please?
     
  22. wake69

    wake69 Android Expert


    Call sprint cs they have to fix
     
  23. wake69

    wake69 Android Expert


    It's something with the files created in temp root /data/bin I believe there is su there that needs to be deleted
     
    Knewz likes this.
  24. Jays4Life

    Jays4Life Lurker


    Spoke to them on the phone as well as eChat, had me resetting using ##72786# and then ##3282# and entering the code they provided me with, amounting to me receiving the same codes but now I can't get through HFA :(
     
  25. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    I had the same exact experience and symptoms as you to a T.

    I stayed on the phone until they got an upper level tech (staying cheerful the whole way through).

    In my case, she noticed that one part of my code wasn't updating with the OTA activation goodies they were pushing thru. By coincidence, my old Evo 4G was still on (she asked) so I turned that off and it went thru when she tried again.

    She couldn't honestly tell if that other old phone was mucking things up or coincidence, but she said coincidence. Just tossing that out there in case you have your old phone on as I did because you just never know.

    Usually, you get voice, no data, I was upside down on that like you are.

    Here's your most important things:

    1. Keep the faith.
    2. Do not panic.
    3. Stay friendly with the tech, they're going to have to stick with you - if you stay very friendly, they stay very relaxed and can think easier.

    Finally, do not babble about rooting. Sorry to be blunt, but there's no need to sidetrack them from their known procedures.

    Simply say you did a hard reset of your phone and you have data but not voice - and that you reset it because something you downloaded seemed goofy. They have some little-used procedure to fix this, and you have to stay patient because all I know about that is the simplified and sanitized version.

    Say you read someone on the internet had this same problem and someone named Joy knew how to fix it. (Joy is VERY nice.)

    Took me over an hour just with the senior tech (Joy), but - it is solvable.

    Make sure the line you're talking to the tech on has a full charge if it's a wireless handset on your home line.

    PS - Even though voice doesn't work - to get through to them, dial *2 on your phone, then the top menu selection to get support - dial 0 when given choices 1 or 2.

    Keep it simple:

    1. Reset because you downloaded something goofy.
    2. You have data but no voice.
    3. HFA is not working.

    4. No long stories. ;) (can't stress that enough)

    Best luck!
     

HTC EVO 3D Forum

The HTC EVO 3D release date was July 2011. Features and Specs include a 4.3" inch screen, 5MP camera, 1GB RAM, Snapdragon S3 processor, and 1730mAh battery.

July 2011
Release Date
0
Reviews
Loading...
Tags:

Share This Page

Loading...