1. Are you ready for the Galaxy S20? Here is everything we know so far!

[CDMA] Perma-temp root successful.... But WiFi tether says "Not Rooted"..??

Discussion in 'Android Devices' started by drew4392, Sep 20, 2011.

  1. drew4392

    drew4392 Lurker
    Thread Starter

    I've spent hours reading and researching... so I come to you all after exhausting my searching ability... please help :-/

    I followed all perma-temp rooting instructions and did it successfully. Zedomax's tutorials were great, and my root results followed his exactly.

    But... things went awry went I launched WiFi Tether (the app he/htcevohacks.com recommends). As soon as I launched it, I got a prompt about a kernal or my device not being rooted. Two options after that... ignore or exit. Both lead to fails.

    I don't understand why it doesn't work. Rooting went well, but app says I'm not rooted.

    Any ideas???

    Thanks!!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. DonB

    DonB ♡ Truth, Justice and the American Way !! ♡ ™
    Moderator

    Should work, have you tried the Wifi tether Beta

    WiFi Tether for Root Users 3.1-beta5

    settings that works for me:

    Version (latest on code.google.com): 3.1-beta5
    Device-Profile: HTC Evo 3D
    Setup-Method: Auto
    Enable WiFi-Encryption: On
    Passphrase: hey wait a minute I'm not telling you that!!!
    Hide SSID: Off
    Change Channel: didn't touch it
    WiFi-driver reload: On (which was the default)
    Enable Access-Control: On
    Change Lan: didn't touch it
    MSS clamping: On
    Routing fix: On
    Change preferred DNS: didn't touch it
    Change alternate DNS: didn't touch it





     
  3. drew4392

    drew4392 Lurker
    Thread Starter

    Thanks for responding. I uninstalled the WiFi Tether version I had on there and installed the one you recommended.

    Same thing. The exact message is: "Sorry, but your kernel does not have all necessary features for running this application."

    Should I disable USB debugging after I root? That's the only thing I can think of that I didn't do.

    Any other ideas?

    Thanks again!
     
  4. DonB

    DonB ♡ Truth, Justice and the American Way !! ♡ ™
    Moderator

    No, has nothing to do with it.



     
  5. wake69

    wake69 Android Expert

    you used the temp root and not the htc unlock method correct?
    do other root apps work?
    what is your hboot version?
    does su work?
    have you rebooted your phone since you temp rooted?
     
  6. wake69

    wake69 Android Expert

    also, if i remember correctly, wireless tether looks for su in a system folder and temp root does not allow access to system folders. try barnacle tether in the market. When i was temp rooted, that was the only wireless tether app that worked for me.
     
  7. DonB

    DonB ♡ Truth, Justice and the American Way !! ♡ ™
    Moderator

    I think you meant to quote Drew not me ?? LOL



     
  8. wake69

    wake69 Android Expert

    what ever what ever i quote who i want

    lol
     
  9. DonB

    DonB ♡ Truth, Justice and the American Way !! ♡ ™
    Moderator

    LOL, it is working fine for me, Drew is the one having the issues, i was simply trying to help him out, lol


     
  10. wake69

    wake69 Android Expert

    i know i know, but the difference is you are fully rooted and he is temp rooted and the location of su not in a system file is gonna make wireless tether not work. this was an issue before revoultionary
     
  11. drew4392

    drew4392 Lurker
    Thread Starter

    I used the perma temp root. The one that htcevohacks advertises. It's all over YouTube. Seemed like the "main" perma temp root.

    I have not checked other root apps. Thanks for pointing out something I missed... and should have checked. I'll do that when I get home.

    From what I have read, hboot can only be checked when you shut off your phone, then upon power up, you hold down a certain key or something. Regardless, if it involves restarting, that wipes the temp root so hboot wouldn't be reflective of root.... right?

    I believe it's the same with su. Meaning, both hboot and su are listed upon startup.

    Please correct me if I am wrong. To confirm, the only way to check (without restarting) if I'm rooted is to try a root app?


    Thanks!
    Andrew
     

HTC EVO 3D Forum

The HTC EVO 3D release date was July 2011. Features and Specs include a 4.3" inch screen, 5MP camera, 1GB RAM, Snapdragon S3 processor, and 1730mAh battery.

July 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...