1. Check out our companion app, Forums for Android! Download from Google Play

Support Charging Port issue? Not sure what to make of this

Discussion in 'Android Devices' started by Helgaiden, Dec 5, 2011.

  1. Helgaiden

    Helgaiden Well-Known Member
    Thread Starter

    Oct 27, 2010
    For the longest time my phone charged fine on my rocketfish car charger. So did my Optimus before this. One day, the triumph stopped charging on that charger. Jiggled the cable where it plugs into the port and it came up. Then it shut off again. Ok, charger bad right? Bought a new charger, rocketfish premium charger (2a charge for faster charging), and it didnt work at all. Except it does work on other phones/devices (like my gf's Nexus S). The micro USB cable i use to charge my Logitech g930 headset worked...now it doesnt. I have a few Samsung micro USB cables that i know work, but wont work with my phone. My HP Touchpad charging cable works great on my phone, and so does the motorola cable it came with. Thats fine. If the phone didnt work with certain cables right out of the box, id understand its pickiness. But for it to work with nearly every cable i plugged into it, then stop and only work with a few select cables doesnt make sense. This has me wanting to exchange it for another Triumph. Any ideas?

    Im on Tickerguy's CM7 rom, B06 i think (right before the haptic feedback fix). It started doing this while on the stock rom though and has persisted into the CM7 ROM.


  2. nyislanders

    nyislanders Member

    Jun 27, 2011
    I've been having this issue as well. It just started happening within the last 2 or 3 weeks. It's really annoying. I was at a friends house and my phone was dying, so I plugged it in to his charger with no luck. Tried plugging it in several time until it started, then stopped. I finally got it to charge after sitting there for 10 minutes playing with it. It works fine with the Motorola charger and a micro USB cable I have plugged in to my computer. No idea what's going on. I'm running the latest MIUI rom.
  3. marc12868

    marc12868 Well-Known Member

    Oct 19, 2011
    Tier 2 Tech Support @ At&t
    Spokane Valley, Washington
    I haven't had any problems with it, but then again I've only tried 1 other cables... But my guess would be motorola made the cable and phone so they only work with each other (with some other cables working), to get more money... I took a closer look and it appears that the OEM cable has 5 wires instead of 4... if you look in the micro usb part you can see it... It's been a while but I don't think other cables have 5 they have 4... So it may be a ground, positive, data +, data -, and some sort of security check type of thing... Then again I could be totally off... correct me if I'm wrong...
  4. agentc13

    agentc13 Daleks Über Alles

    Aug 31, 2011
  5. thangfish

    thangfish Well-Known Member

    Sep 17, 2011
    I'd put my money on a worn / damaged port on the phone. Key info : cable that doesn't work, does, (even intermittently) after playing with it for a while.
  6. rondizzled

    rondizzled Active Member

    Nov 2, 2011
    Yea I've gone through two phones same problem. The port gets damaged. It will eventually not work at all and then you can get a new phone.

Share This Page