1. Are you ready for the Galaxy S20? Here is everything we know so far!

Charging problem

Discussion in 'Android Help' started by uncivilized savage, Nov 9, 2019.

  1. uncivilized savage

    Thread Starter

    I have a Moto e6 it only charges when it's hooked up to a pc. Please help me fix this problem .I ready become developer. Activated USB debugging, my phone doesn't have mtp option. Thanks in advance

    1. Download the Forums for Android™ app!


  2. James L

    James L Android Expert

    Probably the cable or the charger box that's an issue. Try a different one.
    tube517 and ocnbrze like this.
  3. lvt

    lvt Android Expert

    It has nothing to do with the developer menu, try another charger and cable.
  4. uncivilized savage

    Thread Starter

    Thank you but I have tried 10 different ones
  5. lunatic59

    lunatic59 Moderati ergo sum

    With Android 6 or 7 (don't remember) the default connection method is "charge only" so when you connect to any USB port, you should see a notification. Pull down the bar, tap on USB options and select MTP mode. Then you should see it pop up on your PC as storage.

    If you can't then you either have a bad cable or a bad port.
  6. svim

    svim Extreme Android User

    Well I wouldn't dwell too much on the USB debugging option or things like MTP/PTP/mass storage settings, they all are relative to USB data transfer issues and don't have anything to do with power/charging issues. Try focusing more on the power source as the problem. Since you're able to charge your E6 up using a USB port on your computer that at least that eliminates the USB port in your phone and the USB cable as the problem. (...and more confirmation considering you've tried different cables). So that leaves the power adapter as the problem. Oh and don't forger to restart your phone if you haven't already. That alone solves a lot of mystery glitches that might pop up. If the problem remains after a reboot at least you know it's not just a temporary issue but rather something that needs to be addressed. Anyway, how long has this problem been occurring? Did it just start happening recently or since you got this phone? If you have another power adapter you should try that out. Or confirm the power outlet the adapter is plugged into is OK. If the adapter is plugged into a power strip, check the on/off switch if it has one.
    Sythu likes this.
  7. bonod

    bonod Lurker

    probably the problems are.... usb port which is dirty.... the charger cable which is unsuitable for the device..... or the battery stats was error due to uncorrectly charging method. If this happend.. just calibrate your battery stats.
    bbeasley9862 likes this.

Share This Page