1. Are you ready for the Galaxy S20? Here is everything we know so far!

china telecom fix for superpad

Discussion in 'Android Devices' started by mart21, Apr 29, 2012.

  1. mart21

    mart21 Lurker
    Thread Starter

    Hi all, new to this site so need a bit of help. could spend hours trawling internet for answer so thought id just ask.

    just got a superpad vi. not bad but have issues downloading apps as the sites think i'm in china. need to know if there is a quick fix to change pads I.D from china to uk. from what i've read so far this is a china telecom issue.

    thanks

    mart
     


  2. mikedt

    mikedt 你好

    Moved thread into General Tablet Talk.

    Hi Mart, welcome to AF.

    It's most likely got a Chinese app store and Chinese software. It just assumes it's at home in here in China, as it probably wasn't intended to be exported. Did you buy it on Ebay?

    Of course China Telecom doesn't provide service in the UK, however your tablet doesn't know that. Think you'll have to find a way of re-flashing it to European software, so it wont feel quite so homesick.

    There might be some info about changing the software on the internet, but be aware there are several different devices called Superpad AFAIK.
     
  3. mart21

    mart21 Lurker
    Thread Starter

    bought it from amazon. have issues downloading apps as i get a error, basically saying not for this location i.e china. tried to get skygo but because tablet is chinese skygo wont download.
     
  4. mikedt

    mikedt 你好

    I just tried SkyGo from Google Play and getting "This app is incompatible with your China Mobile Samsung GT-I9000.". It definitely doesn't like China.

    Your tablet probably doesn't have Google Play on it. I think you're going to have to change the software/ROM somehow, if that's possible. "China Telecom" is probably embedded into the software. China Telecom(ChinaNet) is one of the main ISPs here.

    Bought from Amazon, but was it shipped from Guangdong Province or something? I'm sure what you've got was intended for use in China and not exported. It happens frequently though.
     
  5. mart21

    mart21 Lurker
    Thread Starter

    What I've found out so far is that I need to root the tablet then change some code in the system. Will post my results on here in a few days when I've managed it.
     
  6. mikedt

    mikedt 你好

    Let us know how you get on with it. :)
     
  7. Tenerife133

    Tenerife133 Lurker

    Have you found a solution yet?
     
Loading...

Share This Page

Loading...