Help Chmod failed: EPERM (Operation not permitted)



Hi I tried to install an apk (from android-python27 project) which unzip and chmod some files in my storage, but I get the following Error (samsung s5 API 21):

Unzip extracted /storage/emulated/0/
01-18 17:08:54.403 20996-21039/ W/FileUtils: Failed to chmod(/storage/emulated/0/ android.system.ErrnoException: chmod failed: EPERM (Operation not permitted)

When I try to install the apk in my another android device (s3 mini API 16) it chmod with success. I also tried to chmod via adb but it doesnt work.

So is there a way to solve this matter? Thanks in advance...

scary alien

not really so scary
I'm pretty sure that this is because the FUSE mounted "SD card" (your /storage/emulated area) does not support chmod:

It's not related to the change in storage permissions introduced in Kitkat (I verified that my 4.1 GNex also refuses to chmod a file on it's FUSE-mounted /sdcard).

If it worked on your S3 Mini, then it's SD card must not have been mounted with FUSE (or the target of the Python extract was not your SD card)?