1. Download our Official Android App: Forums for Android!

Support Choose between Wireless and Edge

Discussion in 'Android Devices' started by bcetin, Apr 21, 2011.

  1. bcetin

    bcetin Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Apr 21, 2011

    Apr 21, 2011
    3
    0
    5
    Hi,

    I'm using HTC Desire HD but I have this odd problem; when both Edge and Wireless connections are active and available, my device always prefers Edge. I'm mostly using my phone for reading e-mails, so I realised this when my monthly bill came double :) When I look at the details of the bill, it's all Edge connections.

    Is there any way I can change this behaviour or am I bound to turn off Edge when I want to use wireless?

    Thanks for any help..
     

    Advertisement

  2. Harry2

    Harry2 Android Expert
    Rank:
    None
    Points:
    323
    Posts:
    5,181
    Joined:
    Jun 3, 2010

    Jun 3, 2010
    5,181
    1,341
    323
    Black Forest
    I take it, Wireless connection means WiFi.

    So, look at the strength of your WiFi signal at your place.
    In my house, I have several places with very weak WiFi.

    Harry
     
  3. bcetin

    bcetin Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Apr 21, 2011

    Apr 21, 2011
    3
    0
    5
    Hi Harry,

    Yes I mean WiFi. I'm new to this subject and terminology.

    My Wireless router is in a place like the "center" of the home and signal stregth is usually at maximum or very close. I also use wireless connectin with my desktop computer in my bedroom with max signal.

    Sorry but I could not understand the relation with WiFi signal strength and my question. I would like my phone to use WiFi when both Edge and WiFi are available. For now, it always chooses to connect with Edge.
     
  4. matt268uk

    matt268uk Newbie
    Rank:
    None
    Points:
    36
    Posts:
    13
    Joined:
    Feb 21, 2011

    Feb 21, 2011
    13
    2
    36
    Ringwood,UK
    Thats strange that your phone chooses edge over wifi when you have a good signal,if you want to make sure you are using wifi while your at home, just go to settings,wireless and networks, and turn off your mobile data when you are at home,its probably a good idea not to have them both on at the same time anyway due to battery consumption, hope this helps....
    Matt.
     
    bcetin likes this.
  5. Harry2

    Harry2 Android Expert
    Rank:
    None
    Points:
    323
    Posts:
    5,181
    Joined:
    Jun 3, 2010

    Jun 3, 2010
    5,181
    1,341
    323
    Black Forest
    The WiFi symbol in the statusbar shows me the signal strenght.
    When I enter my house, the WiFi symbol replaces the Edge symbol (and the phone changed automaticly from Edge to WiFi).
    But in my kitchen is a very poor WiFi signal.
    So, when i enter my kitchen, the Edge symbol replaces the WiFi symbol (and the phone changes automaticly back Edge).
    So, I don't place my Desire HD for long time in my kitchen :D.

    That is, what I meant with WiFi signal strength at different places.

    EDIT: But if your WiFi signal strength is good at all places at your home, then your DHD shows a strange behavior.

    Harry
     
    bcetin likes this.
  6. ajh94

    ajh94 Android Expert
    Rank:
    None
    Points:
    148
    Posts:
    1,072
    Joined:
    Dec 15, 2010

    Dec 15, 2010
    1,072
    73
    148
    Orange Telecomunications, Product marketing!
    Essex, UK
    My Desire used to always choose GPRS "G" over Wi-Fi in my house, but that was when i was using sense, I am now running GV which is of course a different ROM and now it doesn't do that anymore :p i have no idea why it did
     
    bcetin likes this.
  7. bcetin

    bcetin Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Apr 21, 2011

    Apr 21, 2011
    3
    0
    5
    Thanks everyone. So you say that it must choose according to which signal is better. Maybe my operator's edge signal is much better than I thought :rolleyes:

    Maybe switching to a different ROM like ajh94 may solve the problem.
     
Tags:

Share This Page

Loading...