1. Are you ready for the Galaxy S20? Here is everything we know so far!

Citrix Receiver

Discussion in 'Android Devices' started by chinoxl21, Jan 6, 2010.

  1. chinoxl21

    chinoxl21 Newbie
    Thread Starter

    Hello everyone. Has anyone tried using the Citrix Receiver app? My will not connect or it will say You don't have the proper encryption level to access this Session. Of course some of my co-workers have iPhones and it works flawlessly...so I'm a little bummed that I used the exact same settings and it doesn't work. Just wondering if anyone has used it or tried it.


  2. hotrod98

    hotrod98 Lurker

    Did you connect to your company's VPN before trying to launch an application? Are you actually seeing the apps that the admin has made available to you?

    The tech preview of the Android client may not support 128bit encryption. Citrix did the same thing with the tech preview for the iphone and then included encryption support with a later update.

    Citrix admin here so fire away :)
  3. denacho

    denacho Lurker

    CHINOXL21, were you able to this resolved? hotrod98, can i pick your brain? i'm having issues connecting to my PS4 PNAgent site. ours is a remote site (so no VPN involved) and i basically get a connection error when i try to connect:
    Invalid Address - The address cannot be found. Check the address & your network connection.

    we use Secure Gateway (not Access Gateway) so i don't have the SAG checked for the connection. site and login credentials are correct but i only get the error above. curious if you can help me & happy to give more info if you need.
  4. mothy

    mothy Well-Known Member

    I thought I read that you can only access the demo accounts as it is only a demo of the receiver.
  5. denacho

    denacho Lurker

    oh i hope that is not correct. i was able to access the Demo site. i did have a half-way successful connection to our test site. our Test site is a purely internal web interface. so using my droid, i got on our wireless network, created an account for our Test environment with the following:
    Address = servername.domain.org
    username = myusername
    domain = domain.org
    description = Test site

    i did not select CAG since we don't use that (internally or otherwise). the only difference i had with our Test site was i was able to see "some" icons for published apps but not all. and then when i tried to launch any of the apps that did show, i got "Server Error: The server encountered an error. Retry Cancel" at which point i cancelled. i did read a couple tidbits that said Receiver did not like anything with 128-bit encryption (specifically addressing iPhones) so i changed a couple apps to Basic but got the same message.

    the difference at this point though is i cannot even connect to my production site which uses Secure Gateway (not CAG) and is in our DMZ. and i'm not having any luck finding anyone using this on Droid, iPhone, etc.
  6. denacho

    denacho Lurker

    i did find a Citrix Community article that does not list PS4.0 as being supported (Citrix Receiver for Android Requirements XenApp - Citrix Community) even though the eDocs from 3.30.2010 say it is. we are trying to get a XenApp upgrade prioritized so i may use this as leverage and stop beating my head against the wall trying to get it to work in 4.0 at this time.
  7. chinoxl21

    chinoxl21 Newbie
    Thread Starter

    Hey denacho my problem was resolved. Funny you should ask. I so happened to download Citrix again from the market place yesterday, configured my settings and it works great!
  8. denacho

    denacho Lurker

    unfortunately didn't work for me. same Invalid Address error. is your Citrix environment anything like mine?
    PS4.0 running Web Interface in our DMZ with Secure Gateway 3.0.

    our users are all "outside", that is we don't use Citrix internally. so users go to a secure (https://) site and log into Citrix for apps. i created a PNAgent site on my WI server (alongside the usual WI site that "pc" users access). i've tried entering the Address in the Receiver Account as myserver.mydomain.org and https://myserver.mydomain.org with both getting the Invalid Address error.

    can you tell me a little about your Citrix WI and/or PNAgent setup?
  9. stpolo

    stpolo Lurker

    Listening.........same issue here.......
  10. denacho

    denacho Lurker

    i'll keep posting here as i find more. i actually have a case open with our Citrix reseller. we'll see what happens.
  11. denacho

    denacho Lurker

    my citrix support tells me it's not supported on PS4.0 and specifically WI4.0 site. that can further be seen from this eDocs chapter. but i pointed out to them, this same eDocs chapter said something different yesteday and had a 3/30/2010 updated date on it. today it says 4/2.2010. whatevers.

    i did confirm that i can keep my PS4.0 environment and 4.0 WI box but i will need to build a second 5.x WI server if i want to serve up a PNAgent site for Android devices. i'll be doing that while i wait to get moving on my XenApp 5 upgrade to the farm.

    hope this helps someone besides me!
  12. curtmcgirt

    curtmcgirt Lurker

    what's terrible is that the iphone receiver has no problem accessing apps from my web interface 4.0 PNAgent site behind Citrix Secure Gateway (CSG) 3.0.

    it's just the android receiver that doesn't work.
  13. stephen_se9

    stephen_se9 Lurker

    I got into my work desktop using my HTC Desire on the basis of your posting. Thanks.
  14. petey23

    petey23 Lurker

    Are you using internal certificates? That seems to be a bit of a problem for Android.
  15. petey23

    petey23 Lurker

    Can you connect if you choosed to connect via Access Gateway Standard with "No Auth" - that should be the same basic authentication as Secure Gateway. Put the CSG address in the "address" box.
  16. daleb

    daleb Lurker

    I was getting the dreaded Authentication Failed. Check your settings or contact your administrator. We use the Citrix Secure Gateway ver 4.5. Iphone users were getting in fine. Here are the steps to resolve my issue: Uninstalled the Citrix Labs Receiver and installed the Citrix Receiver version 2.1.1059. When that still did not work, I signed up on the Citrix demo cloud so I could verify that the app actually worked and I was able to get into the Citrix Cloud demo fine. Based upon comments regarding Android and Secure Certificates, I then installed FireFox and added the Secure Certifcates add-on plugin. I then accessed my secure Gateway site and logged in via Firefox. While I could not launch any apps (Citrix client detention is for Windows platform), I suspected that I now had a valid Citrix certificate installed. I then added a second store to the Citrix Receiver app, using only the fully-qualified hostname of our secure gateway, my userid and domain. When I clicked OK, I was then prompted for my domain password and was able to see the published apps for my userid. After I got back out of the app and edited the store, I noticed that the Web Interface and Use Citrix Access Gateway options were Greyed out and not enabled (Green Check). Hope this helps those still having issues. Now, if I can get the keyboard input method figured out, along with windows sizing, I will be good to go.
  17. mgullick

    mgullick Newbie

    I can connect to my server and see all of my apps but they won't open. I just get a message stating there is a server error. I can cancel or retry. It works fine for the iPhone folks in my department but doesn't work for me on my DINC 2. With all the Android folks out there it seems this shouldn't be such a problem.
  18. kufel

    kufel Lurker

    This is the response I got from Citrix. I just clicked "email developer" in the Market...
    We have to wait just a little:

    We have discovered an issue with our SSL implementation and the new Ice Cream Sandwich (Android 4.x) implementation. They have changed the security infrastructure but it did not show up on our emulators. We are actively working to resolve this issue as quickly as possible. We have temporarily removed the Receiver for download to 4.x devices. Please watch for updates coming shortly, with the holidays it will most likely be in January.

    Thanks for your feedback and watch for the update.


    Robin Manke-Cassidy
    Director Product Management
    T: +1 408 790 8342 (x23342) | M: +1 480 203 6700
  19. sunnyjim

    sunnyjim Lurker

    Hi Robin,

    I can't get it to work on my Samsung Galaxy Tab 10.1 with ICS. It sees the desktop apps but when I try to connect, it just spins away with no action. Any suggestions?


HTC Droid Eris Forum

The HTC Droid Eris release date was November 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7600 processor, and 1300mAh battery.

November 2009
Release Date

Share This Page