1. Check out our companion app, Forums for Android! Download from Google Play

Root clockwork recovery - can't recover signature verification failed

Discussion in 'Android Devices' started by livefree, Oct 21, 2010.

  1. livefree

    livefree New Member
    Thread Starter
    5

    Oct 21, 2010
    2
    0
    5
    I had a stock Captivate with Eclair J6. I rooted and installed Rom Manager with ClockWork Recovery. I made a backup of my current ROM.

    I then installed the Cognition Froyo Beta. I decided I wanted to roll back to my backup ROM but whenever I reboot into Recovery, I no longer get any option of installing a ROM, update.zip, etc. All I get is a shortened menu that says "reboot, clear cache, wipe user data, wipe internal SD card". I also get an error that says signature verification failed.

    I tried reflashing the recovery area with a new clockwork update but I get the same result when rebooting into recovery. How can I restore my recovery area to a working state with the normal options?

    Thanks
     

    Advertisement

  2. james27007

    james27007 Look into my Eye
    183

    Mar 6, 2010
    1,150
    445
    183
    Male
    Travel and teaching for tech and automotive
    Riverside, CA
    livefree likes this.
  3. dayv

    dayv Member
    16

    Sep 13, 2010
    24
    2
    16
    The initial froyo leak and cog 2.2 beta 1 through beta 5 came with a kernel that has stock recovery version 3e - rom manager will not work with this. You need stock recovery 2e to get rom managers clockwork recovery to work.

    You two or three different options - but since your are wanting to go back to your saved eclair rom the easiest way would be to use one click odin3 back to stock (link below), then root your phone again, install rom manager again, then you can restore your nandroid backup you have saved (keep a copy of your nandroid backup in a safe place).

    [STOCK ROM] Odin3 One-Click Downloader and Drivers CAPTIVATE ONLY - xda-developers
     
    livefree likes this.
  4. livefree

    livefree New Member
    Thread Starter
    5

    Oct 21, 2010
    2
    0
    5
    Thanks for the info guys! I couldn't find anything else about this. :)

    Quick question: since clockwork does not work with Froyo, what is an alternative to make a current ROM backup?
     
  5. dayv

    dayv Member
    16

    Sep 13, 2010
    24
    2
    16
    I don't know of any easy method for an easy back up of a ROM other than ROM manager.

    Clockwork recovery will work with froyo, you just need a kernel that has version 2e stock recovery. There is allot of info on how to get 2e recovery in the dev section on xda forums.

    Be sure you know what your doing if you attempt any of the kernel swap methods - there is a significant risk of bricking if not done correctly.

    the easiest way and safest way (note even though this is a "safer" way any time you flash your phone there is always some risk) to get 2e recovery on froyo would be to flash back to stock then flash one of the latest cog 2.2 betas - the latest betas contain 2e recovery.
     
  6. james27007

    james27007 Look into my Eye
    183

    Mar 6, 2010
    1,150
    445
    183
    Male
    Travel and teaching for tech and automotive
    Riverside, CA
    take a look back at my original reply; you need to flash the kernel that has the 2e recovery, then clockwork will work. That kernel is a froyo kernel so you will not loose anything flashing :D

     
  7. Inous

    Inous Member
    36

    Aug 4, 2010
    22
    2
    36
    Naval Aircrewman
    San Diego / Temecula, CA
    Helpful post but I have a question.... How do you place the Kernel in the PDA slot when there isn't a PDA slot? All I see is this...

    [​IMG]
     
  8. CrimsonPride

    CrimsonPride Well-Known Member
    143

    Jul 28, 2010
    1,482
    200
    143
    student
    north alabama
    that is the reset odin. there is another odin that has several tabs down the side of it. i really dont know where you would download it, unless you download cog 2.2b3 which has the correct odin with it
     
  9. james27007

    james27007 Look into my Eye
    183

    Mar 6, 2010
    1,150
    445
    183
    Male
    Travel and teaching for tech and automotive
    Riverside, CA
    [edit] Nevermind, just download and use the attached version of Odin. This is not a one click, you need to download the kernel from the above post and put it in the PDA slot
     

    Attached Files:

    mpetroline likes this.
  10. mpetroline

    mpetroline New Member
    5

    Dec 31, 2010
    1
    0
    5
    I joined because I am also having the same problem. I cannot however flash back to eclair. I have tried 4 ways to get back and nothing seems to work. Is there a way to do this that always works?

    Edit: more info

    I used odin 1.3 to flash to the pre-released froyo. I tried to root then figured out that does not work. Looked around for the answer and stumbled here. joined to try this method out. It did not work. I suspect I am doing something wrong.
    I downloaded this version of odin and the jkernal file, put it in the PDA area. restarted in download mode and hit start on odin. It seemed to work, but when I check I am still 2.2.

    I might be going about this wrong btw. I am trying to root the pre-released version of froyo. I know I cannot just put the update.zip file into the root folder because of the sig problems. is there another way?

    Edit:2

    I used the xda forums method to find an answer The pages most useful to me

    http://theunlockr.com/2009/10/06/how-to-set-up-adb-usb-drivers-for-android-devices/

    and

    http://forum.xda-developers.com/showthread.php?t=725555

    These two pages allowed me to root the leaked 2.2 xda update. If anyone has any questions PM me
     
  11. james27007

    james27007 Look into my Eye
    183

    Mar 6, 2010
    1,150
    445
    183
    Male
    Travel and teaching for tech and automotive
    Riverside, CA
    @mpetroline

    Hello and welcome

    The issue there is the leaked foryo has a locked recovery menu that requires the update.zip to be signed; well the devs don't have the keys to sign the update.zip correctly; so you cannot use clockwork recovery, rom manager or any update.zip with the leaked version. To fix that you need to flash the hacked froyo kernel here Captivate JI6 kernel with "2e recovery" enabled - xda-developers

    Just make sure when you open odin to right click odin and select run as administrator.
     
  12. reinbeau

    reinbeau Klaatu barada nikto
    163

    Sep 14, 2010
    1,333
    218
    163
    Pilates Instructor
    South of Boston, MA
    So, if one could just flash that kernel, and then the leaked 2.2 update, and be on 2.2? Is it that simple?
     
  13. james27007

    james27007 Look into my Eye
    183

    Mar 6, 2010
    1,150
    445
    183
    Male
    Travel and teaching for tech and automotive
    Riverside, CA
    That is backwards, if you flash the leaked 2.2, it flashes a new kernel. So Flash the leaked 2.2 with the new odin one click; that puts 2.2 on your phone. Then when that is done, flash that kernel. Doing that will then flash the kernel with the unlocked recovery menu so you can use the update.zip files and not get the signature error. You only need to flash that kernel if you plan on using an update.zip file in the recovery menu or using rom manager.
     
  14. monsterbot

    monsterbot New Member
    5

    Feb 15, 2011
    1
    0
    5
    Just want to say thanks for this information. I spent a week looking for the answers to get around the "E: signature verification:" error from the startup menu after loading up to Froyo (rooted). Nobody else had the answer and most responses were something like "follow all the steps in this 90-step manual".

    Lo and behold, it had to do with the updated kernel.

    Anyway, thanks!

    MB
     
  15. reventon

    reventon Member
    16

    Nov 30, 2010
    23
    1
    16
    need help

    i am trying to install cognition 4.3. the guidelines posted says have to use clockwork to install it.

    So when i try to run it and select the cognition zip file and restarts, it gives me blue fonts only.

    i installed the JI6 kernel with 2e recovery in order to get it working but no luck.

    any ideas? Have froyo 2.2 installed.
     
  16. james27007

    james27007 Look into my Eye
    183

    Mar 6, 2010
    1,150
    445
    183
    Male
    Travel and teaching for tech and automotive
    Riverside, CA
    When you boot into recovery and see the blue screen, you are still on the stock recovery, you need to select "reinstall packages" to get the phone to reboot into clockwork recovery.

    Note when you install clockwork it places a "update.zip" file on the internal sdcard; when you reboot into recovery if it does not automatically go into clockwork, just select the reinstall packages and it will run the update.zip file and boot into clockwork recovery.
     
  17. reventon

    reventon Member
    16

    Nov 30, 2010
    23
    1
    16
    when i click reboot in clockwork recovery from rom manager, it restarts phone. again blue font - stock recovery comes up. when i select reinstall packages, it tries to verify update but fails.

    following error

    failed to verify whole-file signature,
    signature verification failed
    installation aborted.

    there is also a 3-button method for clockwork recovery. even doing that takes me to stock recovery. at the top it says android system recovery <3e>

    any suggestion?

    thanks

    update *** flashed it to <2e> and now it works.

    the problem is, when i am trying to install CM-7, its not installing rom. half way through update process, it quits back to my current 2.2. any pointers why its happening?
     
  18. poptate

    poptate New Member
    5

    Dec 3, 2010
    1
    0
    5
    Hi I'm having the same problem as rementon, but I don't know how to flash to 2e. I'm trying to get cyanogenmod on my phone, and according to the wiki in order to do that I have to flash a kernel using Heimdall.

    The problem is I have a Mac, and the Heimdall 1.1.1 suite that's listed in the instructions doesn't work. So I don't know if I can flash it to 2e. Should I be flashing the Captivate J16 kernel that's floating around?

    Or is there a way to do it with the newer Heimdall 1.3.1?

    Any answer would be greatly appreciated. Thanks.
     
  19. james27007

    james27007 Look into my Eye
    183

    Mar 6, 2010
    1,150
    445
    183
    Male
    Travel and teaching for tech and automotive
    Riverside, CA
    I do not have or know how to use a mac but after looking around it looks like you need something called bootcamp? I found this link: Mac 101: Using Windows on your Mac via Boot Camp

    Should give you the windows environment you need to run the stuff in post #2

    Good luck
     
  20. xboxhaxorz

    xboxhaxorz Member
    5

    Oct 29, 2011
    6
    0
    5
    i just did the 2e flash and now my phone is stuck at the at&t logo
     

Share This Page

Loading...