1. Are you ready for the Galaxy S20? Here is everything we know so far!

Clockworkmod freaking out on me?

Discussion in 'Android Devices' started by derek533, Aug 4, 2010.

  1. derek533

    derek533 Member
    Thread Starter

    I currently have stock 2.1 rooted with rom manager installed. I used the DMupdater to obtain root two days ago and everything worked fine and had SP recovery on it. I then installed rom manager and flashed to clockworkmod. Being OCD about everything, I rebooted and clockworkmod came up. Rebooted again and it went back to the regular exclamation point inside a triangle picture instead of clockworkmod. I then flashed SP recovery using Rom Manager and then flashed back to clockworkmod. Again, worked the first time, but after that, it keeps going back to the regular recovery console instead of clockworkmod.

    Update: If any of you rooted your phone using the Easy Root program from the market or DMupdater (the beta posted at Droid Life) and are having problems with Clockworkmod, you need to reflash SPRecovery console using the tried and true method in all the root guides. You don't have to go all the way through the guide, you just need to get to the point where you use RSD Lite to flash SPRecovery onto the phone. From there, you can then use Rom Manager to flash Clockworkmod back onto the phone and it will "stick" from now on once you have used RSD Lite to flash SPRecovery onto the phone.

    I was having an issue where the first time after flashing Clockworkmod using Rom Manager, it would boot just fine into Clockworkmod. Subsequent attempts would bring me back to the exclamation point inside a triangle meaning no Clockworkmod was detected.

    Seems to be the only fix for this is to use RSD Lite to flash SPRecovery onto the phone. From there, you can then use Rom Manager as normal.

    Hope this helps some of you who may be having issues.

    1. Download the Forums for Android™ app!


  2. OMJ

    OMJ Bazinga

    just read about someone else having this issue. No clue whats causing it. Hopefully someone tells koush about it soon
  3. Lock-N-Load

    Lock-N-Load Android Expert

    thats me and now i am ****** no phone no nothing, just data on a card
  4. OMJ

    OMJ Bazinga

    only thing I notice about this is you both used a one click root app. Dont know exactly how that could cause this but I have never heard of anything like this until now.

    Anyone out there that used DMUpdater (the beta the droidlife posted a few days ago) or Easy Root that is having issues like this. Or even that isnt having these issues
  5. Lock-N-Load

    Lock-N-Load Android Expert

    many people here reported success
    many people on the download page reporting success
    I had fine success and things did not break until after I did a baseband, then within 30 minutes.. POW
  6. OMJ

    OMJ Bazinga

    many people reported success but how many went back and checked their recovery a few hours later.

    Most newly rooted users dont go into recovery very often
  7. derek533

    derek533 Member
    Thread Starter

    I guess the question is now, should I go ahead and just re-root the rsd lite/sp recovery with the Motorola drivers and all and is it even possible to re-root?
  8. OMJ

    OMJ Bazinga

    yea that would be my suggestion. You would only have to flash the SPRecovery sbf file though. You wouldnt have to wipe your rom out or anything. After flashing SPRecovery you could flash back to Clockwork with rom manager and see if it sticks then
    derek533 likes this.
  9. derek533

    derek533 Member
    Thread Starter

    Is that different than flashing SPRecovery with rom manager as I have done that and it still doesn't stick.

    Love your av btw. "I've got a nautical themed Pashmina afghan"
  10. OMJ

    OMJ Bazinga

    it is. Im hoping that it will take out your issue
    derek533 likes this.
  11. derek533

    derek533 Member
    Thread Starter

    Trying it now and we'll see if this fixes the issue. I bet you're right that all of us who used the easy root programs may have this issue but most of us haven't discovered it yet.
  12. BenDroid

    BenDroid Well-Known Member

    A friend of mine wanted his new droid rooted yesterday. I didn't have the time to root it for him using RSD Lite and he got impatient and used the Easy Root app. He managed to get everything rooted fine and even used Rom Manager to install BB 0.4. He called me this morning though and told me that he is unable to get another ROM installed through ROM Manager now (he wants to try CM). But he said that he is getting some error. I am waiting on him to call me back to see what type of error is is talking about.

    Not sure what to tell him. I told him to flash SP Recovery and then flash back to see if that made a difference. We will see.
  13. I too did the one-touch root, using Easy Root. I too have been having issues with ClockworkMod. I decided to go back to my backup I did before installing any ROMs so I could start over fresh. It took about half a dozen attempts before the recovery process would work. It just kept rebooting my phone, and when I would go in to RM it would say the recovery failed, which was obvious. Finally one time it just... worked. Now I am back to my pre-ROM state and ready to try again.
  14. derek533

    derek533 Member
    Thread Starter

    Ok, followed the guide posted to rooting and when I got to the point where I am using RSD Lite, nothing happens. My phone shows bootloader 2c.6c, battery OK, OK to program, Transfer Mode: USB.

    I put the SPRecovery sbf file in the c:\ directory and pointed RSD Lite to using the ... button. When I clicked start, nothing happens. Ideas?

    EDIT* Nevermind, I forgot to install the Motorola drivers first.
  15. derek533

    derek533 Member
    Thread Starter

    Update: Ok, flashing SPRecovery using RSD Lite fixes this issue. I didn't go all the way through your guide OMJ, just to the point where I flashed SPRecovery. Then I used Rom Manager to flash Clockworkmod recovery onto it. Thanks a bunch man.
  16. OMJ

    OMJ Bazinga

    I figured that would do it. Not sure what about the 1 click root apps is causing this but at least now there is a solid solution
  17. Lock-N-Load

    Lock-N-Load Android Expert

    hey man, I was the other casualty here of the clockworkMD Easy Root issue.

    I did the RSD Lite method to flash SPRecovery_ESE81.sbf onto my phone like you. So, you mention that once you did this, then went back into ROM Manager and were asked if you wanted to install clockworkMD you accepted and installed the stock one it just installs and from there you have been stable with it and able to make backup ROMS?
  18. derek533

    derek533 Member
    Thread Starter

    Yes. This seems to permanently fix the issue.

    In the end nothing comes too easy I guess although the tried and tested method isn't too hard either.:D
  19. mrjerryk

    mrjerryk Well-Known Member

    If he is using one of Pete's 2.2 releases you can't use clockwork after that. There is a problem with Recovery and some of the 2.2 ROM's and they won't work with clockwork.

    In ROM Manager select Flash Alternate Recovery at the bottom for SPRecovery 0.99.3b. Then you can flash after copying the update.zip to the phone in SPRecovery. I know this is a pain the ass but this is the only way. Hopefully it will be worked out soon enough. I love to flash on the fly with ROM Manager.
  20. BenDroid

    BenDroid Well-Known Member

    I am getting to the point where I am just going to use SP Recovery from now on. It seems that every problem I run into is due to Rom Manager. I hope they get it fixed, but man it is just making everything so much more difficult. I actually had to use RSD Lite on a phone that had clockwork installed but for some weird reason I could not get it to flash a backup that was made through Clockwork Recovery and the phone would not boot so that I could not just use Rom Manager to flash an alternate recovery.

    Oh well ... we live .... we learn.
  21. OMJ

    OMJ Bazinga

    I think a lot gets blamed on clockwork and rom manager that is not its fault. I have been using clockwork for months and only ever use SPRecovery to help other people and write tutorials. I cannot remember having an issue that I had to flash back to SPRecovery for.
  22. bemenaker

    bemenaker Well-Known Member

    I had CM stop working on me recently. I had to flash and older version of CM reboot, installed the lastest CM again, and then it worked again. SPR worked for me in the mean time.
  23. gnath9

    gnath9 Android Enthusiast

    all I use is rom manager and have only had a couple of hiccups so far (prolly my fault). But I absolutely love it !!! and is the reason I flash so many roms :)
  24. Trofn8er

    Trofn8er Newbie

    I was hoping you could help me...I'm new to rooting. I rooted using Easy Root. I already had SP-recovery installed because I updated 2.1 manually when it first came out.

    Anyhow...I tried installing a custom rom using Rom Manager. I downloaded BB and tried to install it and it got stuck in the recovery...you know the triangle with a phone. I tried it twice but didn't work.

    I see you said I need to re-flash SP recovery using RSD Lite. My question is this...do I need to unroot first? also, can I just flash sp-recovery again or do I need to delete it off first somehow?
  25. emverham

    emverham Newbie

    I updated my unrooted stock 2.1to 2.2 manually, then used easy root, then installed rom manager. I also had some problems with the recovery flash 'sticking', but I just kept flashing until it stuck (it tells u this in clockwork I believe). I then installed the Liquid frozen yogurt rom with the Smoked theme and love it. My phone is snappy, longer idle battery life, and I can use wifi tether, take better pics, and usse the updated google apps. I love the new voice search. I wish I could get bluetooth to accessvoice search instead of the voice dialer. Anyone know how to do that? Or stream video from my pc?

Motorola Droid Forum

The Motorola Droid release date was November 2009. Features and Specs include a 3.7" inch screen, 5MP camera, 256GB RAM, processor, and 1400mAh battery.

November 2009
Release Date

Share This Page