1. Are you ready for the Galaxy S20? Here is everything we know so far!

CM7&GOSMS issue's

Discussion in 'Android Devices' started by BlackGravity, Dec 21, 2011.

  1. BlackGravity

    BlackGravity Android Enthusiast
    Thread Starter

    I'm running TG's CM7 and installed GOSMS (best text app imo) anyhow.. when im in the app texting or messing with making themes,if i get a text while reading a text,it goes straight to my lock screen. i get :sms error report"
    window and have to unlock the app again.

    i can receive send and get pictures.. so it's functioning normal,i just get that error window anytime i get a text.. nor when i send. anyone have or had this issue before?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. DAN040790

    DAN040790 Member

    I've never had that issue before and I've been using it for a while now. Did you make sure to wipe data/cache before and after flashing?
     
  3. BlackGravity

    BlackGravity Android Enthusiast
    Thread Starter

    data.. hmm i really cant remember. ill give that a try .
     
  4. jagris

    jagris Newbie

    When you installed CM7 did you flash GAPPS before first boot? I didn't and I got weird errors with everything on the phone.
     
  5. BlackGravity

    BlackGravity Android Enthusiast
    Thread Starter

    no,i flashed before first boot
     
  6. idbl_fanatic

    idbl_fanatic Android Enthusiast


    Yeah,. you should flash CM7, then right after flash gapps, then boot
     
  7. sharpe351

    sharpe351 Well-Known Member

    That may be your issue. MOST devs will tell you to do a first boot into the ROM before flashing Gapps. This is mostly to let the ROM fully install and get "settled". CM7 is one in particular that I personally have had issues like this come up if I flashed Gapps before first boot. You may want to wipe the phone (system and data) and restart the process. It may be an error in the ROM that came about by flashing Gapps to early.
     
  8. agentc13

    agentc13 Daleks Über Alles

    I have always flashed gapps before booting the first time and not had any issues. That is also recommended by the dev:

    Regardless, I don't think this is the issue. I know I had issues when I used GoSMS (not the same issues as stated here) and the ROM is made to function with the stock messaging app. Any 3rd party apps you use are not guaranteed to work. I got tired of the issues I had, and switched to stock. It has been working great since then.

    I know you probably don't want that recommendation and would rather find a way to make the app work better for you. Have you been able to get a logcat of when it happens? Not sure if it will help much, but it can't hurt.
     
  9. BlackGravity

    BlackGravity Android Enthusiast
    Thread Starter

    yes i do get a log cat.. ill post it when i get the error again so you can see what it says.. and GOSMS worked perfect before u went to CM7,but CM7 is sooo kick arse i will deal with the error :).. hope it can get it fixed.
     
  10. BlackGravity

    BlackGravity Android Enthusiast
    Thread Starter

    here's what it says


    Product=triumph
    PhoneModel=Triumph
    Device=triumph
    AndroidVersion=2.3.7
    Brand=Motorolaunable to parse 'default' as integerjava.lang.IllegalArgumentException: unable to parse 'default' as integer
    at android
    null
     
  11. BlackGravity

    BlackGravity Android Enthusiast
    Thread Starter

    reflashed the rom... problem fixed!
     

Motorola Triumph Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...