1. Check out our companion app, Forums for Android! Download from Google Play

Support Commando not charging from Mophie Juice Pack

Discussion in 'Android Devices' started by teddyki, Apr 10, 2013.

  1. teddyki

    teddyki New Member
    Thread Starter

    Nov 17, 2011
    It seems that a lot of folks are having various problems charging the commando from what I found, and here's another.

    I'm trying to charge my commando from a mophie juice pack duo and all I get is "USB Connection" but my device is not charging.

    To eliminate variables:
    I've tried connecting to the Mophie in all 3 USB modes, and none work.
    The mophie juice pack successfully charges a different android device.
    The cable I'm using for my commando is Motorola brand and works when plugged into the wall.
    I've tried several different cables including the one that came with the Mophie.
    The Mophie does not charge my commando when it is powered off.
    I can charge my commado while plugged into my laptop.
    Mophie has an output of 5V and 2.1A which should be more than enough for the commando.
    The Mophie is fully charged when I'm trying to charge my commando.

    what gives? The only evidence I could find that could be it was on this forum:
    androidforums . com /motorola-droid/18667-droid-charge-through-usb.html

    I couldn't imagine why the mophie would not give the "OK" to supply full power as that's its SOLE purpose, but maybe that has something to do with it. Any suggestions?


  2. dodgef25

    dodgef25 Well-Known Member

    Aug 28, 2011
    A quick guess could be the frequency the pack is putting out. Some power adapters have the output frequency listed most don't, I'm not sure what the phone requires. That has been the issue on my phone before when using 1.2amp and it just wouldn't take it (stock is .875a).
    scary alien likes this.
  3. Willster419

    Willster419 The Casio Smartphone Guru

    Feb 25, 2012
    College Student with Internship at Mercury Systems
    New Hampshire
    As weird as it sounds it might be something with the drivers or information inside this juice pack. When i plug mine into my pc, before all my drivers load it does the same thing, just the usb options but no charging. when the computer is fully loaded, with the casio drivers, then the charging happens. the commando uses non-generic drivers/modes, so that if probably it.

Share This Page