1. Download our Official Android App: Forums for Android!

Support Completely Dead Htc Evo Battery(s)

Discussion in 'Android Devices' started by Major__, Jun 29, 2011.

  1. Major__

    Major__ Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jun 29, 2011

    Jun 29, 2011
    1
    0
    5
    I have had my HTC Evo 4g since November of 2011. Maybe a month and a half after i got it the battery stopped fully charging and eventually it completely died. So i started using the extended battery. Well i dropped it and demolished the screen so i got a new one through insurance. i may only have had it for a month then the battery wouldnt hold a charge and it eventually died as well. So i put the extended battery in it and it completley died within 2 weeks !! last week i took my phone to a sprint repair shop and was told that both of the batteries sure enough was totally deceased so he ordered me a new battery .....YESTERDAY I GOT IT AND TODAY ITS COMPLETELY DEAD !!!!!! I dont understand why this is happening with my phone ! have anyone else experienced these problems ??? what should i do ??? im so frickin upset.
     

    Advertisement

  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
    None
    Points:
    1,923
    Posts:
    23,595
    Joined:
    May 13, 2010

    May 13, 2010
    23,595
    14,436
    1,923
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    welcome to the forums!!!!!!!!!!!!!!!!!!!!!!!
    moved your thread to the troubleshooting section/
     
  3. UPS92008

    UPS92008 Member
    Rank:
    None
    Points:
    36
    Posts:
    34
    Joined:
    Feb 23, 2011

    Feb 23, 2011
    34
    1
    36
    Dead as in wont charge at all or dead as in will die after 4 hours of light use???? =]
     
  4. NegusDropout

    NegusDropout Newbie
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jan 8, 2010

    Jan 8, 2010
    10
    0
    15
    theVillage
    Are you using the same charger? Has it been wet? It is the OEM Charger?
    Just asking because that may the the issue.
     
Tags:

Share This Page

Loading...