1. Are you ready for the Galaxy S20? Here is everything we know so far!

Complex chain of events - good understanding needed. Is my phone correctly s-off,

Discussion in 'Android Devices' started by l1ndon, Apr 11, 2012.

  1. l1ndon

    l1ndon Newbie
    Thread Starter

    Hi- I was looking for some guidance about the state of my phone.

    My question is did I do something wrong along the way that is preventing me from changing partition size, and stopping wifi working correctly (due to kernels?)

    So heres the state

    I recently had my phone repaired (new mainboard) so it was back to
    unrooted
    2.2.2
    s-on
    .93.0001 hboot

    I unlocked it using unrevoked 3.31 (after failing with 3.32)

    I tried s-offing using Revolutionary, but received errors both times saying unsuccessful, however it now says s-off and when I try again it says it is s-offed so wont proceed any further

    (I'm not sure if I managed to correctly install the modified windows htc drivers for revolutionary, I tried, and it executed but nothing happened after that)

    I then tried to install alpharev CM7/r2 hboot via Fastboot commander, and got stuck in bootloop. Fixed by re-installng Bravo stock hboot, and restoring my Nandroid backup

    I then tried to install RSK 7.2 Rom (My SD card was already formatted with ext4 from running v6 previously) but it just hung at Rom start up screen (for 20 mins), rebooted then 100's of FC's.

    Went back to original Rom, installed 4ext then repaired the linux partition on sd card.

    Now I can install whatever Rom I want almost sucessfully - BUT cant change to CM7/r2 partition (or I get bootloop) and the Wifi never works in the rom - (just gets stuck obtaining IP), unless I restore my stock Nandroid backup and it works fine.

    If you can understand all that... thanks
     



    1. Download the Forums for Android™ app!


      Download

       
  2. huy_lonewolf

    huy_lonewolf Well-Known Member

    I think it will be more helpful if you give us your current hboot instead of the original hboot. As far as I know, some ROMs only work with certain hboot, so if you get bootloop with a new hboot, most likely it is because of an incompatible ROM. People usually update hboot first, then flash a new ROM.
    Moreover, this is probably a personal choice, but most people I know recommend putting a zip file in the sd card to change hboot rather than adb, but it probably does not make much of a difference. Btw, when you partition your SD card, have you made sure that the first partition is FAT32 and the second one is Ext4 (it must be less than 2GB)? If I am not wrong, are you trying to use data2SD on your Desire?
     
    l1ndon and Hadron like this.
  3. saltire

    saltire Android Expert

    Not sure how you used Unrevoked as it shouldn't support 2. 2. 2, and you also need the Windows hboot drivers setup for it.

    Did you use and follow the guides on here? If you have a custom recovery and can flash Roms then it sounds like you are rooted. Does your hboot screen say Revolutionary at the top, post your hboot screen details.
     
  4. l1ndon

    l1ndon Newbie
    Thread Starter

    Current:

    Bravo pvt1 Ship s-off
    Hboot - 6.93.1002

    Partition is as you said (1.5gb though) it was partitioned already from previous ROM - I did it through 4ext

    (I thought I had done hboot before the ROM?)
     
  5. saltire

    saltire Android Expert

    Looks like you're S-off, it does say Revolutionary above that? Try fastboot direct from Windows cmd prompt - see the adb/fastboot guide in all things root sticky (can ignore the adb for now). Once the SDK setup, phone in fastboot connect usb, type "fastboot devices" at cmd prompt (without quotes). If it returns serial no of phone then i'd re-download cmr2, check md5, and fastboot flash it.

    Other way would be to copy PB99 zip onto root of SD card and install through bootloader - make sure the filename is exact it case sensitive.
     
    l1ndon likes this.
  6. l1ndon

    l1ndon Newbie
    Thread Starter

    Just reading and processing what you wrote...

    in the mean time, it used to say Revolutionary at the top yesterday, and now says Alpharev!
     
  7. l1ndon

    l1ndon Newbie
    Thread Starter

    Im not familiar with what you advised (SDK etc) so just reading about it

    Also, maybe I already had the modified windows hboot drivers installed for some reason
    and according to what I read (by SUroot), you can use unrevoked 3.31 to do 2.2.2

    I think maybe it changed from saying REvolutionary toAlpharev when I flashed the Bravo stock patched hboot
     
  8. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    I think that huy_lonewolf's post is the answer to your bootloop problem.

    If the ROM has a system larger than 145MB it won't fit in the CM7r2 hboot. So if you are running a stock ROM, you will get a bootloop if you flash CM7r2 correctly. You need to either install a smaller ROM before changing hboot, or change hboot, then boot into recovery, wipe everything (system, data, cache) and install the smaller ROM. You always need to check compatibility (i.e. /system size) before flashing ROMs with different hboots.

    Where I disagree slightly is how to flash hboot: I prefer to use fastboot commands from the computer (directly, not via some program like fastboot commander or android flasher), though the PB99IMG method does in my experience work fine.
     
    l1ndon likes this.
  9. l1ndon

    l1ndon Newbie
    Thread Starter

    I was thinking along similar lines, and was going to flash the CM7 after I had installed the RSK Rom (which works with it), but couldnt get the wifi working.


    Would you say that in all likely hood, the problem with the wifi not working is unrelated to the problems I had s-offing? Maybe just a kernel that my phone doesnt like for some reason

    thanks for all the help guys
     
  10. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    The WiFi is trickier as there are more things it could be. If you restored WiFi settings from a backup then try clearing them and re-entering by hand. Or it could be something with that particular ROM (one I've not used).

    I doubt the WiFi problem is related to S-Off. That replaced your hboot but doesn't change the actual android software at all, and the problem is with a ROM that wasn't even on the phone when you ran revolutionary.
     
  11. saltire

    saltire Android Expert

    Ah can ignore what I posted, I read your first post as you couldn't flash hboots full stop - not you can flash hboot but then couldn't install Rom. Different problem. You should still read up on fastboot via cmd prompt anyway ;)
     
  12. l1ndon

    l1ndon Newbie
    Thread Starter

    Thanks again guys, I figured out what you were saying Saltire, another way to flash an HBoot...also read the stuff

    I think I need to try a few more things and then report back my findings...

    I'll see if I can get WIFI working with different Rom/kernel combinations, and then once thats fixed try and flash the CM7R2 (with an appropriate Rom for that partition)

    Lindon
     

HTC Desire Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...