1. Are you ready for the Galaxy S20? Here is everything we know so far!

Computer doesn't recognize the new sd card

Discussion in 'Android Lounge' started by OzymandiasX, Aug 21, 2012.

  1. OzymandiasX

    OzymandiasX Lurker
    Thread Starter

    I have an Optimus Elite. But that shouldn't matter. I placed the card inside and the phone does recognize it. I've connected it through the usb cable and the computer only spots the 2 gb card which came with the phone.

    I've placed data on the 2 gb card before. I haven't the slightest clue what the problem could be.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. ExtremeNerd

    ExtremeNerd Android Enthusiast

    It could be a corrupt card. It may happen if it's a "budget" SD card. Try it in another device, and if it doesn't work. exchange it for a different one.
     
  3. OzymandiasX

    OzymandiasX Lurker
    Thread Starter

    That's a bit rash. Is SanDisk a budget company?

    I'm not an expert on this matter, but perhaps I have to do something else after I've placed the card into the phone? Maybe change a setting.
     
  4. ExtremeNerd

    ExtremeNerd Android Enthusiast

    If you bought it off amazon in bulk packaging, it may be a bad card. It happens, and I've personally made that mistake. If you bought it from a store, I would just exchange it and hope for the best. Once you mount the SD card, there should be no settings to change.
     
  5. dan330

    dan330 Extreme Android User

    there is nothing you need to do.. other than mount the card, which it should do automatically. if you put it in a PC and it works fine. Most likely it is bad.

    you can try to format the card in the phone or in a PC.. see if this fixes it.

    other wise.. it needs to go back for repair.
    Here is the good news.. Sandisk has lifetime warranty!
     
  6. Liamo_210

    Liamo_210 Android Expert

    Not being sarcastic but did you try taking the sd out and putting it back in again
     
Loading...

Share This Page

Loading...