1. Are you ready for the Galaxy S20? Here is everything we know so far!

Computer says Device (As in my Phone) has Malfunctioned?

Discussion in 'Android Help' started by RaeanneMoriarty, Jan 27, 2016.

  1. RaeanneMoriarty

    Thread Starter

    Hi. I have a bit of a problem I am completely lost with...

    Bit of a backstory. Three months ago I was given a Refurbished Samsung Galaxy Avant with a one month warranty. It worked perfectly; computers recognized it and allowed me transfer files, Odin saw it (though I didn't do anything with it. I still had the warranty to wait out first), everything. Now skip forward two months.

    My warranty is finally over. I got excited (all the bloatware on the thing was beginning to drive me nuts) and plugged in my phone to load it on Odin. But then Windows gave me an error: Your device is not recognized or has malfunctioned. (yadadada. Don't want to write the whole thing.). Confused, I did what every good techie does: I googled my problem. The results all said the same thing: try a new port, try a different cord, do you have drivers installed? etc.

    I tried everything. I restarted my phone, restarted my phone in the stock recovery and cleared the cache, tried changing dialer settings to adm or mtp or both, I restarted my computer, I tried all my USB ports, I tried all my usb cords, tested my usb cord and ports by plugging in another phone (which it recognized properly without any difficulty.), I uninstalled and reinstalled drivers. I even went as far was factory resetting my phone and reinstalling Windows 10 (which was annoying, but I needed to anyways), to not avail. Getting desperate, I tried booting into my Ubuntu installation. Ubuntu didn't recognize it. I tried my other PC I have (running Windows 7), got the Malfunctioned error again. I even tried my late 2013 iMac (which is a completely different post I could rant about). Nothing is recognizing my phone, and I am at my wits end with what to do, if anything.

    I tried taking it back to where it was purchased from, but they told me they can't do anything about it. It was two months past warranty and it charges just fine. Computers just won't recognize it or the internal SD card.

    TL;DR- My phone will not be recognized by ANY computer, regardless of OS, with or without drivers. Kies is not installed, nor Android Transfer (in the case of my iMac), and I am at my wits end. What can I do, if anything?

    Any help whatsoever will be helpful and story for all the information! I just wanted to make sure I didn't miss anything... Thank you! <3
     



    1. Download the Forums for Android™ app!


      Download

       
  2. SavageRobot

    SavageRobot Android Expert

    So if you plug it in, switched on in MTP mode you can still see the phone and go through it in file explorer? Did you reinstall drivers again on W10 and same error?
    Do you need to be in Download mode to run Odin? I think if so it needs to install drivers again, or that's the experience I've had in the past. Try plugging it in in download mode and see if it runs driver installation again maybe?
     
  3. Slug

    Slug Check six!
    VIP Member

    Another thing to try...

    Install KIES, reboot PC, then uninstall it. The Samsung hardware driver(s) should remain installed, and may solve the issue.

    You do, iirc. A restart with POWER+HOME+VOL_DOWN pressed should put it into Download Mode, then open Odin, connect via USB, and the COM indicator should turn green. (It's been a while since I flashed a Sammy h/s so my memory might be hazy :oops:)
     
  4. RaeanneMoriarty

    Thread Starter

    @Slug I've downloaded and installed the drivers (both in Win10 and Win7, since I just finished flashing another phone the night before), so I'm 99% sure it isnt drivers. When I try to connect my phone to the computer for Odin, my phone is in Odin download mode, yet it will either not be recognized or Windows will throw the Malfunctioned error.

    @SavageRobot
    Windows will not recognize my phone. So I can't see it in File Explorer or anything. Ive gone to device manager and it called it an unknown device. I had it search for drivers and it claims it has the most updated driver. My Ubuntu installation, which normally installs drivers automatically, won't see or mount the phone or the sd card when plugged in. (Even after driver install)..
     
  5. Jfalls63

    Jfalls63 Android Expert

    You could check Settings in USB hidden menu. On you phone keypad dial *#0808# and it should take you to the menu. Should look like this. If selections are the same tap OK to leave menu.
     

    Attached Files:

  6. RaeanneMoriarty

    Thread Starter

    @Jfalls63 I have done that and that is exactly what it looks like.
     

    Attached Files:

  7. Jfalls63

    Jfalls63 Android Expert

  8. RaeanneMoriarty

    Thread Starter

    @Jfalls63 I just tried it both (with and without the sim card), and still nothing. I ought to mention that my phone does recognize the computer, as it said "connected as a media device" but Windows still claimed it has malfunctioned. I'm really lost here...
     
  9. Jfalls63

    Jfalls63 Android Expert

    Only thing I can think of is something being wrong with the USB port on phone. Hardware.
     
  10. RaeanneMoriarty

    Thread Starter

    Grand. -.- I was afraid of that. Warranty won't cover that (I asked), and I can't afford to get it fixed right now...

    Even though it charges just fine? Or is its battery and internal storage different when it comes to plugging it in? Sorry, still a (kinda) newbie to Android.
     
  11. Jfalls63

    Jfalls63 Android Expert

    I think charging only uses two of the pins on the connector. Others are for actual transfer of data. One other thing I can think of would be to connect to pc with phone off then boot the phone. Seems you have tried every recommend fix I have been able to find.
     
  12. Jfalls63

    Jfalls63 Android Expert

    Do you have USB debugging enabled in developer options? You might try switching it on/off.
     
  13. RaeanneMoriarty

    Thread Starter

    Tried that too, the switching debugger mode on/off. I'll try the other one later when I can get back on my main computer.

    Thank you anyways! <3
     
  14. argedion

    argedion The TechnoFrog

    have you tried linux and motochop?
     
  15. RaeanneMoriarty

    Thread Starter

    I've tried Linux, but I have no idea what motochop is.
     
  16. strabo231

    strabo231 Newbie

    I can almost guarantee the problem has nothing to do with your phone.

    DO NOT CONNECT PHONE TO PC FOR ANY REASON ONCE YOU START THIS GUIDE!! I will notate which step it is okay to connect it again.

    To complete your first few steps (the uninstall steps, I'd suggest Revo Uninstaller, there's a free version, or a free 30 day trail of Pro... link here for free version: http://www.revouninstaller.com/start_freeware_download.html

    Now use Revo, not uninstaller in control panel, to uninstall everything. When Revo opens, you should see uninstall menu option top left selected, and all installed programs on the screen below. Select program to uninstall, then screen will pop up reading "Select an Uninstall Mode". Under normal circumstances Moderate is fine, but in this case you will want to choose Advanced. Follow instructions on screen. Repeat process for each item: Samsung Drivers, Samsung Kies. Restart PC.

    Next, hit the start button, and type Samsung into the search box. Delete all files and folders that come up, excluding backups you might have or firmware files. Restart PC

    Now go into start menu, right click on computer, then left vlick properties. Look top left and select Device Manager. Delete all "unkown devices" under USB in Device Manager.

    Now finally you'll need to run a cleaner to remove registry items and misc leftovers. If you don't have one, I'd suggest CC Cleaner...free version here: http://www.piriform.com/ccleaner/download

    Now here under the cleaner menu on the right, be sure to uncheck anything you want to keep...cookies, passwords, internet history, etc. Run cleaner, then select registry option at bottom. Because of what youre trying to accomplish with the drivers, when it asks if you'd like to backup before continuing, I would select no. Registry backup under normal use is fine, but in this case you don't want the backup reverting to driver or registry errors. When you;ve run the cleaner, and the registry repair tool, restart the PC.

    Now you'll need to reinstall Samsung Kies: http://www.samsung.com/in/support/usefulsoftware/KIES/

    Now once you have reinstalled Kies, go ahead and connect your phone. Now your drivers should be recognized and phone should connect. It is suggested that you uninstall Kies if experiencing problems with ADB, Odin, ect. If that's all running fine there's no need.

    Should you need/want to uninstall kies, you'll want to uninstall Kies, but keep the drivers. In this instance, don't use Revo, just use the regular uninstaller from Windows control panel
     
  17. steve

    steve Developer
    Administrator

  18. RaeanneMoriarty

    Thread Starter

    Okay, I'll try that when I get the chance.

    Thank you guys so much anyways! <3
     
    steve likes this.
  19. Lokahi117

    Lokahi117 Lurker

    Ummmmm any word on whether or not any of the above solved your problem? Usually people come to these forums to get an answer, but then when it's fixed they disappear and never tell anyone if it got fixed or what solved it.
     
  20. RaeanneMoriarty

    Thread Starter

    Okay, so really late reply, but I thought I might as well update. Apparently my phone has a faulty USB port and I don't have any way to fix it. Using Kingoroot, I managed to root my phone then promptly changed it to SuperSU. I then used System App Remover (Root) to get rid of those bloatware apps I hated so much. Finally, using Flashify, I flashed TWRP.

    Searching XDA I did find a ROM for it, but it is a bit outdated. However, it still works, and it is what I am using right now until I can get around developing my own, when and if that may be.

    Thank you guys for your support and ideas anyways!! <3
     
    mikedt likes this.
Loading...

Share This Page

Loading...