1. Download our Official Android App: Forums for Android!

Root Confused

Discussion in 'Android Devices' started by dha, Nov 20, 2011.

  1. dha

    dha Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 20, 2011

    Nov 20, 2011
    1
    0
    5
    Hi. I don't understand the instructions for rooting. This is mostly because I don't understand much about computers, which I blame on social norms for girls and boys. Anyone want to help me out?

    Step 1: Check the checkbox for USB Debugging.
    So far I'm good.

    Step 2: Make sure you have a fresh SD card in.
    Still good.

    Step 3: Install the necessary driver (one for windows/xperia play, and one for casio commando)
    This is where I get lost. Am I doing this on my laptop? On my breakout?
     

    Advertisement

  2. IndyRoadie

    IndyRoadie Member
    Rank:
    None
    Points:
    36
    Posts:
    63
    Joined:
    Feb 24, 2010

    Feb 24, 2010
    63
    7
    36
    Beech Grove, Indiana
    Its the phone driver for your computer they are talking about. Which method are you using? SuperOneClick worked great for me...
     
  3. terabyte128

    terabyte128 Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    121
    Joined:
    Nov 7, 2011

    Nov 7, 2011
    121
    14
    38
    When you connect your phone to your computer, if it is running Windows, the phone should show up as a CD named VERIZON MOBILE. In there, there is a pdf which gives instructions on how to install the phone drivers. Follow that and you should be good to go. Remember that you also do need to have USB debugging enabled for adb to work.
     
  4. sthrnsqrl

    sthrnsqrl Newbie
    Rank:
    None
    Points:
    36
    Posts:
    25
    Joined:
    Nov 3, 2011

    Nov 3, 2011
    25
    1
    36
    I installed the usb drivers, set the debug option, connected the phone, and yes, like you stated, it showed up as a Verizon CD...then, the USB drivers kicked in, and it reverted to *removable Disk*.

    What am I doing wrong?
     
    LegendTW likes this.
  5. LegendTW

    LegendTW Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 6, 2012

    Jan 6, 2012
    1
    0
    5
    Sthrnsqrl,

    I thought I'd answer your question, since by asking it, you answered my question. I have the same phone as you and was having the exact same issue. You do indeed need the drivers for the phone and those drivers are indeed actually on the device when you plug it in via USB. And yes, they disappear just as you said. Same thing happens on mine. I actually didn't know they were there at all until you asked why they were disappearing.

    The only way I've found to get these drivers is to be REALLY fast when the drive pops up. The only file you actually need is the file called "PTAPC_V1_1_6_0630.msi". You have just under 20 seconds to copy it. I figured this out by coping the "USB_driver_installation_guide_v0.5.pdf" file which told me which files to grab. The file is small, so you have time to copy it.

    I hope this helps.
     
  6. crane321

    crane321 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Mar 7, 2012

    Mar 7, 2012
    7
    0
    5
    Hi im new to rooting but decently good with computers. i have a pantech breakout from verizon. i have tried to root my phone for 3 days but have major problems along the way right now i am stumped on how to fix the "Helions with blue fire !" problem while rooting my phone. after this problem is finished i believe i will need the su binaries. sadly i do not believe i have the su binaries because i didnt download them hahaha. also i have updated my breakout and i am using the zergRush exploit. thank you and good rooting
     

Share This Page

Loading...