1. Are you ready for the Galaxy S20? Here is everything we know so far!

Connected to WiFi but can't send texts

Discussion in 'Android Devices' started by chilenofutbol, Jul 23, 2013.

  1. chilenofutbol

    chilenofutbol Lurker
    Thread Starter

    When I try to send a text a message pops up saying "No cellular network available. Connect to an available Wi-Fi Network for messaging." I pull down the menu and see "Wi-Fi Networks Available". I click on it and it shows that I am connected to my home network, yet my phone doesn't seem to recognize the connection. I'm not sure what to do.

     


  2. Best Answer:
    Post #3 by funkylogik, Jul 23, 2013 (1 points)
  3. Droidunited

    Droidunited Member

    Don't be ridiculous. You can't send text messages (sms) via wi-fi! you need a good 3G/4G signal in order to do that. How many bars do you have on your phone? Also you may want to connect with your carrier to see if there is a cell tower outage in your area.

    Also..if you're trying to send like a Google message or a Facebook message that's when you'll need wifi or data connection.

    If you're trying to send a MMS picture message you also need a good 3G/4G signal.
     
  4. funkylogik

    funkylogik share the love peeps ;)

    I dont think "dont be ridiculous" is called for. There are no ridiculous questions here. Thats not how we roll :thumbdown:
    He is right though. SMS uses a cellular connection. There are messenger apps that can send through wifi though if the other person has the app installed too :)
     
  5. RobDeVora

    RobDeVora Lurker

    I know it's a little late but I've been looking up the same issue.

    Firstly let me say that correct or not the issue in question is still incredibly relevant. For the past month I'll see quick pop ups in the status bar stating "no wireless network available connect to wifi for messaging." Just tonight the same message popped up as I drove through an area where I experience a 30-60 second long service drop. Only difference is it was in a direct message over my texting window needing "OK" to be selected. In retrospect I should have screenshoted it.

    As side information I've recently been having trouble with SMS and MMS when connected to wifi. It's hit and miss with receiving and sending both when connected. When disconnected to wifi it's flawless on TMOBILE 4G LTE.

    Any information would be greatly appreciated. I'll update for future problems people may have if I find anything useful.
     
  6. Muilisx

    Muilisx Android Expert

    Actually, regular sms doesn't use data, it uses regular network, so even when on wifi, your texts should still work, and even if you were sending a text that was long enough or contained a photo that required data, even when on wifi, your 3g/4g should still kick in to send the message, and then the data stops again. That's how its been for every Android I've ever owned.
     
  7. Dustin Adams

    Dustin Adams Lurker


    Yah, I definitely don't think it's ridiculous when thats what the phone tells you.. Some people..
     
  8. HumanJHawkins

    HumanJHawkins Lurker

    5 years after the original "don't be ridiculous" response... Guessing that was meant as a joke. Anyway, what is truly ridiculous is that SMS was not automatically bridged to TCP/IP by 2005... The fact that it still isn't has moved from ridiculous to ludicrous... Laughably absurd.

    For others finding this, hopefully someone will post an android-focused solution. In the meantime, if you have a Windows 10 PC, you can simply add people to your "People " app (Windows contacts). Then type "Text Joe Smith" into Cortana for example to text the Joe Smith in your People app.
     
  9. mikedt

    mikedt 你好

    Yup, SMS is very much a GSM legacy from the 1990s. Maybe ridiculous, but that's how it is.

    That would be Outlook or MSN messaging wouldn't it, and the party you want to message must be an MSN or Outlook user as well? An advantage of SMS of course, is you only need to know their phone numbers. All contacts I know use Wechat, so that's how we usually message each other.
     
    #8 mikedt, Oct 10, 2017
    Last edited: Oct 10, 2017
  10. I had the same problem go to settings go to wifi the switch on and off "wifi calling" make sure its not "darkened" (unable to switch on or off) when you switch it off, and it immediately took the issue away an i can send my messages with wifi on or off in accordance with my data being switched on. Hope this helps drop a like if it did. Same message did pop up now it will not.
     
  11. Malazdragon

    Malazdragon Lurker

    Wi-Fi calling must be on. Agreed
     

Samsung Galaxy S3 Forum

The Samsung Galaxy S3 release date was May 2012. Features and Specs include a 4.8" inch screen, 8MP camera, 1GB RAM, Exynos 4412 Quad processor, and 2100mAh battery.

May 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...