1. Are you ready for the Galaxy S20? Here is everything we know so far!

connected to wifi but no internet

Discussion in 'Android Devices' started by andreid31, May 5, 2013.

  1. socrates0

    socrates0 Android Enthusiast

    Since you bought the unit recently I guess that it’s still in warranty, any chance that it can be exchanged for a new unit? You could always say all gadgets have a problem connecting to it. Try connecting you laptop too just to be sure. I don’t know where you are based (I am in India) I use an old D-Link ADSL modem (DSL 502T) in conjunction with a Linksys WRT 54G wifi router both antiques now. But when I had suspected a problem with my modem I had rung up their service center in Mumbai & they were v helpful (but that was long ago). Unless their helpdesk can figure out the problem & give a solution, replacement could be the only option left – unfortunately. Before you ask for a replacement try using a borrowed router & see if it works in your environment.
    BTW this router works on the 2.4GHz is there any gadget close by which works on the same frequency eg: microwave oven, cordless phone especially the high powered type. These could interfere with your connection but it should have allowed a connection. These cause interference but never know it too prevent a connection. You could switch off these gadgets while trying out your router connection.
     


  2. andreid31

    andreid31 Newbie
    Thread Starter

    i just wanna tell you guys that it worked..i don't know why i just left it for 3 days without doing anything because i was a bit frustrated.on 3rd day tested and it worked..this one's really weird. i am just so happy and thankful for those who helped. thanks. have a nice day all.
     
    ocnbrze and Marcha like this.
  3. Marcha

    Marcha Well-Known Member

    Ghosts roaming around or something, haha! I appreciate you telling us that it works now, whatever may have caused the problem. Hope it will stay that way. Enjoy!
     
    ocnbrze likes this.
  4. socrates0

    socrates0 Android Enthusiast

    Good to hear that its now working. N'joy :)
     
    ocnbrze likes this.
  5. TheMindy2011

    TheMindy2011 Lurker

    Good lord, thank you! I have been trying EVERYTHING to get my internet to work, and lo-and-behold, THIS WORKED! :D
     
    ocnbrze likes this.
  6. Marcha

    Marcha Well-Known Member

    Quote:
    Originally Posted by Marcha [​IMG]
    One very simple thing I forgot. Did you set a homepage for your internet settings? It's so obvious that it's easy to forget, but without homepage the browser simply won't know where to go. ;)

    Good lord, thank you! I have been trying EVERYTHING to get my internet to work, and lo-and-behold, THIS WORKED! :D

    Haha, sometimes it's so easy to overlook what can be so obvious. Glad that this solution worked for you.
     
    ocnbrze likes this.
  7. gracie99

    gracie99 Lurker

    Hi. I have the same problem. It is in my home network settings.

    The Android phone and tablet wifi access works perfectly on other networks. Network: Motorola Surfboard cable modem, very fast; router Linksys E1200; extender router: NetGear WN2500RP.

    The problem started a couple of weeks ago. It followed no change in any setup on phone or network settings.

    Just want to be clear: this is a network problem. It also affected my Vizio smart TV when I looked at its network settings. It requested my network password. Put it in repeatedly, but no change. Lost that connection too.

    Should I contact LinkSys? Is the E1200 the most likely bad player? The Surfboard is ethernet; needs ethernet connector to wireless router. Connection between wireless router and wireless repeater is fine.

    I've seen many, many solutions offered here, and tried some. No phone fixes worked. Need a network fix.

    Thank you for any information steering me in the right direction!
     
  8. LelandIA

    LelandIA Lurker

    I've also been having this "connected to WiFi but no internet" problem for the last couple of months (intermittently at first but progressively getting worse) but I'm pretty certain it is a problem with my ISP's (Mediacom) domain name system (DNS) servers and not my phone or my WiFi router. My WiFi router settings have not changed during that time (or for months previous to it). My android phone and my android tablet both connect to the Internet via WiFi without any problem anywhere else but at home. Also any WiFi access from my android devices within my local home network works without any problem.

    I also have a Windows 8 tablet that occasionally reports DNS server problems when trying to access the Internet via my home network but not anywhere else. That device also works without any problem within my local network.

    It is getting to the point where I'm seriously considering changing my ISP, even though I've been with Mediacom (or its predecessors) for about 15 years, because they seem to have become utterly incapable of fixing their DNS server problems.

    Edit 2/7/2015: I thought I'd add that I discovered the problem I was having and it actually was a problem with my router, which had somehow gotten the DNS servers to use set incorrectly. As soon as I fixed that, I'm no longer having any problems with my android devices connecting to the Internet at home. I have absolutely no idea how my router settings got messed up like that but fixing them fixed my problem. :oops:
     
    #33 LelandIA, Jan 17, 2015
    Last edited: Feb 7, 2015

Samsung Galaxy Ace Forum

The Samsung Galaxy Ace release date was February 2011. Features and Specs include a 3.5" inch screen, 5MP camera, 278GB RAM, Snapdragon S1 processor, and 1350mAh battery.

February 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...