1. Are you ready for the Galaxy S20? Here is everything we know so far!

Connecting Droid Turbo 2 to Computer via USB

Discussion in 'Android Devices' started by Zach Polovchik, Nov 19, 2015.

  1. Zach Polovchik

    Thread Starter

    Hey, I've had my Droid Turbo 2 since release day and have been liking it for the most part. Yesterday, though, I decided I wanted to connect it to my laptop to get some pictures off of it and throw some other files on it. On all my other phones, all I had to do was connect it to my computer via USB and a little folder would pop up under Devices and Drives and I could see everything on the phone (music, photos, files, etc.). Now when I connect the Droid Turbo 2, nothing on my computer pops up. All it does is charge the phone (quite slowly I might add, but that doesn't bother me). I've tried multiple USB ports two different computers.
    Any suggestions?
    Thanks!
    Zach

     


  2. Best Answer:
    Post #15 by Tim McDermott, Oct 23, 2016 (1 points)

    1. Download the Forums for Android™ app!


      Download

       
  3. gordon55

    gordon55 Lurker

    I've had the same issue, several times.
    Although in my case the computer would recognize the fact that the phone was attached, when I opened the phone in windows explorer no files were found.

    I kept uplugging the usb cable from the laptop and plugging back in until my laptop 'saw' files on the phone.
     
  4. Zach Polovchik

    Thread Starter

    So I decided to try another USB cable laying around and this time the computer saw the phone and I can access/view all my phone's files on my laptop now. So I guess only some USB cables are able to do this? News to me. Hopefully if anyone else has my same problem, a different USB cable will solve it for them too.
     
  5. It sounded like a bad cable in the initial description. In the case where it sometimes works ... I would check to see if the cable plug or socket is corroded or dirty making a poor contact sometimes and a good contact other times.

    Another really odd thing ... I have been moving files from my Turbo to my Windows 7 machine to my Turbo 2 and back again. Sometimes a file I added on the first phone is not seen on the PC. The solution is to power off/power on the phone and reconnect to the PC. The files are then visible.

    There is some initialization of the file structure that is only happening during the boot process.

    ... Thom
     
    #4 Thom, Nov 19, 2015
    Last edited: Jun 30, 2016
  6. kmf

    kmf Android Enthusiast

    I've been using the USB cable that came with my Turbo 1 turbo charger. It is rather odd that our new turbo charger cable is not also a USB cable.
     
  7. SNeitzel

    SNeitzel Android Enthusiast

    I agree that it sounds like a bad cable. I do know that charge only (no data) USB cables do exist because I have one.
    But you really have to look hard to find one. I cannot see why Moto would purposely include that type of cable.

    The one I have has a single USB plug with 4 different plugs on the other end: micro USB, mini USB, Apple dock and Apple lightning. Works great for those times when a friend needs a quick charge and doesn't have a cable, to throw in the car as a spare or in the travel bag. But again, no data is transmitted on any of them. Also, you can actually charge multiple items at once with it but things charge veeeeery slow.
     
  8. rolandx

    rolandx Member

    I'm having trouble connecting my Turbo 2 to my computer (Windows 10).

    Never mind figured it out. Turned off the Software Installation switch on the USB computer connection screen.
     
    #7 rolandx, Nov 20, 2015
    Last edited: Nov 20, 2015
  9. rtrout

    rtrout Lurker

    Same here. Droid turbo 2. connect with usb cable. select the MTP option. open explorer. internal files show, but sd card shows as blank. all files I want to transfer is on the external sd card. why is it showing as empty? camera setting are selected as stored on sd card. ES File explorer shows as the files on sd card. but not coming up with cable connection
     
  10. Use only high quality USB cables. Keep the cheap ones for charging.
     
  11. Anusien

    Anusien Lurker

    I'm having a similar problem, but it's not related to cables. I have two Droid 2 Turbos (one is a replacement from Verizon to hopefully fix some speaker issues). They're running the same version of the OS and everything. If I plug the new one in, I can see it with adb devices and it will prompt for USB debugging. The old one won't connect. I've tried PTP and MTP, and I've tried two separate computers: one running Win7 and one running Ubuntu. I've tried putting the old phone into safe mode, rebooted, changed cables, changed USB ports, cleaned the cache, blown compressed air into the port, nothing.

    When I first got this phone I was able to connect via USB debugging because I did a backup restore onto this one.
     
    #11 Anusien, Sep 16, 2016
    Last edited: Sep 16, 2016
  12. rdsok

    rdsok Android Enthusiast

    When you can't connect to a device ( the D2T in this case ) on your PC and other devices connect using the same cable and port on the computer.... the only cause can be the device's USB port itself is bad or dirty. Simple logic and process of elimination.
     
  13. There is also the possibility of rust accumulating in the USB socket on the phone. Scraping with a wooden toothpick followed by compressed air flushing might correct it.

    ... Thom
     
  14. Anusien

    Anusien Lurker

    The only conclusion I've come to was a bad USB port. Maybe some of the data pins got damaged but the charging pins didn't?

    The toothpick thing is a good idea, I'll try that. Thanks!
     
  15. Tim McDermott

    Tim McDermott Lurker

    This began for me soon after a recent phone update. Here is how I solved this problem; in my situation:
    >Keep phone connected to the computer using USB cable
    >Go to phone "Settings"
    >Find and select "Developer options" on the settings menu list
    >Choose "Select USB Configuration" - Mine was (and should be) set to "MTP (Media Transfer Protocol)"
    >Temporarily instead, select, "Charging" from the list
    >Once changed, again re-select "Select USB Configuration"
    >Change back to the original "MTP (Media Transfer Protocol)" from the list
    >As was my case, all was then recognized by the computer and my files/folders on the phone were now visible on my Windows based file window.

    Hope that helped someone. It worked for me. -Tim
     
  16. (G)

    (G) Android Expert

    Can't find "Developer Options" for the life of me... Any idea where it's hiding?
     
  17. scary alien

    scary alien not really so scary
    VIP Member

    Go to Settings -> About phone -> scroll down to Build number -> tap/touch that row 7 times and a toast should appear saying you are now a Developer.

    Hit the back button to the main Settings display and you'll now see that you have Developer options just above the About phone row.

    :)
     
    doogald likes this.
  18. Tim McDermott

    Tim McDermott Lurker

    ...and, as peculiar as that sounds, if you don't initially see the Developer options toward the bottom of your Settings list, you do indeed need to perform the above stated oddity.
     
    scary alien likes this.
  19. rdsok

    rdsok Android Enthusiast

    It is not an oddity... the option was deliberately hidden for good reason
     
  20. (G)

    (G) Android Expert

    THANKS! Worked. I had no idea that existed.
     
    scary alien likes this.
  21. greengranite

    greengranite Lurker


    Thanks Tim!!! That worked!!!
     
  22. Paul Lovett

    Paul Lovett Lurker

    Thanks Tim!!! I've been to the Verizon store, on-line with Dell, and Google searched EVERY possible way of trying to fix the problem; and your way fixed it in 30 seconds! Now,,, got any ideas on how to replace the hair I pulled out trying to find the solution!?! Thanks again!
     
    scary alien likes this.
  23. scary alien

    scary alien not really so scary
    VIP Member

    Thank you for signing-up and replying to this thread, Paul--that was very kind of you! :)

    Now to your other question, although it's a bit out of my Android knowledge-zone, you might want to check-out:

    upload_2017-1-10_15-6-37.jpeg

    :D ;) :p

    Cheers!
     
  24. Paul Lovett

    Paul Lovett Lurker

    Thanks for the humor Scary Alien! Your AndroidForums are already bookmarked and will be my first place to look next time I have a problem. Thanks again! And thanks again to Tim McDermott!
     
    scary alien likes this.
  25. shari tyler

    shari tyler Newbie

    I had this same problem. This is what you do. You connect your phone to your PC, just like you were doing. Then you go to your phone at the top and swipe down, and it will give you options to choose. Choose USB. Select File Transfers.


    Here are the directions when I googled it:
    Connect the device to a computer using the supplied USB cable.
    1. If necessary, touch and hold the Status bar (area at the top of the phone screen with the time, signal strength, etc.) then drag to the bottom. The image below is only an example.
    2. Tap the USB icon then select File transfers.
     

Motorola Droid Turbo 2 Forum

The Motorola Droid Turbo 2 release date was October 2015. Features and Specs include a 5.4" inch screen, 21MP camera, 3GB RAM, Snapdragon 810 processor, and 3760mAh battery.

October 2015
Release Date
0
Reviews
Loading...

Share This Page

Loading...