1. Download our Official Android App: Forums for Android!

Support Connecting to Wifi Network with a Hidden SSID

Discussion in 'Android Devices' started by Legato, Jul 16, 2010.

  1. Legato

    Legato Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    43
    Posts:
    132
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    132
    25
    43
    Telecom Switch Tech
    Milford MA
    Anyone have a problem connecting to a network with a hidden SSID? My wife can connect to our router fine with her Droid INc (wireless N router). But i can't unless i enable broadcasting the SSID. I found the hidden SSID enabler app, and going to try that. If that doesn't work does anyone else have any ideas? If i enable SSID broadcast i connect right away. If i disable it, i lose the connection and it is "out of range". Very annoying as i live in a condo unit with 10 other wifi networks in my range. Would like to keep my netwrok as private as possible.

    Any help would be greatly appreciated. Thanks

     

    Advertisement

  2. swagner53

    swagner53 Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    291
    Joined:
    Dec 4, 2009

    Dec 4, 2009
    291
    62
    53
    Strange- I had no trouble connecting to my hidden network at home.
     
  3. bc6droid

    bc6droid Member
    Rank:
    None
    Points:
    15
    Posts:
    30
    Joined:
    Jun 29, 2010

    Jun 29, 2010
    30
    0
    15
    Check this thread out

    Question About WiFi Settings - Android Central Forums
     
  4. Veritech

    Veritech Member
    Rank:
    None
    Points:
    16
    Posts:
    44
    Joined:
    Apr 30, 2010

    Apr 30, 2010
    44
    6
    16
    So. Cali
    Yup having the same problem. Got a hidden SSID on my home router and it won't connect either (out of range). Hopefully someone comes up with a trick lol.
     
  5. AJ_EVO

    AJ_EVO Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    573
    Joined:
    Jun 8, 2010

    Jun 8, 2010
    573
    114
    93
    Orange County
    I don't broadcast the SSID on my home network and I connected just fine. You can't have any typos. I believe even the SSID is case sensitive.
     
  6. Bonez

    Bonez Well-Known Member
    Rank:
    None
    Points:
    88
    Posts:
    214
    Joined:
    Jul 4, 2010

    Jul 4, 2010
    214
    144
    88
    Indiana
    Everything is case-sensitive. The SSID and the password are all case-sensitive. ;)
     
  7. dookie1

    dookie1 Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    236
    Joined:
    Jun 25, 2010

    Jun 25, 2010
    236
    9
    36
    yup...problems with hidden.

    it worked once, then never again. i changed nothing on the phone, just enabled ssid broadcast at the AP, and voila...connects consistently.

    for the record, this is with an enterprise-class avaya (proxim) AP, using 802.1x authentication to a corporate LAN.

    hopefully something addressed in .604?
     
  8. SonicBoom

    SonicBoom Well-Known Member
    Rank:
    None
    Points:
    53
    Posts:
    106
    Joined:
    Jul 22, 2010

    no problem concecting to my hidden WPA2PSK home network, corp networks hidden PEAP MSCHAPV2 is a nightmare though, unable to connect to it no matter what i try
     
  9. SonicBoom

    SonicBoom Well-Known Member
    Rank:
    None
    Points:
    53
    Posts:
    106
    Joined:
    Jul 22, 2010

    change your hidden SSID to something super easy like abc123 just for testing then see if you can connect, if you connect then you are messing up something in your SSID like a space or a capitalized letter or something.
     
  10. mtwalsh367

    mtwalsh367 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jul 28, 2010

    Jul 28, 2010
    1
    0
    5
    I was using a hidden SSID with my Droid just fine for months with an older linksys G router. I just upgraded to a new linksys N router, model E3000. I set the new router up identical to the old router, including the hidden SSID and all of a sudden my phone says out of range. I don't have an issue with 2 different laptops, just the Droid. I changed the SSID to be broadcast and all of a sudden it works great. Change it back to hidden and its out of range again. Has to be some compatibility issues for some router models I presume. Very frustrating.
     
  11. Martimus

    Martimus One bite at a time...
    Rank:
    None
    Points:
    843
    Posts:
    19,535
    Joined:
    Jul 9, 2010

    Jul 9, 2010
    19,535
    4,045
    843
    Male
    Engineer
    'neath a cactus
    I use a hidden SSID on my home network. The DX won't always automatically connect to it. What I've found seems to remedy the situation is to manually force it to connect. I went to the "Add WiFi network" selection under WiFi Settings. I then manually added my SSID including it's encryption type and password. When the DX didn't automatically connect to the SSID, I then went to "Manage Networks" under WiFi settings and clicked on the SSID I had previously added. It then connected to the network.

    It's a bit of a work-around but it's much preferable to dealing with the slower 3G data rates.
     
  12. ZXMustang

    ZXMustang Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    330
    Joined:
    Apr 15, 2010

    Apr 15, 2010
    330
    10
    38
    Earth
    Yes. Mine is hidden too. Just add it manually. And also make sure you dont have MAC filtering on. If you do, you will need to get into the router setup and add the mac address to the list before it will connect even if you have the SSID and Password.
     
  13. Legato

    Legato Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    43
    Posts:
    132
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    132
    25
    43
    Telecom Switch Tech
    Milford MA
    SSID cannot have spaces. ;) I type it fine, i quadrupled checked everything. Everything is set up fine, just won't connect when SSID isn't broadcast, enable broadcast and it connects immediately. So i know it's done right if it connects when broadcast, cause it wouldn't connect then either if something was typed wrong.

    Just leaving SSID broadcasting for now. Hoping the next update to 2.2 will fix this. I have MAC address filtering on, but once again, set up right or i wouldn't be able to connect at all, whether SSID is broadcasting or not. Just doens't like my router i guess
     
  14. Eryl Flynn

    Eryl Flynn Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    311
    Joined:
    Feb 22, 2010

    Feb 22, 2010
    311
    16
    38
    Do your routers use 802.11n? I heard some where that the X is having some issues with .11n networks.
     
  15. Legato

    Legato Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    43
    Posts:
    132
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    132
    25
    43
    Telecom Switch Tech
    Milford MA
    Yep, i use N. I read that too. :( Sad
     
  16. bkendall

    bkendall Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Aug 2, 2010

    Aug 2, 2010
    1
    0
    5
    So, this seems to be an interesting problem - I have found that with my hidden wireless network at home with my incredible, when I just turn on wifi it does not connect, but if I go into the wifi settings where it lists the networks and scroll down so that my network is on the screen. Then the phone sees the network and connects right to it - works most every time - don't know why!
     
  17. SgtBaxter

    SgtBaxter Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    189
    Joined:
    Jul 17, 2010

    Jul 17, 2010
    189
    15
    38
    Mine does the same thing, if I just turn on wifi it won't connect to the network, I have to go into wifi settings then it connects right away.

    Last week on vacation at the hotel with a broadcast SSID it would connect automatically. I think it's an android issue, not phone specific.
     
  18. aguillon5

    aguillon5 Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    107
    Joined:
    Nov 14, 2009

    Nov 14, 2009
    107
    3
    36
    I believe that your router is dual band make sure that wirelss g is enabled you can set up same security in both bands but I would change ssid a little to be able to connect your wireless n devices to proper band.
     
  19. jadepro2002

    jadepro2002 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 18, 2011

    Mar 18, 2011
    1
    0
    5
    In my case the quick fix was to ensure that the ssid being entired was the same case as the one your router was broadcasting. Can you believe the stupid device was actually case-sensitive. When I entired my ssid on my droid the first character was being capitalized, switched it to lower case after giving myself a headache and it connected even though it was hidden.
     
  20. pool_shark

    pool_shark Android Expert
    Rank:
     #81
    Points:
    343
    Posts:
    2,509
    Joined:
    Aug 21, 2010

    Aug 21, 2010
    2,509
    566
    343
    Male
    Enterprise Server Engineer
    Ohio
    Hidden SSIDs don't really provide any extra security.
     
  21. arttd

    arttd Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 7, 2012

    Jan 7, 2012
    1
    0
    5
    I had to take my router out of mixed "N" mode. When I set it to 802.11 B & G mode only, my EVO 4G connects to my network, hidden or visible just fine. If I add in N mode, it craps out and says the network is out of range if it's hidden. It can only connect to "N" node when the ssid is visible. So, just set your router to "Mixed B & G Mode", hide your ssid, and you should be fine. Hope it work for everyone.
     
  22. douglasck

    douglasck Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    May 18, 2015

    May 18, 2015
    1
    0
    15
    Male
    I had the same problem. Luckily I was a Senior Information Management specialist for Xerox so I know a few tricks from the old days before I became disabled. I had to go in and set up my new phone manually for my network, hence my coming across this thread.

    First part for a hidden network is to unhide the network long enough for it to detect your device. Once that happens and you can connect to the network, go into your router, find the android device and set a manual static IP address for your device. Next, hid the network SSID.

    Manually add the android device to your router using exactly what case and password you need. You should have the option of expanding the information that is required to include the static IP address that you assigned with the router, what kind of security you are using, and any other information it needs including the password in the expanded Wi-Fi setup on your android device.

    Enjoy your device and happy computing to you all.
     
  23. Synackz

    Synackz Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jan 18, 2013

    Jan 18, 2013
    2
    0
    5
    Male
    Sr. Network Engineer
    DFW
    Hey guys,

    I stumbled across the answer to this last night.

    For some reason, if you select "show password" when you type it in, it works.


    I did this because I knew I was typing the characters correctly. Just had a feeling that the combined ASCII value was somehow being changed when the password was hidden since it seems to affect certain devices in different ways.
    This was reproducible and is probably a problem with the version of the OS. Please reply back and let me know if this worked for you too.
     
  24. Paulus123

    Paulus123 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 12, 2016

    Dec 12, 2016
    1
    1
    5
    Male
    Solution, that worked for me:

    1. Turn "broadcast SSID" on the router on.
    2. Connect your Droid to the network.
    3. Disconnect the Droid (turn off WiFi).
    4. Turn "broadcast SSID" off (hide your network).
    5. Turn on the WiFi on the Droid.
    6. Find the SSID of your network in the list of WiFi networs on the droid (it will be saved there but will show it as "not available").
    7. Click on the SSID and then "forget".
    8. Now "add network" manually typing in the SSID and password.
    9. Enjoy the hidden connection ;).

    Android "remembers" all networks you have been connected to. If you connected to a visible network first and than have hidden it Android still has it in the list but marks it as a "not available" network. If you now try to add the hidden SSID you create a conflict: You are trying to connect Android to a network that is "not available" according to its list. It won't work.
     
    Zokambaa likes this.
  25. Zokambaa

    Zokambaa Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    May 31, 2017

    May 31, 2017
    1
    0
    15
    I don't know if other devices have similar settings but I had the exact same issue with my Galaxy s8... my s4 had no issues.

    I noticed that the s8 had an option for FT Key Management in the Advanced settings.

    I could connect fine without this on if the SSID was broadcast, however as soon as I hid the SSID, my S4 connected fine but the S8 wouldn't connect.

    With the FT Key Management option enabled, I could connect on my s8 with the ssid hidden.

    I have a cisco cable modem gateway if that makes any difference too.


    But after trying the process listed in the previous message, that too worked... so I may go with that going forward.



     
    #25 Zokambaa, May 31, 2017
    Last edited: May 31, 2017

Share This Page

Loading...