1. Check out our app, Forums for Android! Download and leave feedback here!

connection sharing issue in damageControl 2.0 Rom

Discussion in 'Android Devices' started by wonka816, Apr 30, 2010.

  1. wonka816

    wonka816 Member
    Thread Starter
    15

    Dec 6, 2009
    16
    0
    15
    I keep getting sign in error saying that my Sprint username and password are incorrect when I attempt to do connection sharing with my pc
     

    Advertisement

  2. ejpyle

    ejpyle Well-Known Member
    36

    Mar 12, 2010
    122
    6
    36
    What are you using for a username/PW?
     
  3. brandonpaz

    brandonpaz Well-Known Member
    16

    Apr 29, 2010
    73
    4
    16
    Tampa
    I received the same error but only when I disabled Wireless networking, while connected.

    I dont think mobile networking supported for tethering in DC 2.07.2?

    Paz
     
  4. nenn

    nenn New Member
    5

    May 3, 2010
    2
    0
    5
    im in the same boat, why not just use wifi-tethering? works great.
     
  5. ejpyle

    ejpyle Well-Known Member
    36

    Mar 12, 2010
    122
    6
    36
    works fine for me.
     
  6. brandonpaz

    brandonpaz Well-Known Member
    16

    Apr 29, 2010
    73
    4
    16
    Tampa

    I get an IP from wifi tether, but it appears dns is not working. I have a dns server but I can not browse webpages or perform an NSlookup.

    I can ping the default gateway and I do get good results.

    Brandon
     
  7. DFRESH

    DFRESH Well-Known Member
    88

    Dec 26, 2009
    559
    39
    88
    The Bay Area SF/Oak
    you getting the error because connection sharing doesn't work on DC 2.07 ..but works great in 2.08.
     
  8. brandonpaz

    brandonpaz Well-Known Member
    16

    Apr 29, 2010
    73
    4
    16
    Tampa
    I am runninng 2.08. When I try to use default 2.08 sharing, with out wifi connected I get an error with a sprint username or password.

    So this lead me to try Wifi Tether. I get an IP but no dns.

    Brandon
     
  9. DFRESH

    DFRESH Well-Known Member
    88

    Dec 26, 2009
    559
    39
    88
    The Bay Area SF/Oak
    hmmm weird...i was just using Network Sharing last night for the hell of it....
     
  10. Squiggy

    Squiggy Well-Known Member
    38

    Mar 2, 2010
    360
    18
    38
    Web Developer
    San Diego, CA
    Try enabling access control in Wifi Tether and put a check mark (within the wifi app) next to each computer trying to access the wifi.
     
  11. brandonpaz

    brandonpaz Well-Known Member
    16

    Apr 29, 2010
    73
    4
    16
    Tampa
    I tried it with and with out access conrol, I am able to get an IP both ways.

    I can still ping the default gateway.
    ipconfig /all shows my dns.

    I still cant do any NSlookups or surf the web

    It was a little weird now when I did my nslookup, rather than using the default gateway for dns, it was using local host 127.0.0.1.

    Anybody else having similar issues, or have ideas? I am going to be in a hotel tommorrow and would really like to have network :)

    Thanks in advance,

    Brandon
     
  12. Squiggy

    Squiggy Well-Known Member
    38

    Mar 2, 2010
    360
    18
    38
    Web Developer
    San Diego, CA
    I only know what works for me. On my phone, I click on the "Press to start tethering" button. Once that starts, I can see the network on my PC. I select that wireless network. I then go to Access control, which needs to be enabled, and select my PC. Once I do that, I've got internet access.
     
  13. brandonpaz

    brandonpaz Well-Known Member
    16

    Apr 29, 2010
    73
    4
    16
    Tampa
    I do the exact same thing, and I get an IP, but it is not surfable.

    aka dns does not work properly.
     
  14. brandonpaz

    brandonpaz Well-Known Member
    16

    Apr 29, 2010
    73
    4
    16
    Tampa
    I did a cat on /etc/resolv and found the dns used by the phone
    4.2.2.5
    4.2.2.4
    4.2.2.3
    4.2.2.2

    and I tried to manually used these via my laptop and it did not work :(

    any other ideas?
     
  15. brandonpaz

    brandonpaz Well-Known Member
    16

    Apr 29, 2010
    73
    4
    16
    Tampa
    I tried "fix permissions" in clockwork

    So much for a permissions issue, Chmod (771) ftl

    I am running out of ideas

    Brandon
     
  16. brandonpaz

    brandonpaz Well-Known Member
    16

    Apr 29, 2010
    73
    4
    16
    Tampa
    squiggy can you please connect for me, and from your computer run these two commands

    ipconfig /all
    nslookup www.google.com

    Please paste the output here
     
  17. Squiggy

    Squiggy Well-Known Member
    38

    Mar 2, 2010
    360
    18
    38
    Web Developer
    San Diego, CA
    Here you go:


    Microsoft Windows [Version 6.1.7600]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.

    C:\Users\Owner>cd C:\android-sdk-windows\tools

    C:\android-sdk-windows\tools>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : Owner-PC
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Wireless LAN adapter Wireless Network Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Realtek RTL8191SE Wireless LAN 802.11n PC
    I-E NIC
    Physical Address. . . . . . . . . : 00-26-B6-43-A9-FA
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::940:fb67:4776:860a%12(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.2.100(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Thursday, May 06, 2010 10:43:35 AM
    Lease Expires . . . . . . . . . . : Thursday, May 06, 2010 10:46:47 PM
    Default Gateway . . . . . . . . . : 192.168.2.254
    DHCP Server . . . . . . . . . . . : 192.168.2.254
    DHCPv6 IAID . . . . . . . . . . . : 301999798
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-12-80-2C-0E-00-1E-33-FE-3E-BE

    DNS Servers . . . . . . . . . . . : 192.168.2.254
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Realtek PCIe FE Family Controller
    Physical Address. . . . . . . . . : 00-1E-33-FE-3E-BE
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.Belkin:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{5CB84958-CC96-4BB0-A8E6-50AB9A6F795F}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    C:\android-sdk-windows\tools>nslookup Google
    Server: UnKnown
    Address: 192.168.2.254

    Non-authoritative answer:
    Name: Google
    Addresses: 74.125.19.103
    74.125.19.99
    74.125.19.147
    74.125.19.104
    Aliases: Google


    C:\android-sdk-windows\tools>
     
  18. brandonpaz

    brandonpaz Well-Known Member
    16

    Apr 29, 2010
    73
    4
    16
    Tampa
    Thanks I have the same dns settings but nslookup does not resolve.

    I am stumped I will try a different laptop to see if my pc is the issue.
     
Tags:

Share This Page

Loading...