1. Download our Official Android App: Forums for Android!

Support Contact names not appearing in Messages

Discussion in 'Android Devices' started by sonesh, Jun 17, 2011.

  1. sonesh

    sonesh Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    43
    Posts:
    285
    Joined:
    Nov 2, 2010

    Nov 2, 2010
    285
    31
    43
    Coventry, UK
    This has randomly started happening since I "Cleaned up" my contacts. Fundamentally, my contacts are now based on Exchange, instead of phone, and most of the time this is fine, but from time to time, in messages, numbers appear, instead of names, for some people.

    If i create a new message, I can choose the contact and it'll show the name, but when I press send, it will file it under the persons thread, but still no name showing.

    Even if i click on the number, it shows "Open Contact", and if I click call, it'll shows the persons picture, so it knows this number belongs to a contact, but refuses to display the name or picture.

    Annoyingly, it only happens to the people I contact most often too.
     

    Advertisement

  2. samier

    samier Lurker
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Jun 6, 2011

    Jun 6, 2011
    9
    0
    5
    u might be saved them twice thats y its not showing..............
     
  3. sonesh

    sonesh Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    43
    Posts:
    285
    Joined:
    Nov 2, 2010

    Nov 2, 2010
    285
    31
    43
    Coventry, UK
    Each contact has (linked) an exchange contact, a phone contact and a facebook contact. All i can think of is something is getting broken when the exchange contacts sync, but i'm not changing anything and its not affecting everyone.

    I've just restarted and its fixed everything, but this is the 2nd time I've had to do that this week
     
  4. RED_

    RED_ Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    209
    Joined:
    Nov 13, 2010

    Nov 13, 2010
    209
    8
    36
    Student
    London
    I've just noticed that this has happened to me, as you say a simple restart and everything is fine again.

    I had a big problem with contacts when i formatted my phone. Google decided to get all the people I was following on twitter and add them to my contacts(WTF?! My twitter isn't even linked to gmail. This all happened while i was on my laptop, nothing to do with the phone until ofcourse i turned it on and they all synced to my phone.).

    So essentially I had to delete all my gmail contacts, delete the contacts I restored from a backup and then use the same backup to put my normal contacts back onto my phone hoping that gmail will see it and store them as my normal contacts. Anyway that worked but i still had to link all my gmail contacts with my phone contacts but i think everyone has to do that anyway (Hopefully someone can let me know if thats true.. does everyone have to do that?).

    There's always something wrong with the stock message app isn't there? I had a problem in Froyo where it was delaying notifications or even not letting me know at all until i went into the message manually. GB fixed that but hopefully this doesn't carry on.
     
  5. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #5
    Points:
    3,118
    Posts:
    31,695
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    31,695
    23,278
    3,118
    Scotland
    There does seem to be. I've heard there are issues with the delete key in GB too...
     

Share This Page

Loading...