1. Download our Official Android App: Forums for Android!

Root Contact pictures not showing in HTC Messages app

Discussion in 'Android Devices' started by mattots, Jul 29, 2010.

  1. mattots

    mattots Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    25
    Joined:
    Mar 31, 2010

    Mar 31, 2010
    25
    0
    15
    Since I started installing custom ROMs on my Desire, the contact pictures have been missing in the HTC Messages app. They show up fine everywhere else, just in Messages I see the default grey contact icon all the time.

    I initially thought it could be a bug specific to one of the ROMs I installed but it's happened with AdamG's 'official' Froyo Sense ROM and Paul's MCR Custom ROM r5 which I'm currently running (actually, I've installed 2 slightly different 'bakes' of this and the problem is there in both).

    I've tried asking about this on XDA and MoDaCo in the relevant ROM threads but not had any luck. Just wondered if anyone had any idea at all what could be causing this and how to fix it, or at least find out why it's happening.

    As I said, its literally just in the Messages app that it's happening - everywhere else contact pics show up just fine.

    Hoping someone has some clues as to what's going on!
     

    Advertisement

  2. Tunga

    Tunga Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    174
    Joined:
    Jul 14, 2010

    Jul 14, 2010
    174
    27
    43
    Not exactly a fix but have you looked at Handcent SMS? I'm yet to find anything about the Sense Messaging app that I prefer to Handcent and it may not have this issue.
     
  3. mattots

    mattots Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    25
    Joined:
    Mar 31, 2010

    Mar 31, 2010
    25
    0
    15
    Just installed Handcent and it has the same issue - just shows the grey default icon. So its not not the app itself that's to blame it would seem. Very odd. Need someone with a bit more of an understanding of the internal workings of the os to shed some light on this.
     
  4. mattots

    mattots Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    25
    Joined:
    Mar 31, 2010

    Mar 31, 2010
    25
    0
    15
    Oddly, contact pictures DO show up in SMS Popup. I also just tried Chomp sms and they work in that as well. However, I would still like to get to the bottom of this.
     
  5. DesirableHTC

    DesirableHTC Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    234
    Joined:
    Apr 27, 2010

    Apr 27, 2010
    234
    11
    38
    iPhone breaker
    Leeds UK
    i have the same issue mate, i used chomp SMS before rooting, but after first root i found that i was sending out double messages even though i was only sending one from chomp....? But as for the contact pics in SMS app, i just don't have a scobby!
     
  6. chaosbringer

    chaosbringer Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 20, 2010

    Sep 20, 2010
    1
    0
    5
    Having that issue on my HTC droid....if anyone found a fix. please update me.
     
  7. miguelsilva

    miguelsilva Lurker
    Rank:
    None
    Points:
    8
    Posts:
    2
    Joined:
    Jan 13, 2011

    Jan 13, 2011
    2
    20
    8
    1 - Go to the market and download a terminal emulator (there are several free ones)

    2 - Open the terminal emulator and type the following:

    su
    chmod 666 /data/data/com.android.providers.contacts/files/*

    This changes the permissions on the contacts folder. I had this problem after rooting and messing around with Titanium Backup and this solved it.
     
  8. miguelsilva

    miguelsilva Lurker
    Rank:
    None
    Points:
    8
    Posts:
    2
    Joined:
    Jan 13, 2011

    Jan 13, 2011
    2
    20
    8
    Actually the problem wasn't cause by Titanium backup, it was caused by ROM Manager. Using the "Fix Permissions" option causes this problem on the Desire.
     
    DodgerinNH likes this.
  9. foobar66

    foobar66 Member
    Rank:
    None
    Points:
    16
    Posts:
    40
    Joined:
    Dec 20, 2010

    Dec 20, 2010
    40
    2
    16
    Fantastic. I had the same problem after "fixing permissions in ROM Manager". I spent already 1 day searching for a solution ...

    Thanks, m8
     
  10. kkoolpatz

    kkoolpatz Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 26, 2011

    Jan 26, 2011
    1
    0
    5
    Registered just to say thank you. - Dont know if it means much to you but its a great feeling when you type your problem into google and the first link is your solution.
     
  11. AidanZealley

    AidanZealley Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Feb 6, 2011

    Feb 6, 2011
    1
    0
    5
    When I type the second line it says 'No such file or directory'
    Any ideas why and what I can do to make it work?
    Thanks

    EDIT:

    I rebooted the phone and tried the command again and it worked. My problem is fixed now.
    Thanks @miguelsilva :)
     
  12. ajmoncrieff

    ajmoncrieff Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Feb 23, 2011

    Feb 23, 2011
    1
    0
    5
    Worked perfectly! Thank you very very much
     
  13. androidisforporn

    Rank:
    None
    Points:
    36
    Posts:
    143
    Joined:
    Oct 4, 2010

    Oct 4, 2010
    143
    5
    36
    Also had this issue on HTC Thunderbolt, thanks for the help everyone!
     
  14. stroja62

    stroja62 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Apr 21, 2011

    Apr 21, 2011
    4
    0
    5
    i cant get this to work. r those spaces supposed to be before and after 666. how do i imput it
     
  15. DoodleD

    DoodleD Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    80
    Joined:
    Jan 13, 2010

    Jan 13, 2010
    80
    8
    16
    Eastern PA
    Same question??? Is su on separate line? If so how do you move between them?
     
  16. DodgerinNH

    DodgerinNH Well-Known Member
    Rank:
    None
    Points:
    58
    Posts:
    208
    Joined:
    Apr 2, 2010

    Apr 2, 2010
    208
    23
    58
    Adhesives
    SE New Hampshire

    I just realized I had this problem yesterday on my Incredible. Followed the suggestions (a little nervously since I'd never messed around with a Terminal Emulator) And it worked!!!

    You're a genius, Miguel Silva!!!
     
  17. DodgerinNH

    DodgerinNH Well-Known Member
    Rank:
    None
    Points:
    58
    Posts:
    208
    Joined:
    Apr 2, 2010

    Apr 2, 2010
    208
    23
    58
    Adhesives
    SE New Hampshire
    "Fix Permissions" on ROM Manager is exactly what caused this. Great find and thanks again
     
  18. milkpowder

    milkpowder Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jun 7, 2010

    Jun 7, 2010
    3
    0
    5
    Great solution. Logged in just to say thanks.
     
  19. Rastaman-FB

    Rastaman-FB Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    6,113
    Joined:
    Sep 11, 2009

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    Tip

    DONT USE ROM MANAGER ON DESIRE
     
  20. pettenstein

    pettenstein Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    May 20, 2011

    May 20, 2011
    1
    0
    5
    This gives me the error that there is no such Directory.
    I checked and there isn't... It goes as far as /data/data/com.android.providers.contacts. The folder files/ does not exist...

    What does this mean, is this the whole problem. Or should I look for another fix?
     
  21. dbrook007

    dbrook007 Member
    Rank:
    None
    Points:
    15
    Posts:
    41
    Joined:
    Aug 13, 2011

    Aug 13, 2011
    41
    0
    15
    When I type the su and do a return, it says 'permission denied' ?

    Thx,
    Darren
     
  22. EMPSboo77

    EMPSboo77 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Aug 20, 2011

    Aug 20, 2011
    1
    0
    5
    just to add, and reassure users that when you go into the screen on the terminal emulator on my Htc desire HD... my blue screen has the following text on the screen (this is normal...)
    export PATH=/data/local/bin:$PATH
    $ export PATH=/data/local/bin:$PATH
    $

    so when you type the text in it will look like this
    $su (hit enter) and then type in the next line -(as other people have indicated you will get the text saying it is invalid etc -but this is okay as indicated and then you will power down your phone and restert).
    thought that I would clarify this thread.
     
  23. dbrook007

    dbrook007 Member
    Rank:
    None
    Points:
    15
    Posts:
    41
    Joined:
    Aug 13, 2011

    Aug 13, 2011
    41
    0
    15
    When i try it, it just says 'permission denied'
     
  24. jayroller

    jayroller Well-Known Member
    Rank:
    None
    Points:
    63
    Posts:
    102
    Joined:
    Sep 24, 2010

    Sep 24, 2010
    102
    26
    63
    Male
    South of Heaven
    Maybe a silly question, but is your phone rooted?
     
  25. Baldilocks

    Baldilocks Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,242
    Joined:
    Jul 18, 2010

    I'm having the same problem with my Galaxy S II. But I have no /files subfolder. This is driving me crazy!!
     
Tags:

Share This Page

Loading...