1. Download our Official Android App: Forums for Android!

Support Contacts all Unknown and Can't make calls

Discussion in 'Android Devices' started by primal100, Jul 22, 2013.

  1. primal100

    primal100 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Feb 13, 2013

    Feb 13, 2013
    3
    0
    5
    Hi,

    I have a Samsung Galaxy S3. Suddenly a few days ago all my contacts appear as unknown. I have them backed up to my google account (they are ok there) but I tried to merge and still the same.

    Also I can no longer make standard calls. When I dial a number and click call it goes back to the dial screen after a second. Interestingly when I go to Viber and select make standard call through carrirer, it works.

    From googling around it seems it might be due to an app. Is there a way to see what apps have access to my contacts or my normal phone dialer?

    Otherwise a factory reset might be my only option.
     

    Advertisement

  2. DonB

    DonB ♡ Truth, Justice and the American Way !! ♡ ™
    Moderator
    Rank:
     #15
    Points:
    1,983
    Posts:
    20,218
    Joined:
    Nov 30, 2009

    Nov 30, 2009
    20,218
    10,140
    1,983
    Male
    18th Hole Of the Golf Course
    Moved your post here for proper help and support.

    How long ago has this been happening, that might help in deciding which app could be causing this issue ? If all else fails then yes a FR will be the easier and quickest way to resolve your issue.

    One thing you can try is, login to your Gmail from a PC and check your contacts there and see if they are all there.

    If they are there that is good, then go back to your device and delete the Gmail account you have on the device, then go back to Goggle and setup the account again, and then let it sync again, and see if that brings them up.

    Another thing you can also do is go to applications, and look for Viber, make sure you clear out the default, to make sure that is not taking over your dialer as default. Then try your dialer again, cheers and report back.
     
  3. Petrah

    Petrah Psychotic Female
    Rank:
    None
    Points:
    333
    Posts:
    4,085
    Joined:
    Jun 13, 2011

    Jun 13, 2011
    4,085
    1,467
    333
    Female
    Annoying my X-Husband
    Hanover Park, IL

    A better option is attempting to see if it is indeed a rogue app causing the issue. The only way to find that app is via process of elimination. Uninstall 5 apps and write down their names, check to see if the problem persists. If it does, uninstall 5 more apps. Rinse and repeat till you've narrowed it down to the last 5 uninstalled apps. Reinstall each one of the last 5 apps, one at a time checking between each install to see if the problem is back. You'll narrow down the culprit this way.

    If that fails you may need to factory reset (unless you're rooted/romed, then do this via recovery).
     
  4. primal100

    primal100 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Feb 13, 2013

    Feb 13, 2013
    3
    0
    5
    Hi,

    Thanks for responses. DonB, what you suggested worked. Viber was set as the default for calls (must have done that by mistake). Interestingly it wasn't going to Viber when I attempted to make a call but instead nothing happened so probably an issue with Viber. Anyway I moved it back to use normal Phone by default and its working.

    For contacts, removing Google account, adding it again and re-synching fixed the issue.

    Thanks again
     

Share This Page

Loading...