1. Check out our companion app, Forums for Android! Download from Google Play

Support Conversations.apk / "Text Messaging"

Discussion in 'Android Devices' started by smallp0x, Nov 29, 2010.

  1. smallp0x

    smallp0x New Member
    Thread Starter

    Nov 29, 2010
    Hello everyone, pardon my ignorance but I seem to have an issue with restoring my stock conversations.apk, or the "text messaging" app. I accidentally uninstalled it after rooting my Droid X and I have been trying to get it back. I'm hoping I didn't screw myself.

    I was able to find a system dump back up but after it installs (conversations.apk that is) I can't get it to launch. I'll tap it's little icon, it'll appear to open, and then it'll just return me to my home screen. I was wondering if this was because I need to reinstall a service or something? All help is appreciated! :D

    Further info:
    My system version is 2.3.15.MB810.Verizon.en.US and my Android version is 2.2. I used Titanium Backup to uninstall the default apps, and then used APKInstaller from the market to reinstall the conversations.apk app.

    Of course right when I create a thread after 3 days of trying to figure it out, I do. For the sake of others, I'll tell you how I did it. First, go here for the default (2.3.15) apps:


    I downloaded the conversations.apk AND the conversations.odek file. Then I downloaded Root Explorer.

    I coped the conversations.apk, conversations.odek, and RootExplorer_2.12.4.apk onto my SD card. I installed Root Explorer using APKInstaller. I ran Root Explorer and used it to copy the conversations.apk and .odek to my system/app folder. Then I "long pressed" conversations.apk in Root Explorer and clicked on permissions. I checked all three boxes for user, and I did the same of the odek file. I rebooted my phone and wala, it worked... didn't even have to reinstall them!


  2. bradvanscoyk

    bradvanscoyk New Member

    Jun 12, 2012
    I did the same exact thing as you (uninstalled default apps like a newb) and now am trying to get it back to normal. I followed the same exact steps as you but it didnt work. Both the .apk file and .odek file are in my system/app folder and i successfully changed the permissions. I dont know what else to do? I tried installing the .apk file with apkinstaller and it gives me an error after trying to install for about a second saying *explamation mark* "application not installed"
    any idea what i could do? I also tried the same thing with the default mediagallery with no success... Please help

Share This Page