1. Download our Official Android App: Forums for Android!

Support Copilot Central not recognising Galaxy

Discussion in 'Android Devices' started by Sly712, Nov 25, 2010.

  1. Sly712

    Sly712 Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    9
    Joined:
    Jul 19, 2010

    Jul 19, 2010
    9
    0
    25
    Mobile Operations Analyst
    Sydney, Australia
    I have recently purchased a full version of Copilot 8 (with AU/NZ Maps) and downloaded Copilot Central for PC to manage Copilot.

    For love nor money can I get Copilot Central to see my Galaxy with Copilot on it. I have followed the instructions on the Copilot site to connect below:

    Getting the device Connected:
    1) Launch Central 2.0
    2) Log in with your SSO details (this is a must in order to
    download maps or purchase upgrades)
    3) Plug your android device to your PC through a USB cable
    4) On the device, drag the top bar down and tap on USB connected
    5) Select "Mount"
    6) You will see in Central your Device model (for android devices we just show "Android Device") and CoPilot 8 version"

    When I try step 4 and 5 my phone does not give me the option to "Mount".

    I have also tried changing the USB setting on my handset by going to Settings>About Phone>USB Settings and tried all the options (Samsung Kies, Media Player, Mass Storage, PC Internet and Ask
    on Connection). I can confirm that my PC can see the phone and Kies can also see the phone when connected to USB.

    I have contact Copilot Support and all they do is refer me to the instructions above!!! :(

    How do I get Copilot Central to recognise my device??? Anybody have an experience with this???
     

    Advertisement

  2. Sly712

    Sly712 Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    9
    Joined:
    Jul 19, 2010

    Jul 19, 2010
    9
    0
    25
    Mobile Operations Analyst
    Sydney, Australia
    Anybody???

    The muppets at ALK Tech just keep on referring me to the online FAQ :(
     
  3. letzter

    letzter Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 23, 2010

    Dec 23, 2010
    1
    0
    5
    Did you enabled in your network settings of your Samsung phone that it shall ask you if connected by USB which mode to use? It might be that you have set "use Kies always" and then it just won't ask you ... So you might want to try it.
     

Share This Page

Loading...