1. Download our Official Android App: Forums for Android!

Support Copying files changes the file date

Discussion in 'Android Devices' started by DougAJ4, Jun 8, 2011.

  1. DougAJ4

    DougAJ4 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jun 8, 2011

    Jun 8, 2011
    7
    0
    5
    Acer A500 with 3.01 O/S
    When I copy a file from my Windows computer via USB, or from a USB drive, to the Internal tablet memory (SD card) the file date and time change to the time of copying. This also happens with internal file copies.

    I have carried out the copy using the Windows file manager, the Android Astro file manager, and a beta copy of the Total Commander file manager, all with the same results.

    Is there any way to change this behaviour so the file date remains unchanged?
     

    Advertisement

  2. Dolmangar

    Dolmangar Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    257
    Joined:
    Feb 4, 2010

    Feb 4, 2010
    257
    14
    38
    Rational Tools Consultant
    DC Metro Area - USA
    Use XCOPY through a command window and you can retain attributes. This ofcourse only works when you're connected to a windows PC.

    For Example:
    C:\>xcopy filename.txt /K F:\target_directory\filename.txt

    You would need to set the target (second part) to the drive letter and directory of your tablet's drive. It may ask if the target is a file or directory, press "f" to specify file and it should copy.

    the /K option in XCOPY will copy attributes, in this case the file creation date is the one you care about.
     
  3. DougAJ4

    DougAJ4 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jun 8, 2011

    Jun 8, 2011
    7
    0
    5
    Dolmangar - thanks, that sounds promising, but when I connect to the Windows computer (Windows 7) it appears in "My Computer" as "Portable Devices(1) ... Acer ICONIA TAB A500", and does not have an associated drive letter.

    If I try "Map Network drive" it does not appear anywhere on the network, and if I open the properties dialog, it is all read only, so I can't see any way to assign a drive letter.

    Is there some settings I need to do on the Acer to make it visible to the Windows network perhaps?
     
  4. DougAJ4

    DougAJ4 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jun 8, 2011

    Jun 8, 2011
    7
    0
    5
    I was hoping this would be fixed in the 3.1 upgrade, but it seems not.

    Is there some way to retain the original file date/time when we copy files from an external source?
     
  5. DougAJ4

    DougAJ4 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jun 8, 2011

    Jun 8, 2011
    7
    0
    5
    I'd like to get some feedback on this.

    When I copy files from a USB drive the file date changes to the current date.

    Is there a way to change that behaviour, or is everyone else happy with it working that way?
     
  6. erpol

    erpol Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jul 13, 2011

    Jul 13, 2011
    1
    0
    5
    @dolmangar:
    - there is no drive letter attached to the iconia device, which forbids using xcopy, and
    - it's not the file creation date that's changed, but the file modification date, which is the one all file managers use for date sorting.

    I agree that this behavior is both abnormal and very annoying, especially so with photos as most (if not all) photo gallery browsers rely on the file modification date for sorting as well, not the "date taken" Exif field.

    This screws up my photo collections completely, the only alternative (that I won't contemplate for now) being to rename the files with some form of numbering...
     
  7. Dolmangar

    Dolmangar Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    257
    Joined:
    Feb 4, 2010

    Feb 4, 2010
    257
    14
    38
    Rational Tools Consultant
    DC Metro Area - USA
    I don't happen to have Windows 7 machine so I can't validate how to set the drive letter, however I assume that Windows is just being helpful and hiding it from you. I'm pretty sure that it has assigned a letter behind the curtain.

    Once you have you device attached, you can probably go to Manage (In Win XP, right click on "My Computer" and select Manage", not sure if the same process applies to 7). It should then start Computer Management (or 7 equivalent) window, where you should find something like "Storage" or Disk Management. My guess is that you would find the drive letter listed there.

    Although it's irritating that Explorer doesn't allow you to do this from the GUI, any time you copy or move files you are creating a new set of attributes (a move is really a copy with a delete). The xcopy /K option should retain all attributes (creation and modification date included).

    Hopefully this helps, I don't have a Win7 machine so you'll have to do some google searches to figure out your drive letter.


    ****Found something online
    To access Computer Management:
    Open 'Administration Tools', select 'Computer Management', click on 'Disk Management'
    This can also be done from the command line (or Run) "diskmgmt.msc"

    You should see your drive here, or you might have to go to removable storage.



     
  8. DougAJ4

    DougAJ4 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jun 8, 2011

    Jun 8, 2011
    7
    0
    5
    Thanks for the replies but:
    - If there is anything in Windows 7 that allows a drive letter to be allocated to the tablet, it certainly isn't obvious.
    - I really don't want to have to use XCopy anyway
    - Even if I could get XCopy working over a PC-Tablet link, it still wouldn't help with copying from a USB drive using the tablet software.

    When files are copied internally the file date is left unchanged, and that's the behaviour I'd like to see with files copied from external sources.

    Is there somewhere where this sort of issue can be raised with the people responsible for the software (whoever they are).
     
  9. Dolmangar

    Dolmangar Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    257
    Joined:
    Feb 4, 2010

    Feb 4, 2010
    257
    14
    38
    Rational Tools Consultant
    DC Metro Area - USA
    Sounds like someone needs to either write a new file manager app, or request an update to Astro, or OI. This could either be done by contacting the developers or probably over at XDA.

    What application are you using now to copy the file with a USB drive plugged into the tablet? Does Acer have a built in file manager that it's using?

     
  10. DougAJ4

    DougAJ4 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jun 8, 2011

    Jun 8, 2011
    7
    0
    5
    Dolmanger - I have tested with all of the following:

    Astro (file manager supplied with the tablet)
    File Expert
    File Manager HD
    ES File Explorer
    Total Commander (Beta)
    Also The Windows file manager copying from a PC over a USB cable.

    All work the same way.

    The author of Total Commander(Christian Ghisler) believes it to be an operating system issue, and since all the other programs give the same results that would seem to be a reasonable assumption.
     
  11. skyrail02

    skyrail02 Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Jul 5, 2016

    Jul 5, 2016
    1
    0
    15
    Paris
    Thanks Dolmangar for the tip.
    But it's not working with Airdrive on my Galaxy S5 under marshmallow not rooted, and windows7 with netdrive on PC.
    Everything is ready and working, but Xcopy keep copying files to internal memory without preserving file date.
    What is weird is: I can see date preserved for a few seconds, then it switch to current date.
     

Share This Page

Loading...