1. Are you ready for the Galaxy S20? Here is everything we know so far!

Corporate contacts appearing on my phone

Discussion in 'Android Apps & Games' started by brownbag68, Oct 13, 2014.

  1. brownbag68

    brownbag68 Member
    Thread Starter

    My work has an outlook exchange system and I have added my email (corporate) account onto my phone. I have never had contacts on this account synced and just checked to ensure this. Yet my corporate contacts seem to show on my phone in my contacts, even the 'Suggested Contacts'
    Has anybody else experienced this and is there a solution?
    Thanks.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. chanchan05

    chanchan05 The Doctor

    You mean the contacts app, or are they appearing somewhere else? You can change the display settings of the contacts app to change which ones appear.
     
  3. brownbag68

    brownbag68 Member
    Thread Starter

    I've tried two contacts apps and both are the same. I am using Contacts+ and it doesn't have that option - you can only change the 'custom view', but once you start typing in something to search (as I usually do), it selects from all contacts on the phone. In any case, they shouldn't be in the phone anyway, as I am not syncing my corporate contacts - only calendar and email. That is the real issue.
     
  4. RazzMaTazz

    RazzMaTazz Android Expert

    Just in case it helps... on the stock Android contacts app that I have:
    1) In the system account settings, you can choose whether or not to "sync" contacts from a given account. And...
    2) In the contact app's settings, you can also choose whether or not to "display" contacts from a given account.
     
  5. chanchan05

    chanchan05 The Doctor

    It depends also on how exactly did you disable sync in the first place. Normally, they would automatically sync the moment you logged in your corporate account. What app are you using to sync the email and calendar?
     
  6. brownbag68

    brownbag68 Member
    Thread Starter

    I'm not using an app to sync email and calendar. I just go to the corporate account in settings, click into it to go to the Sync page, and I tick Calendar and email, but not Contacts. I'm not doing anything unusual - just the standard method of syncing some components of the account but not others. That's why I am saying that it doesn't matter what app I use to look at contacts, the corporate ones shouldn't be there.
     
  7. chanchan05

    chanchan05 The Doctor

    I didn't see your phone model, but have you checked inside the email app? Depending on phone model, the email app has a setting for syncing contacts.
     
  8. brownbag68

    brownbag68 Member
    Thread Starter

    I'm using a OnePlus One with Paranoid Android 4.6 Beta.
    I'm using Aquamail - are you saying that some email apps can actually bring contacts into the phone. I can't see how the contacts can be synced by Aquamail if they are not even in the phone
    i.e., how can Aquamail access contacts if they aren't synced by the basic corporate account in the first place?
     
  9. chanchan05

    chanchan05 The Doctor

    Some email apps have an option to download and see the contacts on the account you connected it to. That's why I'm asking if you connected the email app to your account, or are you looking at your corporate mail via web access.
     
  10. brownbag68

    brownbag68 Member
    Thread Starter

    Yes, I have connected the email app to my account - I'm not using web access. I took a look and my app doesn't seem to have any option to download contacts.
     
  11. RazzMaTazz

    RazzMaTazz Android Expert

    From your home-screen.
    Go to System Settings->Accounts & Settings (or something similar depending on your OS version & phone).
    Click on the name of your corporate account.
    Uncheck "Sync Contacts".

    Even if you do this, the corporate contacts that have already synced may remain there. If so then you have 3 options:
    1) Delete each contact 1 by 1.
    2) Go into System Settings->Applications->Manage Applications-> All, and then find your "Contacts Storage" app and delete the data. Unfortunately that will delete ALL of your contacts but any of your cloud-based contacts (on Gmail, Hotmail, Facebook, etc.) will automatically re-appear within minutes or hours (depending on your connection speed and contact count).
    3) Leave your corporate contacts synced (taking up memory) but don't display them if they irritate you. Whether or not you can do this, and how you do this, depends your contacts app. On my phone with my stock Android contacts app, from the main screen of the contacts app, in the "Contacts" tab, I hit the settings button and then hit "Display Options". Then I select the account and check/uncheck the email groups.
     
    brownbag68 likes this.
Loading...

Share This Page

Loading...