1. Check out our companion app, Forums for Android! Download from Google Play

Root Corrupted Photos, this is getting old.

Discussion in 'Android Devices' started by toomuchrum, Sep 15, 2011.

  1. toomuchrum

    toomuchrum Member
    Thread Starter
    5

    May 31, 2011
    6
    0
    5
    I have a DX presently running 2.3. The same phone originally had 2.2 verizon and 2.2 APEX that I installed. In ALL instances, i've tried (3) different Micro SD Cards.

    Problem: Corrupted Photos.

    I can take 1 to 10 photos. WHILE in the camera app, after taking a picture I can click on the small thumbnail to view it (looks fine). Even after I take 10 pictures I can click on the small thumbnail (..and scroll through the pics I just took) and they look fine.

    It seems if I exit out of the camera app and try to view the photos through the Gallery app, most of the batch (usually all) are corrupted. When I say corrupted, I mean they don't show...I get the generic android camera and film icon. This usually happens (and this is the kicker) when the photos are REALLY important (shocker!).

    I've tried, 3rd party gallery apps, same result. I've tried, formatting the SDCARD, same result. I've tried DIFFERENT SDCARDS, same result. I've tried reading while hooked to a computer, same result (invalid image).

    Here is another kicker.. IF I view the photo (via thumbnail) just after I take it, AND select 'share' to Facebook/Picassa/etc. They upload just fine!!! BUT if, as mentioned above, I exit out of the camera app, then re-enter the gallery..they are corrupt!

    Something is seriously wrong here. It can not be the SD-Cards (tried 3). Just after taking the pics and viewing from the camera app, they ARE there! (can scroll through them all). Plus I've researched this problem via Google and there does not seem to be a straight answer to fix the problem.

    It's actually frustrating, I live in NE PA where all the flooding was and I took a drive today and snapped alot of pictures. While driving I would 'preview' them while in the camera app and they were fine. Tonight when I tried to view them/download them to the computer .... all gone ... not viewable.

    Funny thing is when I take pictures of the Dogs (here at my home) they are all fine, when I take them and days later. This leads me to think that there is something wrong with the GPS tagging/Location service for the photo. I'm not a expert or even a novice with the Android OS, but it seems logical.

    If anyone has any time to look into this or offer up some suggestions, I would really appreciate it!

    Thanks for your time...
     

    Advertisement

  2. pool_shark

    pool_shark Well-Known Member
    243

    Aug 21, 2010
    2,489
    541
    243
    Male
    Enterprise Server Engineer
    Ohio
    The gallery is touchy about how you delete photos. Do not delete photos using a file manager, only use the gallery. (this goes for the stock gallery).

    Gallery 3D doesn't care how you delete photos.

    Most people will tell you that any one of the 3rd party galleries are better, but I disagree because none of those allow you to rotate the pics with your fingers the way the stock gallery does.

    When your pics get corrupt, clear data in media storage.
     
  3. bigbadwulff

    bigbadwulff Well-Known Member
    143

    Jun 15, 2010
    2,442
    200
    143
    Rotate pics with fingers. Forgot it even did that. I have little need for it. But, if that happened to me(losing pics) and I was on a ROM that did that, I'd revert to something that didn't do it, like Froyo :)
     
  4. pool_shark

    pool_shark Well-Known Member
    243

    Aug 21, 2010
    2,489
    541
    243
    Male
    Enterprise Server Engineer
    Ohio
    It was a known issue on froyo, on both my D2 and the X. It came from deleting pics from file explorers instead of the gallery.
     
  5. darkcyber

    darkcyber Well-Known Member
    163

    Nov 12, 2009
    1,608
    151
    163
    Male
    North Alabama
    What rom was you on prior to Apex? Did you have this problem then? You might consider either doing a new install of Apex and see if that solves the problem or switch to a different rom.
     
  6. toomuchrum

    toomuchrum Member
    Thread Starter
    5

    May 31, 2011
    6
    0
    5
    Prior to Apex I was on stock Froyo. Then Apex 2.2, then stock gingerbread. I'm not sure about the stock Froyo (I upgraded to Apex 2.2 quickly), but Apex and stock gingerbread have done the problem (corrupted photos).

    Today while on the road, I snapped 2 pictures. While still in the camera, they previewed fine. I closed the camera app and opened up the Gallery app, both pic were fine. Closed Gallery app and then re-opened it, both pics were fine. Tonight I opened up the Gallery app and BOTH PICS ARE CORRUPT! So in the coarse of 5 hours, they went from fine to corrupt! I just don't get it.

    Is there a way to disable the photo location tagging???? I'd like to try that to see if it makes any difference.
     
  7. Bugly

    Bugly Well-Known Member
    143

    Jan 30, 2011
    1,057
    104
    143
    Male
    VW mechanic
    Tacoma, Washington
    personally, i would SBF the device, you can do that all the way to 2.3.3 (602) now, i think there is something wrong with your system apps.
     
  8. cookie_monster

    cookie_monster Well-Known Member
    78

    Jul 28, 2010
    548
    94
    78
    IOWA
    get a app called sd card rescan it will make them show up again
     
  9. colchiro

    colchiro Well-Known Member
    323

    Jun 4, 2010
    8,886
    1,784
    323
    Male
    Web developer/IT
    Make sure you safely disconnect your card from your computer when you connect via usb.
     

Share This Page

Loading...