1. Are you ready for the Galaxy S20? Here is everything we know so far!

Couldn't Get Rid of Write-Protected Files

Discussion in 'Android Devices' started by hamon456, Jul 8, 2018.

  1. hamon456

    hamon456 Lurker
    Thread Starter

    I couldn't delete mp4 files that are write-protected. My only attempt to delete them was on Windows Explorer and when I try to, it says:
    "Cannot delete filename.mp4: The storage is write-protected. Remove the write protection and try again."
    [​IMG]

    I wanted an offline version of a YouTube video, so I downloaded it from a third-party. However, it gave me useless write-protected mp4 files (unplayable videos) that does nothing but take up memory, thus I want to delete them from my tablet's internal storage.

    I'm willing to root my tablet if I have to. But if I do need to root my device, what root should I get, what are some advices for a novice, and what program/tool do I need to erase the write-protected files? Any suggestions and guidance are greatly appreciated!

    Information:
    1. The written-protected mp4 files are IN the internal Android storage, inside the Downloads folder.
    2. My device model number is SM-T230NU (Samsung Galaxy 4 7.0 Tablet)
    3. Android version: 4.4.2
     


  2. mikedt

    mikedt 你好

    What happens if you try to delete the file from the tablet itself using the stock Samsung Android file manager, rather than using a PC? Maybe Windows is seeing the tablet's storage as a read only device?
     
    Jfalls63 likes this.
  3. hamon456

    hamon456 Lurker
    Thread Starter

    I tried viewing the write-protected files in the "My Files" app (aka the file manager, I think), but they're still not visible even if I tick "show hidden files", hence why I used Windows Explorer to view the written-protection file.


    Here is me using "My Files" (or the file manager) on my Samsung Galaxy Tab 4:


    "Show hidden files" not enabled yet.
    [​IMG]



    This is the "Show hidden files" enabled:
    [​IMG]

    The write-protected files are still hidden, apparently. ^


    Plus it's not searchable using the search bar function in "My Files" app:
    [​IMG]



    I inspected its properties and the "Read Only" box is not ticked. The tick boxes are faded, so I couldn't do anything about it.
    [​IMG]



    Here's my Imgur album of me inspecting the file properties in Windows Explorer:
    https://imgur.com/a/ao4Cgd0
    It's probably irrelevant.
     
    #3 hamon456, Jul 8, 2018
    Last edited: Jul 9, 2018
  4. hamon456

    hamon456 Lurker
    Thread Starter

    I snooped on another forum thread and found the solution! I had to download Root Explorer to delete the write-protected files, and I did not need to root my tablet at all.

    Root Explorer app > Storage Tab > Download Folder > Select Write-Protected mp4 file > Trash Bin

    Imgur album - Root Explorer:
    https://imgur.com/a/kqetNw7

    Forum thread I stumbled upon:
    https://androidforums.com/threads/cant-delete-phone-files-write-protected.906780/

    App I used:
    https://play.google.com/store/apps/details?id=com.speedsoftware.rootexplorer


    EDIT: To make this more clear, my problem is resolved. I do not need any more assistance. :)
     
    #4 hamon456, Jul 9, 2018
    Last edited: Jul 9, 2018
  5. svim

    svim Extreme Android User

    Root Explorer is a fine file manager app (my favorite on rooted devices) but you could have used any file manager app to do the same. Root Explorer cannot magically act as a rooted app if your phone is not already rooted (in your situation all it was doing was functioning like any other, non-root file manager app). And just a side note, Samsung includes a basic file manager app on its devices, look in your app menu for the 'My Files' app. You could have also just used My Files.
    Conversely, rooting your phone will not allow Windows Explorer to gain root access on your Tab. Rooting relates only to the actual device you've rooted, it does not necessarily give anything you connect to your Tab root access. Also, Windows Explorer will still have very limited, restricted access to your Tab, rooted or not, which is why it couldn't remotely delete that file, it needed to be done locally as the Windows OS can only do a limited number of things to the file system used on Android devices.
     
    Dannydet and hamon456 like this.
  6. hamon456

    hamon456 Lurker
    Thread Starter

    I see.

    I did try using the "My Files" app. As mentioned before, the write-protected file weren't visible at all (as shown in the pictures). Nonetheless, thanks clearing things up with your thorough explanation.

    (I actually got Root Explorer for free anyway)
     
  7. svim

    svim Extreme Android User

    You need to enable the 'Show hidden files' option in the My Files app Settings menu.
     
    Dannydet likes this.

Samsung Galaxy Tab 4 7.0 Forum

The Samsung Galaxy Tab 4 7.0 release date was May 2014. Features and Specs include a 7.0" inch screen, 3MP camera, 1.5GB RAM, Marvell PXA1088 processor, and 4000mAh battery.

May 2014
Release Date
0
Reviews
Loading...

Share This Page

Loading...