1. Are you ready for the Galaxy S20? Here is everything we know so far!

Cross-platform alternatives to Family Link?

Discussion in 'Android Lounge' started by ChaunceyK, Sep 18, 2021.

  1. ChaunceyK

    ChaunceyK Member
    Thread Starter

    My daughter has a new LG Journey. We want to monitor and approve which apps she downloads and purchases she wants to make.

    The devices we would use to monitor her are an iPhone and a Chromebook.

    Can anyone recommend something other than Family Link? Prefer something free of course, but would definitely consider a paid app (pay once, not a subscription).

    Thanks in advance.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. svim

    svim Extreme Android User

    Just want to clarify if you're looking for an alternative to Google's Family Link specifically (assuming it's to avoid Google oversight or a feature issue) or is this just a matter about having a cross-platform service?

    If the latter, note that there is an iOS version of the Family Link app. Plus since you do need to create a new Google account for your daughter anyway to implement Family Link, you'll have access to it just by being able to log into that account from any device (Android, iPhone, Linux, Windows, Mac, etc.) if necessary.
    https://www.androidauthority.com/google-family-link-how-to-1067082/
    If the former however, is this an issue where you just don't want our Google overlords having that much more insight into your home life or is it some aspect to Family Link you that's an issue? If so, please state what that might be. If there's some specific functionality feature that might help suggest viable alternatives.
     
    Dannydet likes this.
  3. ChaunceyK

    ChaunceyK Member
    Thread Starter

    Sure, I can clarify.

    Daughter had an older Android phone with an earlier OS version. Family Link worked fine on it.

    Now with this new phone, we went through the setup process and all was fine until she signed into her Google account. It acknowledged she had the Family Link supervision, but then immediately got stuck at the home screen with "Android is starting." We tried this a couple of times, first signing in when asked, and then skipping sign-in until all updates were made. Both ways, it got stuck right after signing in to Google.

    I also tried it on one of my burner phones. Same OS version, same results.

    I suspect something went wrong in the latest Android OS update that's causing an incompatibility. Reason being (if you'll check my other post from today), my video calls went kaplooey after that same update on my main phone. Feels like two separate issues popped up with the latest update, at the very least (maybe other issues I haven't noticed, for all I know).
     
  4. svim

    svim Extreme Android User

    This does sound like there's some kind of glitch that's causing the authentication step of just lock up on itself. Could be some some kind of compatibility issue due to something like a system upgrade but that's a situation where you have an existing Family Link set up and implemented and then an operating system upgrade gets installed. Since this is a new phone, unless it was a matter where you had Family Link set up on it and then applied an OS version upgrade, a more likely occurrence is some config file became corrupted and it's a matter of getting past that.
    Try going into the Settings >> Apps menu on her phone, find and open the Family Link app entry, tap on Force stop, then find and tap on Clear data. Using Clear data will wipe the app's settings and config files, and the app's cache. This essentially returns the app back to its original first time used state so when you start the app up you need to go through the entire set up and configuration process again.
     
    Dannydet and puppykickr like this.
Loading...

Share This Page

Loading...